Bug 83258 - EDITING: Ctrl + Mouse scroll ball Zoom in and out reset viewing position to center
Summary: EDITING: Ctrl + Mouse scroll ball Zoom in and out reset viewing position to c...
Status: RESOLVED DUPLICATE of bug 83588
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.3.1.1 rc
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-29 21:07 UTC by Robert Gonzalez MX
Modified: 2014-10-21 18:33 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Gonzalez MX 2014-08-29 21:07:41 UTC
Problem description: 
In Draw, when using the combination of Ctrl + mouse scroll ball to zoom in or out, resets the position of viewing to the center of the sheet. This behavior wasn't present in 4.3.0.4

Steps to reproduce:
1. Create new draw file
2. Go to the botom of the sheet and draw a figure
3. use ctrl + mouse scroll ball to zoom in
4. when the figure is not visible, move with the scroll bar to center te figure in the viewing area
5. user ctrl + mouse scroll ball to zom in
6. The viewing position resets to the center of the sheet and the figure is not visible.

Current behavior:
Resets the viewing position to the center of the sheet

Expected behavior:
It should perform a zoom in with the current viewing position like when you do an horizontal scroll with Shift + mouse scroll ball.

This bug dificults the editing of the drawing.

              
Operating System: Windows 8
Version: 4.3.1.1 rc
Comment 1 A (Andy) 2014-08-31 08:25:41 UTC
reproducible with LO 4.3.1.2. (Win 8.1)
Comment 2 Robert Gonzalez MX 2014-09-04 02:21:24 UTC
Hello. 
Testing today with impress it behaves the same way. So i changed the component to Presentation.
I don't know if that right, but I think that this way will receive faster atention, because Impress have more development work.
Comment 3 Papamatti 2014-10-03 07:19:10 UTC
I can confirm this behavior with libreoffice 4.3.2 while scrolling with ctrl and mousewheel the screen viewpoint will always centered.
Zooming with the scrollslider behaves normally instead.
Comment 4 Yousuf Philips (jay) (retired) 2014-10-21 18:33:49 UTC
It has now been fixed in bug 83588.

*** This bug has been marked as a duplicate of bug 83588 ***