Bug 59925 - BASIC: Application terminates itself on string concatenation, if length of result string is expected to be > 64K
Summary: BASIC: Application terminates itself on string concatenation, if length of re...
Status: RESOLVED DUPLICATE of bug 38838
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: BASIC (show other bugs)
Version:
(earliest affected)
3.5.4 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-27 09:11 UTC by Vladimir
Modified: 2013-01-27 10:36 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir 2013-01-27 09:11:35 UTC
Problem description: Application terminates itself on string concatenation, if length of result string is expected to be > 64K

Steps to reproduce:
1. Run the example (sub):

'----------------------------------------

Sub Error__String__Concatenation__Application_crashes

	Dim aLength as Long
	Dim aString as String
	
	aString="1"

	While Len(aString)<100000
	
		aString=aString & aString
		
	WEnd 'aLength<1000000
	
	MsgBox Len(aString)

End Sub 'Error__String__Concatenation__Application_crashes

'----------------------------------------



Current behavior:
Application terminates itself.

Expected behavior:
Application reports about an error.
              
Operating System: Ubuntu
Version: 3.5.4 release
Comment 1 Julien Nabet 2013-01-27 10:36:37 UTC
Work in progress to remove this 64k limit.
More info here: https://bugs.freedesktop.org/show_bug.cgi?id=38838

*** This bug has been marked as a duplicate of bug 38838 ***