Download it now!
Bug 60060 - CONFIGURATION: Sections lose write protection if saved as docx
Summary: CONFIGURATION: Sections lose write protection if saved as docx
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.5.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:5.0.0
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-30 08:11 UTC by ernest
Modified: 2016-06-18 14:00 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Docx example, where the behaviour can be reproduced. 3 different sections have been defined, each time it is opened again, all sections will lose their write protected status. (11.56 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2013-01-30 08:11 UTC, ernest
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ernest 2013-01-30 08:11:29 UTC
Created attachment 73908 [details]
Docx example, where the behaviour can be reproduced. 3 different sections have been defined, each time it is opened again, all sections will lose their write protected status.

Problem description: 

Sections set as protected under write protection lose their write protection if they are saved as docx and opened again.

Steps to reproduce:
1. Insert, create a section in a document
2. check the write protection mode under sections
3. save the document as docx
4. close the document
5. open the document again, the sections are still defined but they have no write protection.

Current behavior:

Once the file is reopened the sections have lost their write protection and can be edited.

Expected behavior:

The section had to be protected from edition and keep the lock status.

              
Operating System: Windows XP
Version: 3.6.5.2 rc
Comment 1 Florian Reisinger 2013-04-21 15:09:02 UTC
I can confirm this with Version 4.0.3.1 (Build ID: a67943cd4d125208f4ea7fa29439551825cfb39) @ Win7 x64
Comment 2 QA Administrators 2015-03-04 02:20:58 UTC Comment hidden (obsolete)
Comment 3 Jean-Baptiste Faure 2015-03-15 16:14:37 UTC
Still reproducible with LibreOffice 4.4.3.0.0+ built at home under Ubuntu 14.10 x86-64.

Best regards. JBF
Comment 4 Commit Notification 2015-04-01 12:30:57 UTC
Eilidh McAdam committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=bb96ad0f9a24f92c8553da566f0ebedc064a1318

tdf#60060: DOCX export of section protection

It will be available in 4.5.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2015-04-01 12:31:00 UTC
Eilidh McAdam committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2813cfaae68af93b24bf4ecc1128f6647178f642

tdf#60060: unit test for docx section protection export

It will be available in 4.5.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 6 tommy27 2016-04-16 07:26:52 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (5.0.5 or 5.1.2 https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

- Update the version field
- Reply via email (please reply directly on the bug tracker)
- Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 

3. Leave a comment with your results. 

4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2016-04-16
Comment 7 Jean-Baptiste Faure 2016-05-01 08:15:23 UTC
I tried again with the current master:
1/ open the test file (attachment 73908 [details]) with the master (LO 5.2.0.0.alpha1+)
2/ Menu Format > Section
3/ Add write protection to the first section (TextSection), no matter if it is with or without a password
4/ save and close the file
5/ reopen the file:
   ==> the checkbox for write protection is gone but the section is marked read-only in the status bar
   ==> the second section (section1) is read-only too
   ==> the third section is missing in the Navigator but its contents is still there.

I guess that something is wrong in the first commit for this bug. 

Best regards. JBF
Comment 8 Jean-Baptiste Faure 2016-05-01 08:17:36 UTC
Removed target because the fix is incomplete and version 4.5.0 is outdated.
OS set to ALL because I tested under Linux.

Best regards. JBF
Comment 9 pietro.pangallo 2016-06-16 08:02:45 UTC
Fixed in:
Version: 5.3.0.0.alpha0+
Build ID: a8bd44573b75d1399257d6f5d052611439607189
CPU Threads: 2; OS Version: Linux 4.1; UI Render: default; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-06-13_23:46:49
Locale: it-IT (it_IT.UTF-8)
OS:openSUSE Leap 42.1 (x86_64)

status NEW -> RESOLVED WORKSFORME