Bug 60134 - FORMATTING: Can't change letter-spacing of fill signs in tabs
Summary: FORMATTING: Can't change letter-spacing of fill signs in tabs
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
(earliest affected) release
Hardware: All All
: medium normal
Assignee: Not Assigned
Depends on:
Blocks: TableofContents-Indexes Writer-Styles-Character
  Show dependency treegraph
Reported: 2013-01-31 19:43 UTC by Cyril Brosch
Modified: 2023-09-13 03:17 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:

test tab fill (13.60 KB, application/vnd.oasis.opendocument.text)
2015-06-07 16:12 UTC, Gordo
Screencopy of fill dot (87.46 KB, image/png)
2018-05-25 22:05 UTC, Regis Perdreau

Note You need to log in before you can comment on or make changes to this bug.
Description Cyril Brosch 2013-01-31 19:43:15 UTC
Seraching for a way to have more space between the dots in my (non-automatic!) table of content I found the following advise: http://ask.libreoffice.org/en/question/4122/tab-fill-character-spacing/

While it seems to have worked in 2012, in LO 3.6.4, which I'm using now, changing the letter-spacing doesn't do anything, while all other options I tried (high/low, scale) do work.

For me this looks like a regression, it is reproducable with a new document, other lenghths for tabs, and user-defined fill signs.
Comment 1 Urmas 2013-02-01 10:02:31 UTC
Comment 2 Cyril Brosch 2013-02-10 12:04:10 UTC
I've just tested with LO (in Windows), the problem ist there, too.
Comment 3 Buovjaga 2014-11-05 07:14:33 UTC
I tried to reproduce, but I can't even make fill characters appear for tabs. If anyone wants to try: https://help.libreoffice.org/Common/Tabs

Win 7 64-bit and Version:
Build ID: b7d8a58ff2698ffc6e22943f64aa97c5ea253bd9
TinderBox: Win-x86@42, Branch:master, Time: 2014-11-05_00:40:38
Comment 4 Gordo 2015-06-07 16:12:36 UTC
Created attachment 116351 [details]
test tab fill

A character style, with expanded spacing, applied to a tab stop with a fill character does not work in Indexes and Tables → Entries tab or when applied to a paragraph tab stop with a fill character.

For a table of contents, you can add a tab stop after the Entry and put its distance just greater than the longest entry.  Then between the two tab stops, in the Text box, type in full stops and apply a character style with expanded spacing.

Windows Vista 64
Build ID: 88805f81e9fe61362df02b9941de8e38a9b5fd16
Comment 5 Jean-Baptiste Faure 2016-05-22 07:17:17 UTC
Nobody gave a number of a version in which it worked. So removing regression from summary.

Not sure if this behavior is a bug or is by design. If we had a version in which it worked, we would be sure it is a bug.

Best regards. JBF
Comment 6 QA Administrators 2017-05-22 13:39:54 UTC Comment hidden (obsolete)
Comment 7 Cyril Brosch 2017-05-23 20:15:30 UTC
I re-tested with LO 5.3.1 in Linux, and I still can't change the spacing of fill signs inserted via the tab function.
AS comment #5, however, rightly remarks, this may not be a regression. I think it is nevertheless a bug, because a normal function (letter spacing) can not be applied, while similar functions work. If it were by design, the option of letter spacing should be greyed out or the like.
Comment 8 QA Administrators 2018-05-24 02:46:06 UTC Comment hidden (obsolete)
Comment 9 Cyril Brosch 2018-05-25 20:52:25 UTC
I've tested the formatting of filling dots with the newest LO (Linux).

I can change nearly all attributes (size, bold, underline, superscript, ...), but changing the letter-spacing option still does nothing. 
The bug is still present.
Comment 10 Regis Perdreau 2018-05-25 22:05:19 UTC
Created attachment 142283 [details]
Screencopy of fill dot

You can see letter spaced and not space fill dot.
Comment 11 QA Administrators 2019-09-02 09:26:39 UTC Comment hidden (obsolete)
Comment 12 Cyril Brosch 2019-09-12 20:06:46 UTC
I've tested it again with LO on Linux, the bug is still present
Comment 13 QA Administrators 2021-09-12 03:48:42 UTC Comment hidden (obsolete)
Comment 14 Cyril Brosch 2021-09-12 15:59:49 UTC
I've just tested with LO on Linux. I can still change every detail of the fill signs except for the letter spacing.
Comment 15 QA Administrators 2023-09-13 03:17:24 UTC
Dear Cyril Brosch,

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present with the latest version of LibreOffice from https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the information from Help - About LibreOffice.
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a comment that includes the information from Help - About LibreOffice.

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)

If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3) from https://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to 'inherited from OOo';
4b. If the bug was not present in 3.3 - add 'regression' to keyword

Feel free to come ask questions or to say hello in our QA chat: https://web.libera.chat/?settings=#libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team