Bug 60136 - Attached SVG vector graphic does not display / import correctly
Summary: Attached SVG vector graphic does not display / import correctly
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
4.0.0.2 rc
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
: 65120 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-01-31 20:48 UTC by Gerry
Modified: 2013-11-17 19:12 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Face-smile.svg (9.86 KB, image/svg+xml)
2013-01-31 20:48 UTC, Gerry
Details
test.odt (12.03 KB, application/vnd.oasis.opendocument.text)
2013-02-01 16:58 UTC, Gerry
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gerry 2013-01-31 20:48:38 UTC
Created attachment 74018 [details]
Face-smile.svg

Attached SVG vector graphics does not display / import correctly in LibreOffice 4.0 rc2.

How to reproduce:
* Have a look at attached vector graphics in Firefox (or any other SVG viewer)
* Open Writer and select the SVG graphics via "Insert" -> "Picture" -> "From File"
* Compare how the graphic is displayed in LO and in Firefox. It is wrong in LO 4.0rc2, because there is some big blue curve visible which should not be there.



P.S: The graphic is from http://openclipart.org/detail/30217/tango-face-smile-by-warszawianka
Comment 1 Thomas van der Meulen 2013-02-01 14:58:34 UTC
I can confurm this bug running LO  Version 4.0.0.2 (Build ID: 408fe71bd18616c467b3dcd7ab6756528ffcae2) running on mac os x 10.6.8




it is good at :Version 3.6.5.2 (Build ID: 5b93205)
Comment 2 Pedro 2013-02-01 15:03:24 UTC
I can confirm this problem in 4.0.0.3. This is a regression from 3.x (tested in 3.5.7.2 and 3.6.4.3 under Windows XP Pro x86 SP3)
Comment 3 Gerry 2013-02-01 16:58:58 UTC
Created attachment 74054 [details]
test.odt
Comment 4 Gerry 2013-02-01 16:59:31 UTC
I agree to pje335 and Pedro. The SVG imports nicely in Version 3.6.2.2 (Build ID: 360m1(Build:2)), but does not anymore in Version 4.0.0.2 (Build ID: 408fe71bd18616c467b3dcd7ab6756528ffcae2).

Another interesting side note: If I integrate the SVG in a Writer document in version 3.6.2.2, the issue is the same: It is correct in 3.6.2.2, but still wrong in version 4.0.rc2. Please have a look at the attachment test.odt.
Comment 5 ign_christian 2013-05-31 08:57:38 UTC
*** Bug 65120 has been marked as a duplicate of this bug. ***
Comment 6 Thomas van der Meulen 2013-06-27 16:11:09 UTC
Hello all, I have retested this bug with  LibreOffice Version: 4.1.0.1
Build ID: 1b3956717a60d6ac35b133d7b0a0f5eb55e9155 on Mac osx 10.8.4. and it seens like the bug is fixed. after that I tested it with LibreOffice 4.0.4.1 on mac osx 10.8.4 and the bug was still there so I will set it to works for me.

Could some one test this bug again to verify this, thank you :-)