Bug Hunting Session
Bug 60139 - LO cannot start Fatal error on Mac: lightproof-hu_hu-1.3.oxt clashes with bundled dict-hu.oxt
Summary: LO cannot start Fatal error on Mac: lightproof-hu_hu-1.3.oxt clashes with bun...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.6.5.2 release
Hardware: Other All
: medium normal
Assignee: Stephan Bergmann
URL:
Whiteboard: target:4.1.0 target:4.0.1 target:3.6.6
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-31 22:46 UTC by János Korponai
Modified: 2013-02-14 12:49 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
uno_packages.zip (198.89 KB, application/zip)
2013-02-01 12:21 UTC, János Korponai
Details
extensions.zip (186.74 KB, application/zip)
2013-02-01 12:21 UTC, János Korponai
Details

Note You need to log in before you can comment on or make changes to this bug.
Description János Korponai 2013-01-31 22:46:01 UTC
After installation of LO 3.6.5 I have got this message on MacBook Pro (MacOSX 10.6.8).

The program cannot be started.
The service manager is not available.
("file:///Users/janoskorponai/Library/Application                    upport/LibreOffice/3/user/extensions/bundled/registry/com.sun.star.comp.deployment.component.PackageRegistryBackend/common.rdb: duplicate <implementation name="org.openoffice.comp.pyuno.LightproofOptionsEventHandler.hu_HU">")
Start setup application to repair the installation from CD, or the folder containing the installation packages.

Hardware Overview:

  Model Name:	MacBook Pro
  Model Identifier:	MacBookPro7,1
  Processor Name:	Intel Core 2 Duo
  Processor Speed:	2,4 GHz
  Number Of Processors:	1
  Total Number Of Cores:	2
  L2 Cache:	3 MB
  Memory:	4 GB
  Bus Speed:	1,07 GHz
  Boot ROM Version:	MBP71.0039.B0B
Comment 1 Stephan Bergmann 2013-02-01 10:00:07 UTC
János, can you attach here (or send directly to me) a zip of your /Users/janoskorponai/Library/Application Support/LibreOffice/3 folder?
Comment 2 János Korponai 2013-02-01 10:10:57 UTC
Here you are.

On 2013.02.01., at 11:00, bugzilla-daemon@freedesktop.org wrote:

> Stephan Bergmann changed bug 60139 
> What	Removed	Added
> Status	UNCONFIRMED	NEEDINFO
> CC	  	sbergman@redhat.com
> Ever confirmed	  	1
> 
> Comment # 1 on bug 60139 from Stephan Bergmann
> János, can you attach here (or send directly to me) a zip of your
> /Users/janoskorponai/Library/Application Support/LibreOffice/3 folder?
> 
> 
> You are receiving this mail because:
> 	• You reported the bug.

----
Janos Korponai
Department of Chemistry and Environmental Sciences
University of West Hungary
9700 Szombathely, Károly G. tér 4.
Hungary
Comment 3 Stephan Bergmann 2013-02-01 10:23:37 UTC
(In reply to comment #2)
> Here you are.

where?
Comment 4 János Korponai 2013-02-01 10:35:15 UTC
I've got this message:

The file you are trying to attach is 3471 kilobytes (KB) in size. Attachments cannot be more than 3000 KB. We recommend that you store your attachment elsewhere and then paste the URL to this file on the attachment creation page in the appropriate text field. Alternately, if your attachment is an image, you could convert it to a compressible format like JPG or PNG and try again. 

Please give me an alternative way.

Janos
----
Janos Korponai
Department of Chemistry and Environmental Sciences
University of West Hungary
9700 Szombathely, Károly G. tér 4.
Hungary
Comment 5 Stephan Bergmann 2013-02-01 12:04:49 UTC
János, sorry for the trouble this causes.  It should probably suffice if you make available zips of just the two sub-folders /Users/janoskorponai/Library/Application Support/LibreOffice/3/user/extensions and Users/janoskorponai/Library/Application Support/LibreOffice/3/user/uno_packages. which are hopefully each small enough individually.
Comment 6 János Korponai 2013-02-01 12:21:22 UTC
Created attachment 74040 [details]
uno_packages.zip

On 2013.02.01., at 13:04, bugzilla-daemon@freedesktop.org wrote:

> 
> Comment # 5 on bug 60139 from Stephan Bergmann
> János, sorry for the trouble this causes.  It should probably suffice if you
> make available zips of just the two sub-folders
> /Users/janoskorponai/Library/Application Support/LibreOffice/3/user/extensions
> and Users/janoskorponai/Library/Application
> Support/LibreOffice/3/user/uno_packages. which are hopefully each small enough
> individually.
> 
> 
> You are receiving this mail because:
> 	• You reported the bug.

----
Janos Korponai
Department of Chemistry and Environmental Sciences
University of West Hungary
9700 Szombathely, Károly G. tér 4.
Hungary
Comment 7 János Korponai 2013-02-01 12:21:22 UTC
Created attachment 74041 [details]
extensions.zip
Comment 8 Stephan Bergmann 2013-02-01 12:55:26 UTC
You have installed per-user an extension lightproof-hu_hu-1.3.oxt (extension identifier "org.openoffice.comp.pyuno.lightproof.oxt.hu_HU", publisher information is a link to <https://launchpad.net/lightproof>) that contains a UNO service implementation with name "org.openoffice.comp.pyuno.LightproofOptionsEventHandler.hu_HU" that clashes with the extension "org.openoffice.hu.hunspell.dictionaries" (aka dict-hu.oxt, "Hungarian spelling dictionary, hyphenation rules, thesaurus, and grammar checker") that comes bundled with LO.

It has always been an error to produce such clashing extensions with different extension identifiers, but in the past LO unfortunately did not warn about that, and in recent versions LO unfortunately warns "too mercilessly" about it in cases where the clashing extension is inherited via a pre-existing user profile.  (Trying to install the extension freshly into a recent LO would lead to an error message stating that the extension cannot be installed.)

@János:  The easiest workaround for you might be to clear LO's information about your per-user extensions by removing the /Users/janoskorponai/Library/Application Support/LibreOffice/3/user/uno_packages folder, and manually re-installing the other two per-user extensions you apparently had installed (Mendeley-1.8.oxt and texmaths-0.35.oxt) once LO starts again for you.

In any case, I'll change those "org.openoffice.comp.pyuno.Lightproof..." implementation identifiers in the various dict-*.oxt we potentially bundle to no longer clash with that lightproof-hu_hu-1.3.oxt extension.
Comment 9 Not Assigned 2013-02-08 08:25:20 UTC
Stephan Bergmann committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c925f5c33021065cb0b10fa37fca8a51ae2058f2

fdo#60139: Rename bundled extensions's Lightproof service implementation names



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 10 Not Assigned 2013-02-08 08:25:44 UTC
Stephan Bergmann committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/dictionaries/commit/?id=350dc590b04041f15d6c570075ade425e4db93ad

fdo#60139: Rename bundled extensions's Lightproof service implementation names



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 11 Stephan Bergmann 2013-02-08 08:59:29 UTC
requested backports of the fix to libreoffice-3-6 (<https://gerrit.libreoffice.org/#/c/2033/>) and libreoffice-4-0 (<https://gerrit.libreoffice.org/#/c/2032/>)
Comment 12 Not Assigned 2013-02-08 15:04:23 UTC
Stephan Bergmann committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/dictionaries/commit/?id=8669b40a8835c007682507d1efd06f7f24452226&h=libreoffice-4-0

fdo#60139: Rename bundled extensions's Lightproof service implementation names


It will be available in LibreOffice 4.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 13 Not Assigned 2013-02-14 12:49:15 UTC
Stephan Bergmann committed a patch related to this issue.
It has been pushed to "libreoffice-3-6":

http://cgit.freedesktop.org/libreoffice/dictionaries/commit/?id=dcb0157e37ca1746c6ada9cb0cbcadbfdfe6251e&h=libreoffice-3-6

fdo#60139: Rename bundled extensions's Lightproof service implementation names


It will be available in LibreOffice 3.6.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.