Download it now!
Bug 60159 - PDF import: Formulas broken
Summary: PDF import: Formulas broken
Status: RESOLVED DUPLICATE of bug 96080
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: notBibisectable, regression
Depends on:
Blocks: PDF-Import-Draw
  Show dependency treegraph
 
Reported: 2013-02-01 13:36 UTC by PITRider
Modified: 2016-05-10 09:06 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
broken formulas (408.99 KB, application/pdf)
2013-02-01 21:36 UTC, PITRider
Details
broken ole diagrams (187.03 KB, application/x-7z-compressed)
2013-02-01 21:41 UTC, PITRider
Details
screenshot current master linux amd64 (6.23 KB, image/png)
2014-12-04 11:55 UTC, Michael Stahl (CIB)
Details
Another 4.5 master screenshot (19.97 KB, image/png)
2014-12-04 12:06 UTC, Matthew Francis
Details

Note You need to log in before you can comment on or make changes to this bug.
Description PITRider 2013-02-01 13:36:26 UTC
Hi, does anyone know why LibreOffice 3.6.4.3 and above does not import images from PDF, VSD and CDR (in 3.5.7.3 everything worked well.) In WINDOWS everything works too
Comment 1 PITRider 2013-02-01 21:36:48 UTC
Created attachment 74076 [details]
broken formulas

broken formulas
Comment 2 PITRider 2013-02-01 21:41:03 UTC
Created attachment 74077 [details]
broken ole diagrams
Comment 3 PITRider 2013-03-07 21:58:36 UTC
LibreOffice-4.0.1.2: bug with OLE diagrams (in VSD) fixed

loading formulas from PDF not fixed yet
Comment 4 ign_christian 2013-06-14 13:19:11 UTC
VSD files looks ok on LO 4.0.4.2 (Win7 32bit)

But some formulas are broken when importing PDF, so change component & summary accordingly
Comment 5 Michael Stahl (CIB) 2013-10-04 12:07:35 UTC
For the PDF file there are 2 formulas marked (1) that look
significantly worse in 4.0.0.3 compared with 3.6.7.2.

the other formulas in the PDF look broken in the same way in all
versions i tried.

For the VSD file you should have filed a separate bug in the first place
(only one problem per bug), but since comment #3 claims
that it works now that is no longer necessary now.
Comment 6 vvort 2014-05-26 06:44:18 UTC
Looks like here we have the same problem as in Bug 63834 ('bullet' problem there)
---
Formulas (1) now imports perfectly
Comment 7 Matthew Francis 2014-12-04 03:25:44 UTC
mstahl: What platform did you reproduce on that showed a regression?


If there's a visual regression in the rendering of the formulas that are displayed, I can't see it on Linux between 3.6 and present day 4.5 master (if anything, the layout now looks slightly better).

The other formulas with completely broken rendering are likewise equally broken over the same period.


Setting Whiteboard:notBibisectable in the absence of other information
Comment 8 Michael Stahl (CIB) 2014-12-04 11:55:07 UTC
Created attachment 110452 [details]
screenshot current master linux amd64

still broken for me in same way as 4.0
Comment 9 Michael Stahl (CIB) 2014-12-04 12:04:49 UTC
... but you're right, it's not bibisectable: the bibisect builds
display it correctly on my system.

maybe some fonts are missing in my configuration?
Comment 10 Matthew Francis 2014-12-04 12:06:11 UTC
Created attachment 110453 [details]
Another 4.5 master screenshot

Well that's bizarre. On current 4.5 master on Ubuntu 14.04 I get the attached for the same formulae, which seems essentially correct.

Could you possibly be having a font or acceleration related issue that's specific to your installation or distribution? (my screenshot is from a VM, so it's probably not meaningfully accelerated)
Comment 11 vvort 2014-12-04 13:20:51 UTC
'∂', '=' and '-' in formulas (1) uses "Symbol" font - that's the cause of problems.
Comment 12 vvort 2015-01-22 15:12:51 UTC
Michael Stahl, please take the screenshot of test file from Bug 88610 - it may help in solving this problem.
Comment 13 Robinson Tryon (qubit) 2015-12-10 01:26:38 UTC
Migrating Whiteboard tags to Keywords: (notBibisectable)
Comment 14 Heiko Tietze 2016-05-10 09:06:16 UTC
There are numerous tickets regarding the placement of images and text. For instance 58173, 63834, 82093, 91666 etc. Closing this as duplicate, but keep it referenced.

*** This bug has been marked as a duplicate of bug 96080 ***