Bug Hunting Session
Bug 60184 - FILEOPEN: Open R/O
Summary: FILEOPEN: Open R/O
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.5.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-02 12:16 UTC by Bruno
Modified: 2017-03-06 18:45 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bruno 2013-02-02 12:16:38 UTC
I've just a question, I didn't find the right topic.
In MS Office it is possible to declare a file open by default as R/O (read only) so that no backup file is created and one can't make accidentally a mistake. How do I proceed in LibreOffice for Writer files or spread sheets etc.

many thanks
              
Operating System: Windows 7
Version: 3.6.5.2 rc
Comment 1 Urmas 2013-02-02 13:08:38 UTC
You can do something similar by making the file read-only by setting the corresponding file attribute.
Comment 2 Bruno 2013-02-02 17:27:20 UTC
it's not the same approach as in MS Office. It's too complicated always to change the attribute of the file. Please add this feature in LibreOffice to declare a file by default at open time as R/O. Add a prompt, so that it can be opened as R/W on request.

Thanks


From: bugzilla-daemon@freedesktop.org 
Sent: Saturday, February 02, 2013 2:08 PM
To: b.inhelder@bluewin.ch 
Subject: [Bug 60184] FILEOPEN: Open R/O



Comment # 1 on bug 60184 from Urmas 
You can do something similar by making the file read-only by setting the
corresponding file attribute.

--------------------------------------------------------------------------------
You are receiving this mail because: 
  a.. You reported the bug.
Comment 3 Jorendc 2013-02-10 20:48:33 UTC
Thanks for reporting
@Bruno: I discussed this a little bit on our QA channel; and we can't find any other workaround for now then setting each file as Read-Only (as Urmas already mentioned).
Is it possible to provide us more information about the use case (why would you use an option to open as Read-Only by default?).

Thanks in advance,
Joren
Comment 4 Bruno 2013-02-12 14:55:03 UTC
Hi Joren

It's a feature of MS Word (specified in the security part of the file) that I used in the office. One can declare a file as default R/O at open time to prevent the creation of a ~-file (performance!) and the whole edit-environment and to prevent accidentally unwanted changes (safety) if you just want to read a document. I think over 90 percent of opening a doc-file is just for read. Nevertheless it's possible to open in R/W mode because one gets a prompt if it has to be opened R/O or R/W.

I hope my explanations are clear enough and I would appreciate if you could implement such feature also in LibreOffice.

Thanks
Bruno




From: bugzilla-daemon@freedesktop.org 
Sent: Sunday, February 10, 2013 9:48 PM
To: b.inhelder@bluewin.ch 
Subject: [Bug 60184] FILEOPEN: Open R/O


Jorendc changed bug 60184 
      What Removed Added 
      Status UNCONFIRMED  NEEDINFO  
      CC    joren.libreoffice@telenet.be  
      Ever confirmed    1  


Comment # 3 on bug 60184 from Jorendc 
Thanks for reporting
@Bruno: I discussed this a little bit on our QA channel; and we can't find any
other workaround for now then setting each file as Read-Only (as Urmas already
mentioned).
Is it possible to provide us more information about the use case (why would you
use an option to open as Read-Only by default?).

Thanks in advance,
Joren

--------------------------------------------------------------------------------
You are receiving this mail because: 
  a.. You reported the bug.
Comment 5 Jorendc 2013-02-12 16:40:50 UTC
Hi Bruno,

Thanks for your clear explanation. I and others now know what you exactly mean. I'm not a dev but a QA-member, so I can't implement such things :-).

Because this is an enhancement request, I mark it as such.

Thanks for your time filling this report!

Kind regards,
Joren
Comment 6 Oliver Specht (CIB) 2016-01-13 15:06:04 UTC
What about the existing setting in File/Properties/Security/Open file read-only?
Comment 7 Timur 2017-03-06 18:45:39 UTC
Per previous comment, I close as WorksForMe. 
Please be aware of Bug 48606, though.
If you feel this is not correct, please explain and set back to New.