Bug Hunting Session
Bug 60245 - Autocomplete in functions
Summary: Autocomplete in functions
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: AutoCorrect-Complete
  Show dependency treegraph
 
Reported: 2013-02-03 17:41 UTC by Justin
Modified: 2016-10-19 23:31 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Justin 2013-02-03 17:41:01 UTC
The "intellisense" when entering functions is not very good.  Start typing =r and you will get a tool-tip for rand() which is the function I would expect to come up but if you continue on typing and do =randb you would expect an intellisense entry for the randbetween function, but that doesn't happen.  Excel drops a list of functions when you start typing, and also shows the parameters the function can take, etc.
Comment 1 Jorendc 2013-02-03 22:09:47 UTC
Thanks for reporting!

Because this is an enhancement request, I mark it as such. Can't find any duplicate so far. Therefore I mark it as NEW too.

Kind regards,
Joren
Comment 2 Justin 2013-04-15 10:50:24 UTC
Please add this.  I cant really stick with calc until this is implemented. It adds a lot of time searching for functions.
Comment 3 Jorendc 2013-04-15 10:53:33 UTC
Hi Justin,

Please do not alter the bug version to set it at a newer version of LibreOffice. The bug version is the oldest version of LibreOffice you can 'reproduce' the behavior/missing.

Because this isn't a bug but an enhancement request, I set the version to 'unspecified', because it isn't a feature since ... ever.

Kind regards,
Joren
Comment 4 Yousuf Philips (jay) (retired) 2015-06-13 15:39:08 UTC
randbetween() presently appears as the tooltip when typing randb.

Version: 5.1.0.0.alpha1+
Build ID: cdd7ef358d8e97ebf13431b78337f61ad5c2c01a
TinderBox: Linux-rpm_deb-x86@45-TDF, Branch:master, Time: 2015-06-11_23:52:22