Bug 60250 - mirrored page style that starts on left page handled as if it started on right page
Summary: mirrored page style that starts on left page handled as if it started on righ...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: x86 (IA32) Windows (All)
: high critical
Assignee: Michael Stahl (CIB)
URL:
Whiteboard: target:4.1.0 target:4.0.1
Keywords: regression
Depends on:
Blocks: mab4.0
  Show dependency treegraph
 
Reported: 2013-02-03 18:55 UTC by gerdl
Modified: 2018-04-03 14:40 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
writer document empty first page, at all 4 pages (70.53 KB, application/vnd.oasis.opendocument.text)
2013-02-03 18:55 UTC, gerdl
Details

Note You need to log in before you can comment on or make changes to this bug.
Description gerdl 2013-02-03 18:55:26 UTC
Created attachment 74150 [details]
writer document empty first page, at all 4 pages

while beeing displayed corrctly embedded calcs are printed incorrect.
Parts of the boders are right-shifted and partial printed on the next page.
no problems when printing the same document with version 3.6.5.2
tested with two HP Laserjet 4000 TN Printers.
Comment 1 Petr Mladek 2013-02-04 11:02:29 UTC
IMHO, the difference is only with the second page. It looks related to  asymmetric page margins and  "Mirrored" page layout. See "Format/Page/Page".

In LO 4.0.0.3, both the 2nd and 3rd page are considered as a right pages. The wider inner margin is on the left side. It is suspicious and looks like a bug.

LO-3.6.5 interlace the left and right pages more reasonably.

We should fix it ASAP but I think that it is not a blocker for the 4.0.0 release. The .0 release is intended for early adopters and might include even annoying bugs => reducing severity, adding Writer developers into CC.
Comment 2 Michael Stahl (CIB) 2013-02-04 23:57:50 UTC
fixed on master
Comment 3 Not Assigned 2013-02-04 23:59:10 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2fc87188bd4a73d25b64b32e0287cee5d6ee4a48

fdo#60250: InsertNewPage: copy margins for mirrored pages



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 4 Not Assigned 2013-02-05 08:14:19 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7fea9d676296b380aa18a13d361f1c08957e5ec3&h=libreoffice-4-0

fdo#60250: InsertNewPage: copy margins for mirrored pages


It will be available in LibreOffice 4.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.