Download it now!
Bug 60252 - Add a Clipboard Manager to manage multiple copy/paste
Summary: Add a Clipboard Manager to manage multiple copy/paste
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.4.3 release
Hardware: All All
: high enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: needsUXEval
: 129433 (view as bug list)
Depends on:
Blocks: Clipboard
  Show dependency treegraph
 
Reported: 2013-02-03 20:54 UTC by ugboatcaptain
Modified: 2019-12-16 19:08 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of clipboard in MS Word (238.20 KB, image/jpeg)
2013-02-03 20:54 UTC, ugboatcaptain
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ugboatcaptain 2013-02-03 20:54:13 UTC
Created attachment 74153 [details]
Screenshot of clipboard in MS Word

Hi, Excuse me if this is the wrong place for an enhancement request but it is where I ended up, being new here.

The request is for an integrated clipboard manager as in  MS Word 2003. This enables a number of clipboard items to be stored and be accessible from a side panel, so that by simply clicking on one of the clipboard items it pastes it into the document.

I am aware that there are clipboard manager apps out there but having one integrated into the Word window saves a stack of time on some of the documents I use and is the only reason I do not junk MS Word completely. The screenshot shows the clipboard panel as it appears in Word.

Thanks,
Regards & best wishes
Mike (Gonzologist)

              
Operating System: All
Version: 3.6.4.3 release
Comment 1 Jorendc 2013-02-03 22:15:05 UTC
Hi,

Thanks for reporting! I altered the title a bit, to make it more sense.
I also mark this report as Enhancement request.

I tried to search for already-existing enhancement reports, but I couldn't find any. Therefore I mark it as NEW. Also I set this to 'high' because of the difficulty to implement such feature.

Kind regards,
Joren
Comment 2 Franklin Weng 2015-08-03 08:50:11 UTC
In 4.4.1 still no clipboard manager.

It will not be a problem when using Linux desktop (KDE/Gnome) since we can use the system clipboard manager.  However it will be a problem running under Windows since no such system manager.
Comment 3 Buovjaga 2019-09-27 08:13:37 UTC
Adding design team to the loop. This seems a bit out of scope. Maybe best left to a 3rd party extension?
Comment 4 Mike Kaganski 2019-09-27 08:17:34 UTC
(In reply to Franklin Weng from comment #2)
> It will not be a problem when using Linux desktop (KDE/Gnome) since we can
> use the system clipboard manager.  However it will be a problem running
> under Windows since no such system manager.

https://www.windowscentral.com/how-use-new-clipboard-windows-10-october-2018-update ;-)
Comment 5 Heiko Tietze 2019-09-30 07:54:07 UTC
The clipboard is out of scope and up to the operating system. So yes, let's resolve this as WF.
Comment 6 Buovjaga 2019-12-16 19:08:09 UTC
*** Bug 129433 has been marked as a duplicate of this bug. ***