Download it now!
Bug 60265 - Document converter wizard fails to find powerpoint files to convert
Summary: Document converter wizard fails to find powerpoint files to convert
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: Other All
: medium minor
Assignee: Anurag Kanungo
URL:
Whiteboard: target:4.1.0
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-04 08:42 UTC by pasqual milvaques
Modified: 2014-01-06 06:39 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description pasqual milvaques 2013-02-04 08:42:14 UTC
when using the wizard to batch convert files it works nice with excel and word files but for powerpoint files it finds nothing to convert. doesn't find ppt nor pptx files

the document converter is accessible from the menu in the route:
File -> Wizards -> Document Converter
Comment 1 Joel Madero 2013-02-20 22:48:33 UTC
Confirmed. 

Version 4.1.0.0.alpha0+ (Build ID: 9601a571d42b0199bdccf2256fc8be82e14af8a
Date:   Mon Feb 18 23:22:17 2013 +0100
Bodhi Linux 2.2

+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

New (confirmed)
Minor (makes the converter useless for powerpoint files but still can open ppt and pptx files and manually save them, ie. no loss of data, no prevention from making high quality work)
Medium (low is default, seems like this feature might affect a substantial amount of people plus might be reason for people to think twice about moving to LibreOffice)

ProposedEasyHack -- assuming it's just detection that is borked
Comment 2 Julien Nabet 2013-03-03 22:39:08 UTC
On pc Debian x86-64 with master sources updated today, I reproduced the problem.

In wizards/source/importwizard/DialogModul.xba, I noticed this line:
349         MSFilterName(2,2) = "odp|odp"
(why odp twice?)

but above all, I noticed that if I change the line 347:
MSFilterName(2,0) = "ppt|pps|pptx|pptm|ppsx|ppsm"

by
MSFilterName(2,0) = "ppt|pps"
+ make dev-install, it worked.

Now I don't know:
- why it works with this changed line
- where's the really faulty line
- why I need to run "make dev-install"
I tried to avoid this last one (because it's quite long to run it) by making changing directly the content of ./solver/unxlngx6/pck/basicsrvimport.zip but it didn't work.

Noel: any idea?
Comment 3 Anurag Kanungo 2013-04-22 07:38:30 UTC
ppt,pps,pptx,ppsx,pptm,ppsm are being detected and ppt,pptx,pps are being converted to odp but

Formats ppsx , pptm , ppsm are not being converted still .
I think there is some problem with these formats support .

and we require make-dev-install to make it work , as make wizards doesn’t modify the build .


https://gerrit.libreoffice.org/#/c/3548/1/wizards/source/importwizard/DialogModul.xba
Comment 4 Caolán McNamara 2013-04-26 09:36:08 UTC
Works for those now, that was commited as http://cgit.freedesktop.org/libreoffice/core/commit/?id=f25ad4403645cd67b2e50026abf0fe6e81ed9213
Comment 5 Caolán McNamara 2013-05-03 12:14:08 UTC
there's a magic "SBMAXEXTENSIONLENGTH" value in the wizards which seems to be used in a truly bizarre way
Comment 6 Commit Notification 2013-05-03 12:45:08 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b10e69287c42db61679d70146ed5e7c54ee1863e

fdo#60265 Really fixes Basic problem



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2013-05-03 12:53:28 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=25547fbddda1d540d2191e9e9a893c7f263b80e2

Related: fdo#60265 fix lunatic way to detect special filter name



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.