Download it now!
Bug 60279 - FORMATTING: conditional formatting is deleted as well on key "Delete"
Summary: FORMATTING: conditional formatting is deleted as well on key "Delete"
Status: RESOLVED DUPLICATE of bug 57661
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-04 13:52 UTC by Rohan
Modified: 2013-02-08 10:13 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
spreadsheet used for test (7.84 KB, application/x-vnd.oasis.opendocument.spreadsheet)
2013-02-06 18:38 UTC, Michel Rudelle
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rohan 2013-02-04 13:52:10 UTC
I have tested this with 4.0.1.0+ (Build ID: a560ee1625393faf5cd5e04c356a9101b701542)

When deleting the contents of a cell by pressing the key "Del" on the keyboard, the conditional formatting for that cell is also deleted. I don't think this is meant to happen because the UI doesn't reflect this change: the cell keeps its color. Also, when pressing "Undo", the contents of the cell are restored but the conditional formatting is not. This can be verified by checking the region in Format -> Conditional Format -> Manage...

You can use the test sheet from #59843. Strangely enough, on that sheet you have to select two cells and press delete, otherwise the format stays correct.
Comment 1 Joel Madero 2013-02-04 16:44:12 UTC
Cannot reproduce on 4.1 master. You marked RC3 as the version that you tested against but then you put 

4.0.1.0 which is RC1, have you tested against RC2 and RC3 as well? 

Also, you didn't say what operating system you're running. 


My test:

Version 4.1.0.0.alpha0+ (Build ID: 027bb41aa16793e88e9fc1b3550c8c893363647)

on Bodhi Linux

Marking as WFM as my version is newer. If you have tested this on RC3 as well, please reopen the bug. If the oldest release that you have tested on is RC1 and you have also tested on RC3, please change the version to 4.0.0.1 rc, as Version is supposed to be the oldest version that you have seen the problem, not the latest it has been tested.
Comment 2 Rohan 2013-02-04 23:27:54 UTC
I think you are confusing version numbers. 4.0.0.3 is rc3 and 4.1.0.0.alpha+ is master. However, I have been using 4.0.1.0 (!), which is not available in the Bugzilla dropdown - that is why I added it in the comment. This version is supposedly later than rc3.

But I have now also installed and tested with Version 4.0.0.3 (Build ID: 7545bee9c2a0782548772a21bc84a9dcc583b89). Indeed, this version is older than my 4.0.1.0, because not only can I reproduce this bug, #59843 is also still in it.

Sorry that I overlooked the operating system, I added it now and reopened the bug.
Comment 3 Michel Rudelle 2013-02-06 18:38:03 UTC
Created attachment 74297 [details]
spreadsheet used for test

Hi,
I reproduce, use the attached file and follow the instructions in the sheet.
Note that according to the document used, it is not always necessary to clear the whole area, sometimes a few cells are enough. 

Version 4.0.0.3 (Build ID: 7545bee9c2a0782548772a21bc84a9dcc583b89) - Vista
and also with Version 3.6.5.2 (Build ID: 5b93205) - Vista
It works fine with 3.5.7.2
It might perhaps be good to change the version of the bug?
Comment 4 Michel Rudelle 2013-02-06 18:45:38 UTC
(In reply to comment #3)

Sorry, I reversed the colors for point 2, please read:
2) initial checks :
  1 is in A1 :
    A3:C7 - > background red   ok
  enter 0 in cell A1
    A3:C7 - > background yellow   ok
Comment 5 Michel Rudelle 2013-02-08 10:13:19 UTC

*** This bug has been marked as a duplicate of bug 57661 ***