Bug 60295 - VIEWING: Scroll Bar Doesn't Work Correctly for Large Spreadsheets on OSX 10.8+
Summary: VIEWING: Scroll Bar Doesn't Work Correctly for Large Spreadsheets on OSX 10.8+
Status: RESOLVED DUPLICATE of bug 46271
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.5.2 release
Hardware: Other macOS (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-04 22:23 UTC by Sean
Modified: 2013-02-07 20:37 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
A spreadsheet with som astronomical data. (1.59 MB, application/vnd.oasis.opendocument.spreadsheet)
2013-02-04 22:23 UTC, Sean
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sean 2013-02-04 22:23:34 UTC
Created attachment 74197 [details]
A spreadsheet with som astronomical data.

Problem description: 
Vertical scroll bar works incorrectly when viewing a spreadsheet with 10k+ rows. Limited to Mac OS X 10.8+

Steps to reproduce:
1. New spreadsheet.
2. Paste in text that gets 10k+ rows
3. Attempt to click on the grey scroll oval on the right hand side and drag to move around - it's not possible to click & drag to quickly scroll to the end of the data.

Current behavior:
At most the spreadsheet will page down or up depending on mouse position relative to some (infinitely thin?) position on the grey scroll bar.

Expected behavior:
Clicking anywhere in the grayed part of the scroll bar and dragging should scroll through the data.
           
Operating System: Mac OS X
Version: 3.6.5.2 release
Comment 1 Jorendc 2013-02-06 15:21:26 UTC
I can't reproduce this behavior using Mac OSX 10.8.2 and LibreOffice 4.0.0.3 rc3. When I drag the grey-oval to the bottom of the scroll bar, I'm at the bottom of the document (you need to scroll up a little bit to see last entry because you scroll till you have a full blank window without data).
Comment 2 Sean 2013-02-07 20:32:22 UTC
Just upgraded to 4.0.0, and the behavior is the same. Jorendc, are you using a massive spreadsheet? What I suspect is happening is that the target size of the scroll bar is being reduced to 1 pixel or less even though the scroll bar itself stops at a fixed size.
Comment 3 Sean 2013-02-07 20:34:15 UTC
(In reply to comment #2)
> Just upgraded to 4.0.0, and the behavior is the same. Jorendc, are you using
> a massive spreadsheet? What I suspect is happening is that the target size
> of the scroll bar is being reduced to 1 pixel or less even though the scroll
> bar itself stops at a fixed size.

Yep, just found the target area right at the bottom grey oval. The entire grey oval should work.
Comment 4 Sean 2013-02-07 20:37:11 UTC
This is, indeed, a duplicate of Bug 46271. Thanks emir_sari@msn.com.

*** This bug has been marked as a duplicate of bug 46271 ***