Bug 60336 - Ignore BOM at the beginning of flat ODF formats
Summary: Ignore BOM at the beginning of flat ODF formats
Status: CLOSED DUPLICATE of bug 46262
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
4.0.0.0.alpha0+ Master
Hardware: x86 (IA32) Windows (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-05 21:50 UTC by Regina Henschel
Modified: 2017-11-05 17:39 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
flat format with BOM (24.42 KB, application/vnd.oasis.opendocument.graphics-flat-xml)
2013-02-05 21:50 UTC, Regina Henschel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Regina Henschel 2013-02-05 21:50:42 UTC
Created attachment 74258 [details]
flat format with BOM

If you edit a flat format, for example .fodg, with an external editor, it can happen, that a byte order mark is written. In such cases LO does not open the file with the correct module, but shows the text import dialog. If you specify the .fodg filter explicitly, than the file opens fine.

My request is, that the file type detection first skips BOMs and tries to get the file format from the rest. Only if the file will be actually imported as UNICODE text, then the BOM should be considered.
Comment 1 Joel Madero 2013-04-17 15:42:43 UTC
Hm, not an exact duplicate but very similar to 60166 - marking as a dupe because I think both are asking for the same thing.


Regina - if you disagree please feel free to mark this as NEW as I can confirm the behavior, just feel like it's confirming the same strange behavior as the other bug.

Thanks!

*** This bug has been marked as a duplicate of bug 60166 ***
Comment 2 Maxim Monastirsky 2013-12-29 09:32:49 UTC

*** This bug has been marked as a duplicate of bug 46262 ***
Comment 3 Regina Henschel 2017-11-05 17:39:29 UTC
Fix verified in Version: 5.3.7.2
Build ID: 6b8ed514a9f8b44d37a1b96673cbbdd077e24059
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; Layout Engine: new; 
Locale: de-DE (de_DE); Calc: group