Bug Hunting Session
Bug 60348 - PDF: Objects with gradient coloring cannot be exported to vector formats correctly
Summary: PDF: Objects with gradient coloring cannot be exported to vector formats corr...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
3.5.4 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-06 04:16 UTC by Martin Drozdik
Modified: 2013-06-23 03:21 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
The testing document and the various exports (tiff is correctly exported) (162.62 KB, application/x-gzip)
2013-02-06 04:16 UTC, Martin Drozdik
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Drozdik 2013-02-06 04:16:00 UTC
Created attachment 74268 [details]
The testing document and the various exports (tiff is correctly exported)

Problem description: 

When saving a document containing a rectangle object with gradient colouring and transparent area into vector formats, the following problems occur:

PDF: the proportions of the gradient colouring are not the same. The height and width are always the same even when the original height and width were different.

EPS: the same as with PDF + transparency is ignored

SVG: the object bears almost no resemblance to the original one (opening with inkscape)


Steps to reproduce:
1. Create a rectangle
2. Right click the rectangle -> Area -> Gradient -> Type = square
3. In the same context window select Transparency -> Transparency = 50%
4. OK
5. Export with default settings to PDF, SVG, EPS
              
Operating System: Ubuntu
Version: 3.5.4 release
Comment 1 Joel Madero 2013-06-23 03:21:40 UTC
In general we keep 1 bug to 1 report - this is really 3 in 1. I'll try to address them:

Version: 4.2.0.0.alpha0+Build ID: b0a1666f756aa5f5315366eca9d7d02ddd55d2b
Date:   Tue May 28 08:51:01 2013 +0300 
Platform: Bodhi Linux 2.2 x64

+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + +

PDF: WFM - PDF looks pretty good to me. I'm not crystal clear on what you mean about height/width being even but my export def. looks different than the one you provided

EPS: Seems completely broken with 4.2 so impossible for me to test. With 4.0 it seems like I can only export as PDF - separate bug I suppose

SVG: Looks good to me

Because this is 3 in 1 and I can only test 2 really, I'm marking as WFM, I believe the EPS issue has already been reported and is being looked into

If PDF export is still broken for you with version 4.0 or later (4.1 rc, or daily master), please mark this bug as UNCONFIRMED and let us know what version you tested on.

For EPS - if you are able to test on a later release once SVG export is fixed, please open another bug and report the problem

If SVG still seems broken for you in 4.0 or later, please report on a new bug report.


Thanks for reporting!