Bug 60350 - VIEWING: Cell protection - NOT spreadsheet protection, then unprotecting some cells
Summary: VIEWING: Cell protection - NOT spreadsheet protection, then unprotecting som...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.5.2 release
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-06 04:24 UTC by Ivan Stephen
Modified: 2014-06-04 05:32 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ivan Stephen 2013-02-06 04:24:37 UTC
Problem description:  I've given up on trying to use cell protection, even though there are times when it would be great to be able to "lock" individual cells, rows or columns.  It is unnecessarily complex.  Are you planning to rethink it for the next release, or the one after that?

I am not a programmer, so I lack the ability to do this myself.  My thinking is that if a procedure doesn't work well, there is probably a better way to do it.  That's called a bug -  isn't it?

Steps to reproduce:
1. ....
2. ....
3. ....

Current behavior:

Expected behavior:

              
Operating System: Mac OS X
Version: 3.6.5.2 release
Comment 1 Emir Sarı 2013-02-07 02:42:08 UTC
This seems like a valid enhancement request, setting status to "NEW".
Comment 2 Jean-Baptiste Faure 2013-04-22 05:24:41 UTC
(In reply to comment #1)
> This seems like a valid enhancement request, setting status to "NEW".

Indeed, but the reporter did not say clearly what he feels too complicated.
And he should propose an alternative.
NB: I feel easy to protect only one cell or a column in a sheet, when you have understood that all cells are protected by default. 

Best regards. JBF
Comment 3 Ivan Stephen 2013-04-22 19:56:13 UTC
I'm the original reporter.  When I simply want to protect a single cell, the procedure is ridiculously complex.  I have not been able to figure out how to do it, even with online "help".

Just allow us to protect ONLY what we want to protect, right from the menu.


On Mon, 22 Apr, 2013, at 1:24 AM, bugzilla-daemon@freedesktop.org wrote:

> Jean-Baptiste Faure changed bug 60350 
> What	Removed	Added
> CC	  	jbf.faure@sud-ouest.org            
> 
> Comment # 2 on bug 60350 from Jean-Baptiste Faure
> (In reply to comment #1)
> > This seems like a valid enhancement request, setting status to "NEW".
> 
> Indeed, but the reporter did not say clearly what he feels too complicated.
> And he should propose an alternative.
> NB: I feel easy to protect only one cell or a column in a sheet, when you have
> understood that all cells are protected by default. 
> 
> Best regards. JBF
> 
> You are receiving this mail because:
> You reported the bug.
Comment 4 Michel Rudelle 2013-11-23 17:37:21 UTC
I think there is some misunderstanding because the procedure is very simple.
Can you please explain step by step how you proceed to protect:
- just one cell (eg cell B2)
- a column (eg C)
Waiting this information, I set the status to NEEDINFO
Best regards
Comment 5 QA Administrators 2014-06-01 21:29:57 UTC
Dear Bug Submitter,

This bug has been in NEEDINFO status with no change for at least 6 months. Please provide the requested information as soon as possible and mark the bug as UNCONFIRMED. Due to regular bug tracker maintenance, if the bug is still in NEEDINFO status with no change in 30 days the QA team will close the bug as INVALID due to lack of needed information.

For more information about our NEEDINFO policy please read the wiki located here: 
https://wiki.documentfoundation.org/QA/FDO/NEEDINFO

If you have already provided the requested information, please mark the bug as UNCONFIRMED so that the QA team knows that the bug is ready to be confirmed.


Thank you for helping us make LibreOffice even better for everyone!


Warm Regards,
QA Team
Comment 6 Ivan Stephen 2014-06-01 22:35:31 UTC
I originally reported it because this function is essentially unusable in its current format.


Ivan Stephen
istephen@vaxxine.com
905-688-5270

On Sun, 1 Jun, 2014, at 5:29 PM, bugzilla-daemon@freedesktop.org wrote:

> 
> Comment # 5 on bug 60350 from QA Administrators
> Dear Bug Submitter,
> 
> This bug has been in NEEDINFO status with no change for at least 6 months.
> Please provide the requested information as soon as possible and mark the bug
> as UNCONFIRMED. Due to regular bug tracker maintenance, if the bug is still in
> NEEDINFO status with no change in 30 days the QA team will close the bug as
> INVALID due to lack of needed information.
> 
> For more information about our NEEDINFO policy please read the wiki located
> here: 
> https://wiki.documentfoundation.org/QA/FDO/NEEDINFO
> 
> If you have already provided the requested information, please mark the bug as
> UNCONFIRMED so that the QA team knows that the bug is ready to be confirmed.
> 
> 
> Thank you for helping us make LibreOffice even better for everyone!
> 
> 
> Warm Regards,
> QA Team
> 
> You are receiving this mail because:
> You reported the bug.
Comment 7 Jean-Baptiste Faure 2014-06-04 05:12:51 UTC
Ok, just saying it is unusable without answering our questions does not help. 
So closing as WorksForMe because each user who commented feels the current procedure easy enough.

Best regards. JBF
Comment 8 Ivan Stephen 2014-06-04 05:32:59 UTC
I am not a programmer, so explained it quite clearly in very plain English.  Is that clear enough?

In any case, I may need to dump OpenOffice / LibreOffice due to its lack of functionality for the publishing industry.  I hope that a side benefit may be spreadsheets which are more usable for the basic spreadsheet needs that I have.


On Wed, 4 Jun, 2014, at 1:12 AM, bugzilla-daemon@freedesktop.org wrote:

> Jean-Baptiste Faure changed bug 60350 
> What	Removed	Added
> Status	NEEDINFO	RESOLVED
> Resolution	---	WORKSFORME
> 
> Comment # 7 on bug 60350 from Jean-Baptiste Faure
> Ok, just saying it is unusable without answering our questions does not help. 
> So closing as WorksForMe because each user who commented feels the current
> procedure easy enough.
> 
> Best regards. JBF
> 
> You are receiving this mail because:
> You reported the bug.