Bug 60358 - EDITING: Entering "=" causes spreadsheet to crash
Summary: EDITING: Entering "=" causes spreadsheet to crash
Status: CLOSED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: All All
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 61095 65308 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-02-06 09:29 UTC by Kedar Bhise
Modified: 2013-11-20 16:08 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screenshot showing crash state of LibreOffice (51.43 KB, image/png)
2013-02-06 09:29 UTC, Kedar Bhise
Details
Current user profile, Calc working correctly. (1.71 MB, application/x-zip-compressed)
2013-02-22 05:12 UTC, Kedar Bhise
Details
Older user profile, Calc crash on "=" (400.44 KB, application/x-zip-compressed)
2013-02-22 05:14 UTC, Kedar Bhise
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kedar Bhise 2013-02-06 09:29:56 UTC
Created attachment 74278 [details]
Screenshot showing crash state of LibreOffice

Attempting to enter a formula on a new or existing spreadsheet (ods file) causes LO to crash.

Platform: Win XP Professional SP3
LibreOffice Version 4.0.0.3 (Build ID: 7545bee9c2a0782548772a21bc84a9dcc583b89) 

Steps to reproduce:

- Start LibreOffice
- Create a new SpreadSheet via File -> New -> Spreadsheet or via the button on the opening screen.
- Attempt to enter a formula by typing "=" into any cell, via keyboard or via the "=" symbol next to the Formula Bar.

Expected Result: Formula should be entered into cell
Actual Result: LO crashes.
Comment 1 Michel Rudelle 2013-02-07 09:04:31 UTC
I do not reproduce:

Version 4.0.0.3 (Build ID: 7545bee9c2a0782548772a21bc84a9dcc583b89) - Vista
Comment 2 Kedar Bhise 2013-02-08 05:26:53 UTC
I was able to workaround this issue by reinstalling LO 4.0.0.3 and disabling all optional components during Custom installation. No crash.

I then proceeded to add one optional component at a time, and testing for the recurrence of this issue after each install.

At the moment, I am back to a full install, with all optional components installed as well. No crash in Spreadsheet.

Looks like this was a specific combination of environmental factors on my Win XP PC, which I am not able to replicate.

OK to close this bug report.
Comment 3 Joel Madero 2013-02-19 21:05:44 UTC
Adding Kohei and Markus as they are the spreadsheet experts, this is quite serious and appears to be affecting more than just Windows
Comment 4 Joel Madero 2013-02-19 21:06:02 UTC
*** Bug 61095 has been marked as a duplicate of this bug. ***
Comment 5 Joel Madero 2013-02-19 21:09:26 UTC
*** Bug 61095 has been marked as a duplicate of this bug. ***
Comment 6 gcarsan2010 2013-02-20 02:19:20 UTC
i have the same problem with Ubuntu 12.04, Calc crashes when i enter "="  need to fix this problem in Ubuntu 12.04 , not in windows xp or vista, any ideas?, with this bug in Calc, calc is useless to use.
Comment 7 Eike Rathke 2013-02-20 16:56:28 UTC
@gcarsan2010:
I assume you installed the .deb (x86 not x86_64) available from the LibreOffice website, correct?
Which language version?
Comment 8 gcarsan2010 2013-02-20 17:43:44 UTC
Hi, this is the versión i installed: LibreOffice_4.0.0.3_Linux_x86_deb in Spanish, from the libreoffice website. Also i installed LibreOffice_4.0.0.3_Linux_x86_deb_langpack_es, and LibreOffice_4.0.0.3_Linux_x86_deb_helppack_es, in this order.
Comment 9 Joel Madero 2013-02-20 22:49:43 UTC
Two independent users seeing identical problem, marking as NEW and prioritizing.
Comment 10 Eike Rathke 2013-02-21 13:04:23 UTC
I could not reproduce this on Fedora using the x86-64 .deb package.

@gcarsan2010:
Does starting with a fresh user profile help? See https://wiki.documentfoundation.org/UserProfile#Resetting_the_user_profile
and rename ~/.config/libreoffice/4/user to something different.
If that helps please send me the old AND new
~/.config/libreoffice/4/user/registrymodifications.xcu files.
Comment 11 Eike Rathke 2013-02-21 13:14:54 UTC
@gcarsan2010:
If renaming ~/.config/libreoffice/4/user does not help please give it another try with renaming both ~/.config/libreoffice/3/user and ~/.config/libreoffice/4/user and again if that helps send me the old and new ~/.config/libreoffice/4/user/registrymodifications.xcu files.
Comment 12 gcarsan2010 2013-02-21 17:04:57 UTC
Hi, i solve the bug: first i uninstall libreoffice 3.6.5.2 with sudo apt-get remove --purge libreoffice

sudo apt-get clean

sudo apt-get autoremov

then i went inside the folder home/user folder/.config and delete the libreoffice folder.

And then i install the new version libreoffice 4.0.0.3  and the bug disappeared. Now Calc it's working without the "=" bug. The bug is fixed.

Thanks for the help.
Comment 13 Eike Rathke 2013-02-21 18:24:22 UTC
@gcarsan2010:
Great to hear, but.. did you rename the old profile like I described so that it got preserved and you could send me the files mentioned so that I could investigate what went wrong?
Comment 14 gcarsan2010 2013-02-21 19:30:50 UTC
(In reply to comment #13)
> @gcarsan2010:
> Great to hear, but.. did you rename the old profile like I described so that
> it got preserved and you could send me the files mentioned so that I could
> investigate what went wrong?

Sorry, delete the trash folder before I could see your previous email.
Comment 15 Kedar Bhise 2013-02-22 05:12:05 UTC
Created attachment 75289 [details]
Current user profile, Calc working correctly.

(In reply to comment 13)

> @gcarsan2010:
> Great to hear, but.. did you rename the old profile like I described so that
> it got preserved and you could send me the files mentioned so that I could
> investigate what went wrong?

Eike,

Here is my current user profile, with Calc working correctly for formula entering.

I will be attaching an older profile as well, where Calc used to crash.
Comment 16 Kedar Bhise 2013-02-22 05:14:59 UTC
Created attachment 75290 [details]
Older user profile, Calc crash on "="

Follow on to comment 15

Older user profile. Calc crashed consistently on "=" during this time.

Hope this helps.
Comment 17 Eike Rathke 2013-02-22 12:53:32 UTC
Even with the old profile I can't reproduce :-(  All fine here.

Anyhow, thanks for trying.
Comment 18 Jorendc 2013-11-20 16:08:09 UTC
*** Bug 65308 has been marked as a duplicate of this bug. ***