Download it now!
Bug 60360 - cross-reference to an illustration does not work if 'Illustration' is changed to 'Figure'
Summary: cross-reference to an illustration does not work if 'Illustration' is changed...
Status: RESOLVED DUPLICATE of bug 44451
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.0.3 rc
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Fields-Cross-Reference Caption
  Show dependency treegraph
 
Reported: 2013-02-06 10:02 UTC by Parrenin
Modified: 2017-12-15 12:07 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Parrenin 2013-02-06 10:02:52 UTC
Steps to reproduce:
- open a new .odt file
- insert a figure
- insert a legend to this figure.
=> 'Illustration 1' will appear in the legend
- make a cross-reference to this figure with category+number
=> 'Illustration 1' will appear in the main text
- now change 'Illustration' to 'Figure' in the legend
=> 'Illustration' is removed in the main text but 'Figure' is not added
It used to work this way a few months ago.
Comment 1 A (Andy) 2013-03-29 17:19:03 UTC
reproducible with LO 4.0.1.2 (Win7 Home, 64bit)
Comment 2 Owen Genat (retired) 2013-05-14 08:25:08 UTC
This issue is related to bug #58407 in that addressing that bug will resolve the need to cater for this type of editing (at least in relation to changing the default "Illustration" entry to "Figure"). Subsequent alterations to other strings (e.g., "FooBar") would still be a problem though.

Workaround: When inserting the caption (on the Caption dialog), edit the Category from "Illustration" to "Figure" PRIOR to clicking OK.
Comment 3 Andrew Pitonyak 2013-05-25 13:22:22 UTC
This is a problem for the translation team as well. They have no easy way to change "Figure" in the LO documentation while translating from English to some other Language. Adding myself to the CC list.
Comment 4 Owen Genat (retired) 2013-06-01 09:40:29 UTC
Thanks Andrew, I did not know that, but I can understand how this could be an issue in terms of the English word "Figure" being non-specific / generic. In the related bug I pointed to in comment #2 I provide some information pulled from style guides. It is noteworthy that the Oxford Guide to Style 2002 makes a point of mentioning how "Figure" should be avoided in puplications "where confusion between numbers and illustrations may result" e.g., mathematical works. 

In any case, I realise that the matter presented in this bug (preserving the link) is a separate issue. Adding myself to the CC list.
Comment 5 QA Administrators 2015-07-18 17:44:11 UTC Comment hidden (obsolete)
Comment 6 Frederic Parrenin 2015-07-24 05:14:30 UTC
I confirm this problem is still present in version 5.0.0.3.
Comment 7 QA Administrators 2017-01-03 19:41:38 UTC Comment hidden (obsolete)
Comment 8 Dennis Schridde 2017-08-12 09:29:20 UTC
I am using LibreOffice 5.4.0.3 Flatpak and can confirm that the issue is still present.
Comment 9 Dennis Schridde 2017-08-12 09:34:59 UTC
Fixing this currently requires editing the XML.

See-Also: https://ask.libreoffice.org/en/question/39036/how-to-remove-or-edit-caption-category/
Comment 10 Xisco Faulí 2017-12-15 12:07:32 UTC
I think the root cause is the same as in bug 44451

*** This bug has been marked as a duplicate of bug 44451 ***