Download it now!
Bug 60375 - Lost image header after saving in rtf
Summary: Lost image header after saving in rtf
Status: RESOLVED DUPLICATE of bug 76633
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.7.2 release
Hardware: x86-64 (AMD64) All
: high critical
Assignee: Michael Stahl (CIB)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-06 16:08 UTC by Eric
Modified: 2016-06-10 14:12 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Test file to generate the bug (435.78 KB, application/rtf)
2013-02-06 16:08 UTC, Eric
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Eric 2013-02-06 16:08:18 UTC
Created attachment 74293 [details]
Test file to generate the bug

Hi,

I discover this problem since openoffice 3.1 . I try in libreoffice 3.5.72 and the same bug appear.

I made a modification to my rtf, print and save.

After I reopen the rtf file and the image header is disapear.

If I save before the print, everything is fine.

I test it on many configurations french and english , win xp, server 2k3, win7 32bits and 64bits.
Comment 1 A (Andy) 2013-03-29 17:05:11 UTC
This is really buggy (I tested it with LO 4.0.1.2 [Win7 Home, 64bit]).
I opened the file and added a word and then I printed it.  Afterwards, I tried to save it, but LO crashes.  If I save it without printing, then this crash does not occur.

This is reproducible with any new RTF file. 
Steps to Reproduce:
1. Open WRITER
2. Write a word
3. Save it as a RTF file
4. Add a word
5. Print it
6. Save it -> Everything is fine.
7. Insert a picture
8. Save it -> Everything is fine.
9. Add a word
10. Print it
11. Save it -> LO crashes.

-> Therefore, it only occurs if this file has a picture.


@Miklós: Could this issue maybe be something for you?
Comment 2 retired 2014-05-04 13:37:44 UTC
Interesting. 4.2.3.3 + OSX 10.9.2

open rtf, edit, save as rtf under new name. reopen > image is gone.

OS -> all since reported for windows but also happening on osx.
Comment 3 A (Andy) 2015-04-06 19:23:39 UTC
The bugs in Description/Comment 2 and Comment 1 are for me no longer reproducible with LO 4.4.1.2 (Win 8.1).  
Can anybody still reproduce the bug?
Comment 4 Dženan Zukić 2015-11-03 22:56:36 UTC
I cannot reproduce it by following steps Andy gave. My version is LO 5.0.0.5 (x64) @ Win7.
Comment 5 Miklos Vajna 2016-06-10 14:12:02 UTC
This was resolved in the fd8cee8c1fb34432b786d54651f33b6c961ca7fe..b8979cae28cc541a1cfca1b4d2f79b92308bcda0 core.git range on 2014-06-13. The two relevant RTF-specific commits are both related to bug 76633, so resolving this one as a duplicate.

*** This bug has been marked as a duplicate of bug 76633 ***