Bug Hunting Session
Bug 86064 - writer/impress "forget" inserted images
Summary: writer/impress "forget" inserted images
Status: RESOLVED DUPLICATE of bug 82953
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.2.6.3 release
Hardware: All Mac OS X (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-11-09 16:07 UTC by hutschnur
Modified: 2014-11-20 15:12 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description hutschnur 2014-11-09 16:07:58 UTC
writer/impress seem to "forget" images inserted into a document. It makes no difference how often the file is saved. Most of the time the preview pane on the left in impress shows the image is still in place while the slide itself shows something resembling a broken link icon. Same in writer. Upon saving and re-opening the file, the original image is gone for good. Importing the image anew doesn't cure the problem. The problem occurs with windows 7 or OS X. I've tried saving the documents in different formats (.odt, .doc, .docx, .pdf), no cure to the problem. It also doesn't seem to matter if it is an original file that I just created or an imported format.
Hope the description of the problem was sufficient, this is my first ever attempt to report a bug ;)
Comment 1 Joel Madero 2014-11-09 16:18:44 UTC
Can you please provide enumerated steps to reproduce?

Example:
1. Open writer
2. Insert footer
3. . . . .

Etc...

It is much easier to reproduce bugs when you give explicit steps on what we're supposed to do. Marking as NEEDINFO - once you provide the requested steps please set the bug to UNCONFIRMED. Thanks!
Comment 2 Julien Nabet 2014-11-09 17:15:29 UTC
Indeed the process to reproduce this could be useful.

Joel: it seems there are several bugs related to images lost/missing, see those  I put in See Also. Hope recent Zolnai's work about image swapping will help about this, see http://cgit.freedesktop.org/libreoffice/core/log/?qt=author&q=zolnai

Zolnai: thought you might be interested in this one.
Comment 3 hutschnur 2014-11-10 07:07:33 UTC
(In reply to hutschnur from comment #0)
> writer/impress seem to "forget" images inserted into a document. It makes no
> difference how often the file is saved. Most of the time the preview pane on
> the left in impress shows the image is still in place while the slide itself
> shows something resembling a broken link icon. Same in writer. Upon saving
> and re-opening the file, the original image is gone for good. Importing the
> image anew doesn't cure the problem. The problem occurs with windows 7 or OS
> X. I've tried saving the documents in different formats (.odt, .doc, .docx,
> .pdf), no cure to the problem. It also doesn't seem to matter if it is an
> original file that I just created or an imported format.
> Hope the description of the problem was sufficient, this is my first ever
> attempt to report a bug ;)

upon opening a document in either writer or impress, I insert an image via "insert -> image -> from file -> [add file from harddrive]" 
I've tried saving the file right after this process or continued writing and waiting for autosafe, it doesn't matter. Some time after working with the document or after closing and reopening it writer/impress don't show the image but an icon resembling a broken link. I haven't moved the inserted image on the harddrive, though.
Both writer and impress perform the same malfunction. I haven't tried other programmes.
Hope this helps to clarify a bit. Thanks for all your time and effort!
Comment 4 hutschnur 2014-11-11 13:26:28 UTC
(In reply to Joel Madero from comment #1)
> Can you please provide enumerated steps to reproduce?
> 
> Example:
> 1. Open writer
> 2. Insert footer
> 3. . . . .
> 
> Etc...
> 
> It is much easier to reproduce bugs when you give explicit steps on what
> we're supposed to do. Marking as NEEDINFO - once you provide the requested
> steps please set the bug to UNCONFIRMED. Thanks!

Hi, I've somehow misse your comment, though it was the first one. Sorry.

Here are the steps I took:
1. Open writer
2. create new document or open previous one (from previous list)
3. insert image -> from file -> [add file from harddrive]
4. continue work 
5. find out image is no longer shown in file
6. close file
7. upon prompt save file
8. open file again
9. see image is gone

or
repeat steps 1-3
4. save file in any format
5. close file
6. open file, find image gone

or
repeat steps 1-5
6. open file in "open office" "msword" (whatever fits the filetype) and find the image is gone
This is quite a problem since I don't always have access to the images used in the original file. The images in the document or presentation are lost for good.

Thanks for your patience and efforts.
Comment 5 Joel Madero 2014-11-11 22:55:28 UTC
Awesome! Thanks for the update :)
Comment 6 Alex Thurgood 2014-11-17 09:20:58 UTC
Comment 3 seems to imply that document autosave is on. This is/was known to cause image loss, so this report would then be a duplicate.
Comment 7 Alex Thurgood 2014-11-17 09:26:46 UTC
I would suggest this is a dup of bug 82953
Comment 8 hutschnur 2014-11-17 11:00:22 UTC
You just made my day. I turned off autosave and it seems to be a good workaround for the time being. Good luck to you trying to fix the problem for good and thanks again.
Comment 9 Joel Madero 2014-11-20 15:12:18 UTC

*** This bug has been marked as a duplicate of bug 82953 ***