Bug Hunting Session
Bug 47832 - FILESAVE: Pictures on buttons, created in forms, gone after reopening form
Summary: FILESAVE: Pictures on buttons, created in forms, gone after reopening form
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
3.5.1 release
Hardware: x86 (IA32) Linux (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard: target:5.1.0 target:5.0.0 target:4.4.5
Keywords: bibisected, regression
: 51864 89136 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-03-25 01:19 UTC by Robert Großkopf
Modified: 2016-10-25 19:21 UTC (History)
11 users (show)

See Also:
Crash report or crash signature:


Attachments
Shows pictures on buttons when editing form and no pictures after reopening (106.89 KB, application/pdf)
2012-03-25 01:19 UTC, Robert Großkopf
Details
Form in base-file shows a button, created in LO 3.3.4 for testing (13.22 KB, application/vnd.sun.xml.base)
2012-03-25 02:18 UTC, Robert Großkopf
Details
Example writer document, here the error does not exist. (16.81 KB, application/vnd.oasis.opendocument.text)
2014-08-23 09:15 UTC, Thomas Arnhold
Details
bt with master sources when saving form (13.13 KB, text/plain)
2014-08-25 19:24 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Großkopf 2012-03-25 01:19:15 UTC
Created attachment 58996 [details]
Shows pictures on buttons when editing form and no pictures after reopening

When creating a formn in base you could choose pictures for a button. For better transporting databases I choose embedded graphics. But after reopening the form all graphics have gone.
With LO 3.3.4 it works. So it's a regression.
Comment 1 Robert Großkopf 2012-03-25 02:18:22 UTC
Created attachment 58997 [details]
Form in base-file shows a button, created in LO 3.3.4 for testing

I have created an example. The picture I have added under 3.3.4, because it does not work right under 3.5.2 RC1.
When you open the form under 3.5 you could see the picture. When you open the form for editing, then save the form and close it the picture is gone.
Comment 2 Robert Großkopf 2012-03-25 02:21:44 UTC
I have changed the importance to high major, because its a great problem for people, who have created a form with pictures on buttons in LO 3.3.4 and just want to change something in the form - the layout with pictures is destroyed after saving the form in 3.5.2 RC1
Comment 3 Robert Großkopf 2012-03-25 12:13:09 UTC
There is no problem, when the form is only opend for the input of data. Then the form is not changed. It is opend write-protected.
You have to open the form for editing something in the form like change the background-color, add a control ore something else. When you save the form and close it and the open it again the picture is gone.

This problem appears under OpenSUSE 11.4 32bit-rpm with LO 3.5.1 RC2 and 3.5.2 RC1.
Comment 4 Alois Klotz 2012-03-25 12:55:12 UTC
I can reproduce this bug with LO 3.5.1 on Windows 7 64b, Java 1.6_31
Comment 5 Alex Thurgood 2012-03-26 08:49:19 UTC
Confirming in :

LibreOffice 3.5.1.2 
Version ID : dc9775d-05ecbee-0851ad3-1586698-727bf66


This problem could well be linked to the following bug :

https://www.libreoffice.org/bugzilla/show_bug.cgi?id=33393

Adding reference to it.


Alex
Comment 6 Alex Thurgood 2012-03-26 08:50:29 UTC
(In reply to comment #5)
> Confirming in :
> 



I forgot to mention that I can also reproduce with Norbert's build from master from 23/03/2012.

Alex
Comment 7 Alex Thurgood 2012-03-26 08:52:46 UTC
Also added link to an Impress related image loss problem.

https://www.libreoffice.org/bugzilla/show_bug.cgi?id=46447



Alex
Comment 8 Florian Reisinger 2012-05-19 10:42:10 UTC
Please do not use https://www.libreoffice.org/bugzilla/*, use https://bugs.freedesktop.org/* URLs instead..
Thanks

Florian R.
Comment 9 Alex Thurgood 2012-07-12 08:14:27 UTC
*** Bug 51864 has been marked as a duplicate of this bug. ***
Comment 10 Alex Thurgood 2012-07-12 08:18:18 UTC
(In reply to comment #8)
> Please do not use https://www.libreoffice.org/bugzilla/*, use
> https://bugs.freedesktop.org/* URLs instead..
> Thanks
> 
> Florian R.

Hi Florian,

Just out of interest - why should we not use the former ?

Alex
Comment 11 a.scholz 2012-10-30 14:05:58 UTC
Same behaviour in 3.5.7 using calc.
Embedded pictures on a button dissapear after reopening the file.

In Version 3.6.2 embedding is no longer possible (checkbox is grayed out)
Comment 12 Robert Großkopf 2012-10-31 20:19:13 UTC
@comment11

You are right. When I open LO 3.6 I can't embed pictures on buttons any more. Funny idea to "fix" a bug - don't allow the function any more.

Have tested with earlier LO-Versions: With LO 3.5.0 you could open the form for editing, save the form and close the form. The pictures on buttons haven't gone. So this bug appeared first with LO 3.5.1.

Up to 3.5.7 the embedding of graphics seems to be allowed - but didn't work. So since 3.6 the embedding isn't allowed any more ...

Should we ask for an enhancement to get the old functionality of LO 3.3 and LO 3.4 and LO 3.5.0 back? Could be this is a second bug depending on this bug.
Comment 13 Robert Großkopf 2012-10-31 20:26:18 UTC
One hint when I have had a look at "See also":
https://bugs.freedesktop.org/show_bug.cgi?id=33393
has been fixed with LO 3.5.1 - when this bug first appears ...
Comment 14 Mateusz 2012-11-03 00:19:13 UTC
Adding link to my bug (closed as a duplicate), where I presented, on version 3.5.4 how to add an embedded graphics manually by editing .odb file (which is in fact a .zip probably).

Yes, this is a very interesting that the functionality has gone.

Best Regards,
Mateusz
Comment 15 Alex Thurgood 2013-01-26 10:44:25 UTC
Could this be an unintended side effect of changes to the preview/link images code ?

Alex
Comment 16 Alex Thurgood 2013-01-26 11:53:02 UTC
Or, possibly related to the fix to fdo#43867 ? Not sure whether this functionality uses the OLE2 stuff ?

@Caolan : any ideas ?

Alex
Comment 17 Robert Großkopf 2013-05-30 07:54:07 UTC
I have tested with LO 4.0.3.3 . Seems this bug has gone from LO 3.6 to LO 4.0 But now it is impossible to embed pictures for buttons any more. LO 4.0 could read forms, created in LO 3.3.4 with embedded pictures on buttons. But LO 4.0 could not embed pictures itself.
Should we close this bug or is there any 3.6.* planned, which could be fixed?
I will open a new report for embedding pictures on buttons.
Comment 18 Jochen 2013-05-31 06:33:27 UTC
Hi Robert,

(In reply to comment #17)
> I will open a new report for embedding pictures on buttons.

What is the "number" of the new report?
Comment 19 Robert Großkopf 2013-05-31 06:57:59 UTC
(In reply to comment #18)
> Hi Robert,
> 
> (In reply to comment #17)
> > I will open a new report for embedding pictures on buttons.
> 
> What is the "number" of the new report?

Hi Jochen,

I have just added it to "See Also": https://bugs.freedesktop.org/show_bug.cgi?id=65163
At this moment the new report is unconfirmed ...
Comment 20 Joel Madero 2013-10-29 01:48:19 UTC
Still a problem with 4.1.2 on Ubuntu 13.10

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

5ffb884b59688b9e5198d0a6c29f998842c95a37 is the first bad commit
commit 5ffb884b59688b9e5198d0a6c29f998842c95a37
Author: Bjoern Michaelsen <bjoern.michaelsen@canonical.com>
Date:   Wed Apr 25 11:36:01 2012 +0200

    source-hash-f1c162967f032fcc5e4859f67c5b614c5dd19642
    
    commit f1c162967f032fcc5e4859f67c5b614c5dd19642
    Author:     Elton Chung <elton@layerjet.com>
    AuthorDate: Mon Feb 13 15:54:26 2012 +0000
    Commit:     Michael Meeks <michael.meeks@suse.com>
    CommitDate: Mon Feb 13 15:56:32 2012 +0000
    
        Remove unused code

:100644 100644 5fcb517aa12bfbe56c9389e60db34889f86aed47 e578976be5efb5bb209c57bf03246667cb33e933 M	ccache.log
:100644 100644 f1c6ceba2d5e5fa21a42956035acf9ee0622aa6e 0e6676b5b026496f28fd69d44c2bc4a68f6e0d4d M	commitmsg
:100644 100644 f801b7eb61ffa34ddd2930511543b765d65df509 ebdd1a7e99c88faaca1ac8c7d9e3313d4b12bb4e M	dev-install.log
:100644 100644 bd30c2144573cad056e374ef38335db1df41b027 b823a22893d8ebd15c6c7a1fa7330ae6327a9425 M	make.log
:040000 040000 d6adcd256f436caf80efb1b52f54ce911657a97f 26d7acafaccba5b98dc72087a2e62778a3f569cb M	opt


# bad: [5b4b36d87517a6ea96ff8c84c46b12f462fc9a1a] source-hash-8450a99c744e9005f19173e4df35d65640bcf5c4
# good: [65fd30f5cb4cdd37995a33420ed8273c0a29bf00] source-hash-d6cde02dbce8c28c6af836e2dc1120f8a6ef9932
git bisect start 'latest' 'oldest'
# skip: [16b0b88cbd4ef0f51816e97277e40c5cf78f7bf9] source-hash-099198a4224778fe6e43f5dc13b5b9b1b4dc828c
git bisect skip 16b0b88cbd4ef0f51816e97277e40c5cf78f7bf9
# bad: [1b33e76db9e293bea69b7f814ee90a52a10f7a57] source-hash-cac1f33e839469d884730350e46a21d92fb442f2
git bisect bad 1b33e76db9e293bea69b7f814ee90a52a10f7a57
# bad: [8e30bda0f073654bab7bfb0dc57a7d077c314b9d] source-hash-02192b8366c9301ab168770963a88292f4051f52
git bisect bad 8e30bda0f073654bab7bfb0dc57a7d077c314b9d
# good: [57495c59a5f94f67d5eefcab8f6a9fb93cf7576d] source-hash-5a212d501ee1c8ae2b7b9517a4ff486e61cac0fd
git bisect good 57495c59a5f94f67d5eefcab8f6a9fb93cf7576d
# good: [13b5b94ea8d5cd21830dc5e3c9b657e05514ea3e] source-hash-10f977981d2cfb6ba0ccd0185ccb12e212010bc2
git bisect good 13b5b94ea8d5cd21830dc5e3c9b657e05514ea3e
# good: [3b391fdd0f6bec6561861dfb95efb2bdc64221e7] source-hash-a330f38093e2643a26239557050561afae9ff23d
git bisect good 3b391fdd0f6bec6561861dfb95efb2bdc64221e7
# bad: [0bf5e81cae6e0e273fb63bc9bc58e5150228a8ef] source-hash-4eedf5dc54ab19af39d7033462421082d1abb86d
git bisect bad 0bf5e81cae6e0e273fb63bc9bc58e5150228a8ef
# good: [74fa6bec771e6fe10ee8f25d9bfe8f95ab1c4c49] source-hash-4ff7252375b7b85eafbf176ca4e9184cc392d980
git bisect good 74fa6bec771e6fe10ee8f25d9bfe8f95ab1c4c49
# bad: [5ffb884b59688b9e5198d0a6c29f998842c95a37] source-hash-f1c162967f032fcc5e4859f67c5b614c5dd19642
git bisect bad 5ffb884b59688b9e5198d0a6c29f998842c95a37
# first bad commit: [5ffb884b59688b9e5198d0a6c29f998842c95a37] source-hash-f1c162967f032fcc5e4859f67c5b614c5dd19642
Comment 21 Julien Nabet 2014-07-02 21:33:07 UTC
On pc Debian x86-64 with master sources updated today, I could reproduce this.

I noticed these logs:
warn:legacy.osl:13542:1:xmloff/source/forms/propertyexport.cxx:595: OPropertyExport::implConvertAny: unsupported value type!
warn:legacy.osl:13542:1:svx/source/xml/xmlgrhlp.cxx:729: graphic object with ID '1000020100000018000000189E41363E' has an unknown type
warn:legacy.osl:13542:1:xmloff/source/forms/elementimport.cxx:443: OElementImport::EndElement: could not set the property "ObjIDinMSO"!
Comment 22 retired 2014-07-25 10:01:28 UTC
I believe this has been fixed by commit fd641c7b23ce4205c29fc0c564b73336cb2cfb07. Could someone check with the latest daily build?
Comment 23 Julien Nabet 2014-07-25 20:10:15 UTC
(In reply to comment #22)
> I believe this has been fixed by commit
> fd641c7b23ce4205c29fc0c564b73336cb2cfb07. Could someone check with the
> latest daily build?
I tested with master sources updated today, it doesn't work.

FYI, I put for review https://gerrit.libreoffice.org/#/c/10033/
With this patch, I don't reproduce the problem but I don't know if it's the good way to fix this (I mean, could there be a regression, a cornercase I didn't think of, ...).
Comment 24 Alex Thurgood 2014-07-30 14:30:52 UTC
On my master build 
Version: 4.4.0.0.alpha0+
Build ID: a0b89100be8ccc2b60d08d7e3819cd247a6042b0

on OSX 10.9.4, I can open Robert's buttontest.odb and see the image on the button. Guess Julien's fix has sorted it.
Comment 25 Alex Thurgood 2014-07-30 14:37:57 UTC
I can also edit the image, swap it for another one, save the form, and when I open the form in normal work mode, I can see the changed image on the button. Closing LibreOffice, restarting and reopening the file, I can still see the image on the button when I reopen the form.

This is fixed IMHO.
Comment 26 Julien Nabet 2014-07-30 15:06:32 UTC
Alex: my patch hasn't been pushed so if it's ok, it's fixed by something else.

FYI: I had edited the form, moved the button slightly then saved. When reopen the form, the image inside the button didn't appear.

I retest this tonight.
Comment 27 Julien Nabet 2014-07-30 18:57:21 UTC
With master sources updated today (and so without the patch), I still reproduce the problem
1) Edit form
2) Save
3) Reopen form
=> no image
Comment 28 Thomas Arnhold 2014-08-23 09:15:58 UTC
Created attachment 105139 [details]
Example writer document, here the error does not exist.
Comment 29 Julien Nabet 2014-08-25 18:53:59 UTC
Thomas: I tested master sources updated 2 days ago + used the patch, no problem but indeed it worked without the patch too :-(
Comment 30 Julien Nabet 2014-08-25 19:24:32 UTC
Created attachment 105250 [details]
bt with master sources when saving form

I put a breakpoint in svtools/source/graphic/grfcache.cxx at the beginning of GraphicCache::AddGraphicObject
See http://opengrok.libreoffice.org/xref/core/svtools/source/graphic/grfcache.cxx#840

It stopped at the breakpoint during the opening of DB file but also when I saved the form (the bt attached).
For the odt file, it stoppend only during the opening of the file, not when I saved the file after having moved the button.

(BTW, just for information, I had to fetch a random svg and linked it to the button since the svg wasn't included)
Comment 31 Julien Nabet 2014-09-04 05:34:08 UTC
Just for information, I abandonned the patch since, at least, the Windows build fails.
So too complicate for me, I'll let this one for others.
Comment 32 Julien Nabet 2014-11-30 21:21:30 UTC
For the record, I still reproduce this with master sources updated today.
Comment 33 Julien Nabet 2014-12-21 09:59:00 UTC
On pc Debian x86-64 with master sources updated yesterday, I still reproduce this.
Same console log:
warn:legacy.osl:6972:1:svx/source/xml/xmlgrhlp.cxx:727: graphic object with ID '1000020100000018000000189E41363E' has an unknown type
Zolnai: thought you might be interested in this one since you worked on image management recently.
Comment 34 Alex Thurgood 2015-01-03 17:41:06 UTC
Adding self to CC if not already on
Comment 35 Alex Thurgood 2015-02-05 15:08:13 UTC
*** Bug 89136 has been marked as a duplicate of this bug. ***
Comment 36 Julien Nabet 2015-07-11 06:38:28 UTC
On pc Debian x86-64 with master sources updated today, I could still reproduce this.
When I move the button with image, I got this:
warn:legacy.osl:6101:1:sw/source/uibase/docvw/edtwin.cxx:5500: unknown command.
warn:vcl.window:6101:1:vcl/source/window/window.cxx:3423: ignoring RuntimeException "unsatisfied query for interface of type com.sun.star.datatransfer.clipboard.XClipboard!"

After a Ctrl-S to save, I got this:
W: Unknown node under /registry/extlang: deprecated
W: Unknown node under /registry/grandfathered: comments
W: Unknown node under /registry/grandfathered: comments
warn:legacy.osl:6101:1:svx/source/xml/xmlgrhlp.cxx:727: graphic object with ID '100002010000001800000018609F1C26' has an unknown type

And finally when closing Writer:
warn:sw.core:6101:1:sw/source/core/attr/calbck.cxx:170: a 21SwAccessibleParagraph client added as listener to a 16SwTextFormatColl during client iteration.
warn:sw.core:6101:1:sw/source/core/attr/calbck.cxx:170: a 21SwAccessibleParagraph client added as listener to a 16SwTextFormatColl during client iteration.
warn:legacy.osl:6101:1:sw/source/core/attr/format.cxx:228: SwFormat::~SwFormat: Def dependents!
warn:sw.core:6101:1:sw/source/core/attr/format.cxx:237: ~SwFormat: parent format missing from: Paragraph style
Comment 37 Julien Nabet 2015-07-11 07:30:19 UTC
Thomas: I retested with your file, if I try to add an image (eg: a jpg), it fails too.
I got warn:legacy.osl:6307:1:svx/source/xml/xmlgrhlp.cxx:727: graphic object with ID '1000000000000E4000000AB0BE511BB6' has an unknown type on console and when I reopen the odt file, the image is missing.
Comment 38 Commit Notification 2015-07-14 08:38:34 UTC
Zolnai Tamás committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=70f152983f3425a77df2f65b4798417640d47b76

tdf#47832: Pictures on buttons, created in forms, gone after reopening form

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 39 Julien Nabet 2015-07-14 18:56:45 UTC
With master sources updated today (and including your patch), it works as expected! Thank you Zolnai for fixing this long standing bug! :-)

Did you plan to cherry-pick for 5.0 and 4.4 branches? (I can do it for you if you want)
Comment 40 Tamás Zolnai 2015-07-14 20:38:18 UTC
(In reply to Julien Nabet from comment #39)
> With master sources updated today (and including your patch), it works as
> expected! Thank you Zolnai for fixing this long standing bug! :-)
> 
> Did you plan to cherry-pick for 5.0 and 4.4 branches? (I can do it for you
> if you want)

I will cherry-pick the fix for those branches too. It takes some time to build all the branches.
Comment 41 Julien Nabet 2015-07-14 20:42:46 UTC
Zolnai: Just to be sure, you want to cherry-pick, build + retest the patch on these both branches?
Comment 42 Tamás Zolnai 2015-07-14 20:47:48 UTC
(In reply to Julien Nabet from comment #41)
> Zolnai: Just to be sure, you want to cherry-pick, build + retest the patch
> on these both branches?

Yes.
Comment 43 Commit Notification 2015-07-15 07:48:18 UTC
Zolnai Tamás committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e30f56e680a73b201f9059cd09a8ac8c78ebdd51&h=libreoffice-5-0

tdf#47832: Pictures on buttons, created in forms, gone after reopening form

It will be available in 5.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 44 Commit Notification 2015-07-16 08:57:33 UTC
Zolnai Tamás committed a patch related to this issue.
It has been pushed to "libreoffice-4-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3d9b62a40947dbb25360f32a6b330519be6f04ea&h=libreoffice-4-4

tdf#47832: Pictures on buttons, created in forms, gone after reopening form

It will be available in 4.4.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 45 Julien Nabet 2015-07-16 09:02:30 UTC
So let's put this one FIXED now.
Thank you Zolnai! :-)
Comment 46 Commit Notification 2015-07-22 20:54:45 UTC
Zolnai Tamás committed a patch related to this issue.
It has been pushed to "libreoffice-4-4-5":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=09c45087cf02eef3166fb870bae531d40216ca66&h=libreoffice-4-4-5

tdf#47832: Pictures on buttons, created in forms, gone after reopening form

It will be available in 4.4.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 47 Commit Notification 2015-07-23 15:19:14 UTC
Zolnai Tamás committed a patch related to this issue.
It has been pushed to "libreoffice-5-0-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=702cc62537676a66dc4d714598e6949527dbe629&h=libreoffice-5-0-0

tdf#47832: Pictures on buttons, created in forms, gone after reopening form

It will be available in 5.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 48 Adolfo Jayme 2015-07-28 00:49:35 UTC
[Minor cleanup – removing redundant target tags]
Comment 49 Robinson Tryon (qubit) 2015-12-17 06:52:06 UTC Comment hidden (obsolete)