Bug Hunting Session
Bug 60379 - Impress Remote: Options look disabled
Summary: Impress Remote: Options look disabled
Status: RESOLVED FIXED
Alias: None
Product: Impress Remote
Classification: Unclassified
Component: Android app (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: ARM Linux (All)
: high minor
Assignee: Michael Meeks
URL:
Whiteboard: target:4.1.0 target:4.0.1
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-06 17:13 UTC by Rene Engelhard
Modified: 2015-02-13 19:32 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot (40.53 KB, image/png)
2013-02-06 17:13 UTC, Rene Engelhard
Details
Screenshot - this time with correct mimetype (40.53 KB, image/png)
2013-02-06 17:18 UTC, Rene Engelhard
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rene Engelhard 2013-02-06 17:13:51 UTC
Created attachment 74295 [details]
Screenshot

See the attached Screenshot. The Menu seems to have the entries disabled - which is not true, as I can select them just fine.

Stock Android 4.2.1
Comment 1 Rene Engelhard 2013-02-06 17:15:40 UTC
.. with sdremote from today (master~2013-02-06_01.04.36_ImpressRemote-debug.apk)
Comment 2 Rene Engelhard 2013-02-06 17:18:42 UTC
Created attachment 74296 [details]
Screenshot - this time with correct mimetype
Comment 3 Joel Madero 2013-02-07 16:57:20 UTC
Confirmed.

Minor - doesn't prevent use of feature but can be a bit misleading

High - new feature + easy hack
Comment 4 Not Assigned 2013-02-07 18:48:42 UTC
Joren De Cuyper committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5adefb21244ca57b95e9f8df6ec18880438201bf

resolve fdo#60379 Impress Remote: Options look disabled



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 Not Assigned 2013-02-07 18:59:45 UTC
Joren De Cuyper committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=23e6ac150b217be70a80d42deb5b253059030783&h=libreoffice-4-0

resolve fdo#60379 Impress Remote: Options look disabled


It will be available in LibreOffice 4.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 6 Jorendc 2013-02-12 17:07:16 UTC
I need to REOPEN this because my change is reverted. My commit also changed the text color and result in a white text 'searching for computers...' and a white computer list so they are not readable/visible anymore.
Comment 7 Not Assigned 2013-02-13 14:21:39 UTC
Michael Meeks committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f477a88b743ee3cb8835463cc5cd5e3f0c800dba&h=libreoffice-4-0

Revert "resolve fdo#60379 Impress Remote: Options look disabled"


It will be available in LibreOffice 4.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 Not Assigned 2013-02-13 14:21:58 UTC
Michael Meeks committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=31eeb79521b952212e3018f262e25e6b3f4599e7

Revert "resolve fdo#60379 Impress Remote: Options look disabled"



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 9 Joel Madero 2013-02-19 05:13:00 UTC
Michael - can we move this to fixed?
Comment 10 Michael Meeks 2013-02-19 08:44:19 UTC
Nope - the options still look disabled :-) We need to unwind some Android XML theming foo to restore their good looks ...
Comment 11 Artur Dryomov 2014-02-13 13:26:20 UTC
This feature is available from version 2.0.0, which is available on Google Play.
Comment 12 Robinson Tryon (qubit) 2015-02-13 19:32:00 UTC
Moving bug to (new) 'Impress Remote' product.