Bug 60490 - FILEOPEN Crash when opening a drawing odg file
Summary: FILEOPEN Crash when opening a drawing odg file
Status: RESOLVED DUPLICATE of bug 60075
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: x86 (IA32) Windows (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-08 12:21 UTC by bugzilla
Modified: 2013-02-08 18:16 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
Document Which Causes Crash When Opening (627.75 KB, application/vnd.oasis.opendocument.graphics)
2013-02-08 12:36 UTC, bugzilla
Details
gdb console log (9.08 KB, text/plain)
2013-02-08 14:16 UTC, Jorendc
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bugzilla 2013-02-08 12:21:38 UTC
I have a crash when trying to open an odg file.  I have edited it previously with release 4 but when I try to open it again, it just crashes Libreoffice (no error message shown, just a shut down of LO).

The document itself I do not want to post publically - it is possible to make it available privately or be able to remove it from the bug report ?
Thanks
Comment 1 bugzilla 2013-02-08 12:36:58 UTC
Created attachment 74424 [details]
Document Which Causes Crash When Opening

This is an example document which provokes the crash.
Comment 2 Thomas van der Meulen 2013-02-08 13:04:47 UTC
Thank you for reporting this bug, 

I can report this bug running LibreOffice 4.0.0.3 on Windows 7.
Comment 3 Jorendc 2013-02-08 14:16:08 UTC
Created attachment 74429 [details]
gdb console log

I can't reproduce a crash when I try to open the file using Start Center. I can confirm the document don't open at all.

I attached the console output while running in gdb.

Kind regards,
Joren
Comment 4 bugzilla 2013-02-08 14:53:14 UTC
I can confirm I CAN open the document on my OpenOffice [sorry!] 3.2.1 system [Win32, XP].  Digging around for an older Libreoffice install to try with that but this does seem to be an issue with the LO 4 release at the moment.
Comment 5 bugzilla 2013-02-08 14:58:10 UTC
LibreOffice 3.6.4.3 [Win32, XP] opens the document OK in my tests.
Comment 6 Julien Nabet 2013-02-08 18:16:47 UTC
With master sources updated today, I see similar logs and above all this one:
warn:legacy.tools:4976:1:xmloff/source/draw/shapeimport.cxx:192: XMLShapeImportHelper::restoreConnections() was not called!

Maybe I'm wrong, if it's the case, don't hesitate to reopen it.

*** This bug has been marked as a duplicate of bug 60075 ***