Bug Hunting Session
Bug 60491 - missing emboleobj library on non-Windows platforms, causing Editing embedded Excel spreadsheet in Writer to fail
Summary: missing emboleobj library on non-Windows platforms, causing Editing embedded ...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Michael Stahl (CIB)
URL:
Whiteboard: target:4.1.0 target:4.0.1 target:3.6.6
Keywords: regression
Depends on:
Blocks:
 
Reported: 2013-02-08 12:41 UTC by Keith Harding
Modified: 2014-02-10 16:06 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
docx file with embedded excel content (59.28 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2013-02-08 12:41 UTC, Keith Harding
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Keith Harding 2013-02-08 12:41:31 UTC
Created attachment 74427 [details]
docx file with embedded excel content

When opening the attached docx document created in Ms Word 2010. The embedded Excel tables cannot be edited in Writer.

I have confirmed this happens on both Fedora 17 with LibreOffice and MS Windows With Libreofice.
Comment 1 Thomas van der Meulen 2013-02-08 14:32:27 UTC
Thank you for reporting this bug, 

I can reproduce this bug running LAibreOffice Version 4.0.0.3 (Build ID: 7545bee9c2a0782548772a21bc84a9dcc583b89) on Windows 7.

and its work fine with ms office.
Comment 2 Michael Stahl (CIB) 2013-02-08 19:25:08 UTC
on Linux, double-clicking edits these on LO 3.5.6 but not on LO 3.6.5
=> regression
Comment 3 Not Assigned 2013-02-10 01:29:53 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ca8ac449e3524f895de1e94a3c5d511591031b40

fdo#60491: scp2: always package emboleobj library on non-WNT platforms



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 4 Not Assigned 2013-02-10 01:30:12 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5a65ca67d9acefed399ed8706efa402c543bed87

fdo#60491: embeddedobj: catch exception in fallback path



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 Michael Stahl (CIB) 2013-02-11 11:10:41 UTC
there are several problems why this doesn't work:

1) commit 09cd5c460704ddd99669a61ae335bfb2ce357140 changed definition
   of DISABLE_ATL so it is always defined, causing the emboleobj library
   to be excluded from non-Windows installation sets. fixed by comment #3

2) on current master, the second fall-back of the OLE object activation
   doVerb(-9) fails because the type detection of XLS files
   is busted; see bug 60562

3) the third fall-back of the OLE object activation doVerb(-9)
  (to SystemShellExecute) fails because it tries to extract a
  stream that does not exist, and does not handle the exception;
  fixed by comment #4
Comment 6 Not Assigned 2013-02-11 13:08:58 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=92e7811ee757db41dc0b428aa1fe1f3ba3797bac&h=libreoffice-4-0

fdo#60491: scp2: always package emboleobj library on non-WNT platforms


It will be available in LibreOffice 4.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 Not Assigned 2013-02-13 09:01:21 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=27a69f957dc981ed42d594a8a4ebf9baba08d372&h=libreoffice-4-0

fdo#60491: embeddedobj: catch exception in fallback path


It will be available in LibreOffice 4.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 Not Assigned 2013-02-14 08:51:53 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-3-6":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b0bee59347aefe41b4c48919c8b4177572d2d348&h=libreoffice-3-6

fdo#60491: embeddedobj: catch exception in fallback path


It will be available in LibreOffice 3.6.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 9 Not Assigned 2013-02-14 08:57:59 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-3-6":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=59e5098128cd445ed70de418cb787cfa94a65249&h=libreoffice-3-6

fdo#60491: scp2: always package emboleobj library on non-WNT platforms


It will be available in LibreOffice 3.6.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.