Bug Hunting Session
Bug 60495 - FILEOPEN: FORMATTING of "value-conditional color" and "localized decimal separator" need recalculation to appear
Summary: FILEOPEN: FORMATTING of "value-conditional color" and "localized decimal sepa...
Status: RESOLVED DUPLICATE of bug 60215
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: x86-64 (AMD64) All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-08 14:32 UTC by Graham P Davis
Modified: 2013-02-12 05:40 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Table of sunspot data. Columns D and E are formatted to have negative numbers in red. (59.89 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-02-08 14:32 UTC, Graham P Davis
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Graham P Davis 2013-02-08 14:32:25 UTC
Created attachment 74431 [details]
Table of sunspot data. Columns D and E are formatted to have negative numbers in red.

In a book created by a previous version of Calc, I noticed that a column of numbers were all in black, whether or not they were negative. The formatting said they should be red if negative. I changed the formatting several times, lastly to scientific notation, but it appeared to have no effect. I then saved and closed the book.

On opening the saved version with LO 3.6.3, I found the formatting had taken effect, complete with scientific notation, although 4.0.0 hadn't displayed the change. Opening again with 4.0.0, the changed formatting still wasn't visible.

This problem doesn't occur with all numbers; it seems limited to calculated numbers and not directly entered ones. I will do more testing to try to see a pattern.
Comment 1 m.a.riosv 2013-02-08 22:49:52 UTC
Hi Graham, thanks for reporting.

Reproducible.
Win7x64 Ultimate.
Version 4.0.0.3 (Build ID: 7545bee9c2a0782548772a21bc84a9dcc583b89)

If you do a hard calculate the cell looks right (Ctrl+Shift+F9).
Seems to be in relation with the new options in:
Menu/Tools/Options/LibreOffice Calc/Formula/Recalculation on file load/ODF Spreadsheet
setting the option to always recalculate show the format cell right.
Comment 2 j.d.knight 2013-02-10 22:26:28 UTC
Graham,

I can confirm that it appears to only affect calculated fields.

Both suggestions made by mariosv do work.

My reservation with using the setting the options method is that 'recalculation on file load' implies that it recalculates all ODF spreadsheets (not saved in LibreOffice).

This is confusing as it was saved by LibreOffice, albeit an earlier version.

Also you may not want to recalculate ODF files from other sources?

It bothers me more that saving the file using 4.0.0.3 does not resolve the actual problem, as reloading the file takes you back to the original problem.

Pesonally I will just do a manual (Ctrl+Shift+F9) for now.

May I suggest looking at the code that reads the file in and makes the appropriate decision to recalculate or not.

Thanks to everyone.
Comment 3 Horst 2013-02-11 18:58:16 UTC
I have the same experience. I think it is still a bug. Mariosv's solution is a workaround only.
Comment 4 Rainer Bielefeld Retired 2013-02-12 05:40:14 UTC
This one is more or less a DUP of "Bug 60215 - FILEOPEN: Complete Currency FORMATTING VIEWING needs recalculation", but shows some additional effects might have become visible here. For details see my comments in Bug 60215

*** This bug has been marked as a duplicate of bug 60215 ***