Bug Hunting Session
Bug 60508 - EDITING particular .ppt: y-axis label of CHART embedded in Spreadsheet OLE object exceeds chart area
Summary: EDITING particular .ppt: y-axis label of CHART embedded in Spreadsheet OLE ob...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.3.3 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: PPT-Limitations
  Show dependency treegraph
 
Reported: 2013-02-08 18:16 UTC by Rainer Bielefeld Retired
Modified: 2019-09-25 13:48 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2013-02-08 18:16:19 UTC
I found this during my latest tests for "Bug 31754 - SLIDESHOW: Chart y-axis label in .ppt exceeds chart area".

Steps how to reproduce with server installation of  "Version 4.1.0.0.alpha0+ (Build ID: bdfd8de57bf5767ce5c179a5e8705c7587f7b32) TinderBox: Win-x86@6, Branch:master, Pull Time: 2013-02-06_22:06:22" ENGLISH UI / German Locale  on German WIN7 Home Premium (64bit) with own separate User Profile:

1. Download and open Attachment 40406 [details] for Bug 31754
   Expected: all chart visible in Edit mode
   Actual: Y-Axis Label exceeds chart area to the left, is truncated

This is a little strange:
4.1.0.0 Master: always exceeds
4.0.0.3:        exceeds in Edit Mode, looks fine ein SLIDESHOW	
3.6.5.3:        always exceeds

So here my later tests for 4.0 and 3.0 show different results to the ones I saw in Bug 31754.

Can someone confirm my new results? And may be find a root for the unpredictable behavior?
Comment 1 Thomas Arnhold 2013-02-15 14:35:17 UTC
Rainer, I can confirm the behavior.
Comment 2 Markus Mohrhard 2013-02-21 18:38:19 UTC
Against which version is this a regression?

From what I read in the comments I can't figure out in which version this worked.
Comment 3 Rainer Bielefeld Retired 2013-02-21 19:15:22 UTC
@Markus (In reply to comment #2):
Probably against no one. 
The "... exceeds in slideshow ..." is  [Reproducible] with Server Installation of "LibreOffice 3.3.3  English UI/ German Locale [OOO330m19 (Build:301) tag libreoffice-3.3.3.1] on German WIN7 Home Premium (64bit) (where the Edit mode is ok). It seems that at least in one mode the y-axis label always exceeds chart area.

I am pretty sure that these boths problems are 2 sides of the medal, so probably no regression and LibO 333 Version (or more early)
Comment 4 Rainer Bielefeld Retired 2013-02-21 19:17:32 UTC
But no problem at all in AOOo 3.4.0 and AOOo 3.4.1
Comment 5 QA Administrators 2015-02-19 15:49:22 UTC Comment hidden (obsolete)
Comment 6 Daniil Bratashov 2015-02-21 07:30:29 UTC
It exceeds in 4.4.0.3 both in presenation mode and edit mode, but it is not cropped, only shown outside the object area.
Comment 7 QA Administrators 2016-02-21 08:38:07 UTC Comment hidden (obsolete)
Comment 8 QA Administrators 2017-03-06 16:09:57 UTC Comment hidden (obsolete)
Comment 9 Daniil Bratashov 2017-03-06 18:06:29 UTC
In 5.3.0.3 (Slackware linux x86_64) it exceeds in both modes, bug is still present.
Comment 10 QA Administrators 2018-05-11 02:32:24 UTC Comment hidden (obsolete)
Comment 11 Buovjaga 2019-09-25 13:48:42 UTC
Not seeing anything weird, so let's close

Version: 6.4.0.0.alpha0+ (x64)
Build ID: e1b51d4588b4b39592bb94dd5bb90de5e04d061e
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
TinderBox: Win-x86_64@62-TDF, Branch:master, Time: 2019-09-23_09:16:11
Locale: fi-FI (fi_FI); UI-Language: en-US
Calc: threaded