Bug 60522 - Please add .aac audio to the list of supported file formats at "Insert" -> "Movie and Sound"
Summary: Please add .aac audio to the list of supported file formats at "Insert" -> "M...
Status: RESOLVED DUPLICATE of bug 36635
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
4.0.0.2 rc
Hardware: Other Linux (All)
: medium normal
Assignee: Joel Madero
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-09 00:07 UTC by Gerry
Modified: 2013-02-20 00:59 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gerry 2013-02-09 00:07:34 UTC
Similarly to .WMA and .WMV files (bug 36635) also .AAC (Advanced Audio Coding) files are missing in the list of supported file types in "Insert" -> "Movie and Sound"

However, like WMA and WMV files, also AAC files work nicely in LibreOffice. You only cannot select them from the list in the insert dialog.

Solution: Please add .aac files to the list of supported file types. I assume this is a very easy hack.


How to reproduce:
* Please download a sample .aac file, e.g. from here http://chomikuj.pl/Pikus1961/Triangle,154432734.aac
* Try to insert it in a LibreOffice presentation via "Insert" -> "Movie and Sound". -> You will not find the file.
* Instead, rename the file form Triangle.aac to Triangle.mp4. Now you can select the file and it plays nicely in LibreOffice Impress.
Comment 1 Joel Madero 2013-02-20 00:59:29 UTC
Just combined the two, submitting a patch now

*** This bug has been marked as a duplicate of bug 36635 ***