Bug Hunting Session
Bug 60588 - Error in writing content.xml
Summary: Error in writing content.xml
Status: RESOLVED DUPLICATE of bug 60769
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: x86-64 (AMD64) Linux (All)
: highest critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-10 12:34 UTC by opensuse.lietuviu.kalba
Modified: 2013-03-19 20:15 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
File, that can help to reproduce bug (9.51 KB, application/vnd.oasis.opendocument.text)
2013-02-10 12:34 UTC, opensuse.lietuviu.kalba
Details
Error message (117.91 KB, image/png)
2013-02-10 12:35 UTC, opensuse.lietuviu.kalba
Details

Note You need to log in before you can comment on or make changes to this bug.
Description opensuse.lietuviu.kalba 2013-02-10 12:34:08 UTC
Created attachment 74538 [details]
File, that can help to reproduce bug

I can not safe a dokument. In Lithuanian i see eror:

Klaida įrašomas dokumentas Be pavadinimo 1:
Rašymo klaida.
Klaida rašant podokumentį content.xml

After time program cyclic try save dokument, creates many empty (0 B size) files in /.config/libreoffice/4/user/backup/ , it consumes RAM, I can not do any action in program – i must kill LibreOffice.

How to reproduce? 
1. Open attached file.
2. Write some additional text.
3. Do nothink for ~20 minutes
4. Write somethink in adition.
5. Try to safe file.
Comment 1 opensuse.lietuviu.kalba 2013-02-10 12:35:42 UTC
Created attachment 74539 [details]
Error message

I can reproduce a bug, see picture (attached)
Comment 2 Tedo Vrbanec 2013-03-06 15:37:11 UTC
I do not know how it was possible that such a critical bug is not yet resolved. LO 4.0 can't be used at all because of that.
Comment 3 Brenda Granados 2013-03-18 15:32:26 UTC
Hi. I am sorry you are having this problem. I did try to reproduce this using LibreOffice Version 4.0.2.1. I set my language locale to Lithuanian. I opened the document you provided and made a change. I then waited 20+ minutes, added another change, and tried to save. My save was successful- no errors.

Which Linux platform are you using?

Another Question: I see in your attachment that you have chosen to view nonprinting characters. Does the fail to save only occur when you have View -> Nonprinting characters?

Version: Version 4.0.2.1 (Build ID: 7e5467ff8f30d821f4fbf69cb2769163eb64c2c)
Platform: Ubuntu Linux 12.04 LTS x64

----------------------------------------------
LibreOffice is powered by a team of volunteers, every bug is confirmed (triaged) by human beings who mostly give their time for free. We invite you to join our triaging by checking out this link: https://wiki.documentfoundation.org/QA/BugTriage  There are also other ways to get involved including with marketing, UX, documentation, and of course developing -  http://www.libreoffice.org/get-help/mailing-lists
Comment 4 V Stuart Foote 2013-03-19 14:46:43 UTC
(In reply to comment #3)
> Nonprinting characters?
> 
> Version: Version 4.0.2.1 (Build ID: 7e5467ff8f30d821f4fbf69cb2769163eb64c2c)
> Platform: Ubuntu Linux 12.04 LTS x64
> 
Probably duplicated in bug 60769 assigned mab4.0 bug 54157, any chance you can retest in a parralel pre 4.0.2 build to confirm?
Comment 5 Rainer Bielefeld Retired 2013-03-19 16:21:28 UTC
NOT reproducible with reporter's sample document and Server Installation of "LibO  4.0.0.3   -  GERMAN UI / German Locale  [Build ID: 7545bee9c2a0782548772a21bc84a9dcc583b89)]"  {tinderbox: @6, pull time 2013-01-31 11:30(?)} on German WIN7 Home Premium (64bit) with separate  new User Profile:

1. opened copy of sample document from LibO start center
2. Typed "x" behind end of all text
3. Menu 'File -> Save'
   > Saved without problems
4. Typed an "y" behind the "x"
5. Waited half an hour
6. typed "z"
7. Menu 'File -> Save'
   > Saved without problems

Linux Related?
But "Bug 60769 - FILEOPEN, FILESAVE, "Could not save document, error in writing sub document context.xml" then corrupt file." has been confirmed for ALL OS incl WIN.

@Mindaugas Baranauskas
Bug 60769 seems to be fixed for 4.0.1.2. Can you please try?
If your problem persists please contribute a more detailed step by step instruction, may be there is a small detail I do different to your proceeding?
Comment 6 opensuse.lietuviu.kalba 2013-03-19 19:25:53 UTC
I can not reproduce after update to LibreOffice 4.0.1.2. 
(in accordance to https://bugs.freedesktop.org/show_bug.cgi?id=60769#c14 )
We can close this bug.
Comment 7 Rainer Bielefeld Retired 2013-03-19 20:15:27 UTC
Thank you for the test, let's make it a DUP what helps to keep overview.

Please feel free to reopen this Bug if you find evidence that we have an independent issue here.

*** This bug has been marked as a duplicate of bug 60769 ***