Bug Hunting Session
Bug 60593 - [Template manager] Creating new template directory is unnecessarily hard
Summary: [Template manager] Creating new template directory is unnecessarily hard
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 60601 60950 61259 61384 (view as bug list)
Depends on:
Blocks: mab4.0 60601
  Show dependency treegraph
 
Reported: 2013-02-10 13:17 UTC by Mirosław Zalewski
Modified: 2013-05-10 10:04 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mirosław Zalewski 2013-02-10 13:17:58 UTC
In LibreOffice 4.0.0 it is pretty hard to create new template directory. One has to:

1. Select template
2. Move to directory → New directory → Enter name
3. Move another template to new directory or save current file as template there
4. Go to new directory in template manager and move first template back to it's original place

It is especially cumbersome while saving file as new template, since user has no "Move to directory" option. It has either save template elsewhere and then move it, or cancel saving, create new directory (following steps above) and save again.

What we could use is new item in "gear menu". This way user would simply
1. File → Save as template
2. Gear button → Create new directory → Enter name
3. Save

Please also note that "gear button" should be always visible then; I have reported this as https://bugs.freedesktop.org/show_bug.cgi?id=60587

Best regards
Mirosław Zalewski
Comment 1 Rainer Bielefeld Retired 2013-02-10 19:09:31 UTC
Deprecated Regression text in Summary, and more or less not a regression, because problem with completely redesigned Dialogs.
Comment 2 Cédric Bosdonnat 2013-02-11 09:08:58 UTC
Known problem, but would need to add one localize-able string to be fixed.

@andras: would you think it is possible before 4.1?
Comment 3 Mirosław Zalewski 2013-02-28 18:09:11 UTC
*** Bug 61384 has been marked as a duplicate of this bug. ***
Comment 4 Cor Nouws 2013-03-02 16:03:12 UTC
*** Bug 60950 has been marked as a duplicate of this bug. ***
Comment 5 Cor Nouws 2013-03-02 16:08:11 UTC
*** Bug 61259 has been marked as a duplicate of this bug. ***
Comment 6 Cor Nouws 2013-03-02 16:10:17 UTC
pls remember summary of duplicate:
   [Template Manager] FILESAVE: Limited/no handling of folder when choosing File > Save as template
Comment 7 Mirosław Zalewski 2013-03-02 16:55:24 UTC
*** Bug 60601 has been marked as a duplicate of this bug. ***
Comment 8 Mirosław Zalewski 2013-03-02 16:56:18 UTC
Bug 60601, marked as duplicate of this one, describes yet another case why it is important to take care of this issue.

Because template can not be saved in "root" of template directory, it appears to be impossible to save templates for Calc and Draw (whose, by default, have no templates at all).
Comment 9 Cédric Bosdonnat 2013-03-19 10:47:47 UTC
Fixed by Rafael with this commit:
http://cgit.freedesktop.org/libreoffice/core/commit/?id=8d5c061cd66c2a0d41ceda7b61cacef1365f7c4f
Comment 10 Cor Nouws 2013-03-19 13:15:40 UTC
(In reply to comment #9)
> Fixed by Rafael with this commit:
> http://cgit.freedesktop.org/libreoffice/core/commit/
> ?id=8d5c061cd66c2a0d41ceda7b61cacef1365f7c4f

Ah great, thanks!
Is taken into consideration that an empty folder/category was removed (or maybe not showed)?

Explanation: in the current version:
 - select template
 - choose Move to folder > new folder
 - go to template in new folder
 - choose Move to folder > folder foo
 - close and open template manager
 > new folder has disapeared
Comment 11 Cor Nouws 2013-05-10 10:04:38 UTC
(In reply to comment #10)

> Is taken into consideration that an empty folder/category was removed (or
> maybe not showed)?
> [...]
>  > new folder has disapeared

Is fine in 4.0.3 :-)