Bug Hunting Session
Bug 60599 - [FILEOPEN] In sheets from Excel 2010/2013, cell borders appear wider in LO
Summary: [FILEOPEN] In sheets from Excel 2010/2013, cell borders appear wider in LO
Status: RESOLVED DUPLICATE of bug 56960
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
3.6.5.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-10 17:02 UTC by Mirosław Zalewski
Modified: 2013-07-01 08:57 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample document as seen in MS Office 2013 (reference) (8.58 KB, image/png)
2013-02-10 17:02 UTC, Mirosław Zalewski
Details
Sample document as seen in LibreOffice 4.0.0 (7.38 KB, image/png)
2013-02-10 17:03 UTC, Mirosław Zalewski
Details
Sample document for testing purposes (9.09 KB, application/vnd.ms-excel)
2013-02-10 17:04 UTC, Mirosław Zalewski
Details
pdf difference between Excel (for Mac) and LibreOffice (39.11 KB, image/png)
2013-02-10 18:05 UTC, Jorendc
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mirosław Zalewski 2013-02-10 17:02:29 UTC
Created attachment 74551 [details]
Sample document as seen in MS Office 2013 (reference)

While importing files created by Excel 2010 and 2013, LibreOffice adds additional width to cell borders - they appear heavier (wider) in LO than in MSO.

I am attaching:
- screenshot from MS Office 2013 (under Windows 8)
- screenshot from LibreOffice 4.0.0 (under Windows 8)
- sample spreadsheet file created by MSO. This file contains some strings in Polish, but I do not own MSO and I am afraid to translate it, as LO save filter may kick in. So here is translation:
  * "Cienkie" = "thin"
  * "Średnie" = "medium"
  * "Średnie przerywane" = "medium dashed"
  * "Grube" = "thick"

On side note, Excel "dashed" is imported to LibreOffice as "solid". This is probably related to https://bugs.freedesktop.org/show_bug.cgi?id=48282 .

I could reproduce this on LibreOffice 3.6.5, Debian GNU/Linux (amd64). Original images were taken at LibreOffice 4.0.0, Windows 8 (arch unknown).

Best regards
Mirosław Zalewski
Comment 1 Mirosław Zalewski 2013-02-10 17:03:26 UTC
Created attachment 74552 [details]
Sample document as seen in LibreOffice 4.0.0
Comment 2 Mirosław Zalewski 2013-02-10 17:04:16 UTC
Created attachment 74553 [details]
Sample document for testing purposes
Comment 3 Jorendc 2013-02-10 18:02:59 UTC
I can reproduce this behavior using Mac OSX 10.8.2 and verifying using Excel (for Mac) 2011. Therefore I mark this as NEW.
The difference isn't that big when I export both documents to PDF.

Kind regards,
Joren
Comment 4 Jorendc 2013-02-10 18:05:08 UTC
Created attachment 74559 [details]
pdf difference between Excel (for Mac) and LibreOffice
Comment 5 Thomas Arnhold 2013-02-10 18:09:58 UTC
Can reproduce this. This seems to be a known problem, Bug #52578 and #58356 may be related.

It seems that border widths are improperly handled at import - some kind of values rounded up or something similar.
Comment 6 Jorendc 2013-02-10 18:38:18 UTC
@Thomas: please do not delete me from the QA field.

Kind regards,
Joren
Comment 7 Thomas Arnhold 2013-02-15 14:24:25 UTC
Jorendc: Sorry this was not my intention.
Comment 8 Owen Genat (retired) 2013-06-04 07:18:18 UTC
I am providing this comment in the hopes of offering some clarity. Bug #58356 referenced in comment #5 has been marked as a duplicate of bug #56960 which initially outlined a series of problems but now appears to deal solely with a XLSX cell border issue. Bug #56960 appears related to bug #53287 which has also had a rather rough life but again deals with XLS/XLSX cell border issues.

I think those last two bugs are currently awaiting UX advice on two issues: a) how to treat the particular issue of displaying / rendering cell border widths on screen; b) whether to restrict the number of possible cell border widths to only a few values (as OOXML does). Bug #48282 seems related to these two bugs as well. I will leave it to Mirosław and Joren to determine how and to what extent this bug may relate to these issues and what to do about it.

Comment #5 also references bug #52578 which is a different issue and a clearer bug - that of incrementing cell border widths (up to 4.00pt/thick) each time an XLSX is saved. I have commented in that bug to try and provide a clearer picture of what appears to be occurring.
Comment 9 Kevin Suo 2013-07-01 08:55:13 UTC
This seems to be the same issue as shown in Bug 56960.

*** This bug has been marked as a duplicate of bug 56960 ***