Download it now!
Bug 60601 - [Template Manager] It is not possible to import spreadsheet templates without manual intervention in profile template directory
Summary: [Template Manager] It is not possible to import spreadsheet templates without...
Status: RESOLVED DUPLICATE of bug 60593
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: Other All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on: 60581 60593
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-10 17:34 UTC by Mirosław Zalewski
Modified: 2013-03-02 16:55 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Default view after switching to Spreadsheet tab. There is no obvious way to import templates (14.02 KB, image/png)
2013-02-10 17:34 UTC, Mirosław Zalewski
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mirosław Zalewski 2013-02-10 17:34:32 UTC
Created attachment 74555 [details]
Default view after switching to Spreadsheet tab. There is no obvious way to import templates

LibreOffice 4.0.0 introduced new template manager. 

Currently:
- there is no easy way to create new directory (#60593) 
- importing templates may be done only after selecting directory (#60581)
- by default, there is no directory for spreadsheet templates

Result:
It appears to be impossible to import spreadsheet (and Draw) templates using new template manager.

In fact, this issue will solve automatically after mentioned two will be taken care of. I report this only to justify importance of them.

Best regards
Mirosław Zalewski
Comment 1 Rainer Bielefeld Retired 2013-02-10 19:10:14 UTC
Deprecated Regression text in Summary, and more or less not a regression, because problem with completely redesigned Dialogs.
Comment 2 Cédric Bosdonnat 2013-02-11 09:05:54 UTC
I am aware that there is no UI to directly create a new folder. But you can save a template into any folder in the "File -> Save As Template" menu and then you can move the selected template to a new folder.

This is yet-another UI Design bug IMHO.
Comment 3 Cor Nouws 2013-03-02 16:06:48 UTC
@miroslaw:
(In reply to comment #0)
> - there is no easy way to create new directory (#60593) 

Isn't this issue not baiscally a duplicate of 60593?
If there's a logic way to create a directory / folder etc... ?
Comment 4 Mirosław Zalewski 2013-03-02 16:55:24 UTC
Cor: thinking about it now, I believe it is fine to say so.

I set up this bug because I though it is important to stress out consequences of hardness of creating new template directory (which came to me only after reporting 60593). I don't know why I didn't simply post a comment to mentioned bug. It could be due to my frustration with new template manager, maybe.
Perhaps that wasn't the wisest thing I did in my life ;) .

Given that 60593 is already in 4.0's MAB, I hope that it will get some attention. I am marking this one as duplicate, then.

*** This bug has been marked as a duplicate of bug 60593 ***