Bug 60622 - : Send as e-mail does not attach document
Summary: : Send as e-mail does not attach document
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: regression
Depends on:
Blocks:
 
Reported: 2013-02-11 00:21 UTC by Jeppe Bundsgaard
Modified: 2013-03-04 20:26 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screenshot of Thunderbird message (11.04 KB, image/png)
2013-02-11 00:21 UTC, Jeppe Bundsgaard
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jeppe Bundsgaard 2013-02-11 00:21:20 UTC
Created attachment 74572 [details]
Screenshot of Thunderbird message

Problem description: 
When trying to send a text as a word-attachment, the attachment does not get attached to the message. A am using Thunderbird.

Steps to reproduce:
1. Choose File->Send->E-mail as Microsoft Word
2. ....
3. ....

Current behavior:
No document attached
Expected behavior:
Document attached

              
Operating System: Ubuntu
Version: 4.0.0.2 rc
Last worked in: 3.5.7.2 release
Comment 1 Thomas Arnhold 2013-02-11 08:01:12 UTC
Can't reproduce this with Libo Version 4.0.0.3 (Build ID: 7545bee9c2a0782548772a21bc84a9dcc583b89) on Windows 7.

Is it Linux specific? Can anybody confirm this?
Comment 2 Rainer Bielefeld Retired 2013-02-11 08:54:30 UTC
Works fine with Server Installation of "LibO  4.0.0.3 rc   -  ENGLISH UI / German Locale  [Build ID: 7545bee9c2a0782548772a21bc84a9dcc583b89)]"  {tinderbox: @6, pull time 2013-01-31 11:30(?)} on German WIN7 Home Premium (64bit) with separate  new User Profile. For a blank new document with few words nonsense text I did menu 'File -> Send -> E-Mail as MS WORD...', and my Seamonkey 2.15 opened a new mail with attachment "noname.doc"

Related to Linux or rc version or TB?

@Jeppe Bundsgaard
Can you please test 4.0.0.3 release?
Does that work for other document formats?
Comment 3 Jeppe Bundsgaard 2013-02-11 09:49:16 UTC
I did test it on 4.0.3-release - the bug-system did not accept 4.0.3 as the version (there was no 4.0.3 - but a 4.0.3-rc and that returned "not a known version, so I used 4.0.2-rc)).
Comment 4 Jeppe Bundsgaard 2013-02-11 09:50:33 UTC
Sorry - of course I meant 4.0.0.3.

And no, it does not work for .odt either.
Comment 5 Michael Meeks 2013-03-02 20:00:29 UTC
Works for me with Evolution.

This 'Emne' bed.doc - is that not your document ? attached ?
Comment 6 Jeppe Bundsgaard 2013-03-04 20:26:58 UTC
Sorry! I had not defined the mail agent in LibreOffice settings. When I did that it worked. But of course it is still strange that Thunderbird opened and did not insert the attachment correctly. Maybe Libreoffice sends settings to the mail agent according to the mail agent's demands (and expected kmail on Kubuntu)?