Download it now!
Bug 60627 - EDITING: CRASH when 'Format - Bullets and Numbering'
Summary: EDITING: CRASH when 'Format - Bullets and Numbering'
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
4.1.0.0.alpha0+ Master
Hardware: Other Windows (All)
: medium major
Assignee: Caolán McNamara
URL:
Whiteboard: BSA target:4.1.0
Keywords: regression
Depends on:
Blocks: mab4.1
  Show dependency treegraph
 
Reported: 2013-02-11 06:38 UTC by Rainer Bielefeld Retired
Modified: 2013-02-15 12:43 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2013-02-11 06:38:36 UTC
Steps how to reproduce with server installation of  "Version 4.1.0.0.alpha0+ (Build ID: bdfd8de57bf5767ce5c179a5e8705c7587f7b32) TinderBox: Win-x86@6, Branch:master, Pull Time: 2013-02-06_22:06:22" ENGLISH UI / German Locale  on German WIN7 Home Premium (64bit) with own separate User Profile:

1. Launch LibO
2. <New Draw document>
3. Menu 'Format -> Bullets and Numbering ..' 
   > CRASH

Already crashes with server installation of  "Version 4.1.0.0.alpha0+ (Build ID: 2823789bec0c029d9714aff0ed65923e23177ef) TinderBox: Win-x86@6, Branch:master, Pull Time: 2013-01-24_22:52:49" ENGLISH UI / German Locale  on German WIN7 Home Premium (64bit) with LO41 Masters User Profile

Was still ok with server installation of  "4.1.0.0.alpha0+ (Build ID: 6a393297ce6d99bbc4edefbf01ab9c5c6f0eff8) TinderBox: Win-x86@6, Branch:master, Time: 2013-01-04_01:06:01  - ENGLISH UI / German Locale  on German WIN7 Home Premium (64bit) with LO41 Masters User Profile 

No problem with 4.0.0.3 and 4.0.1.0 branch versions

Operating System: Windows 7
Version: 4.1.0.0.alpha0+ Master
Last worked in: 4.0.0.3 rc
Comment 1 Rainer Bielefeld Retired 2013-02-11 06:43:13 UTC
Already [Reproducible] with server installation of  "4.1.0.0.alpha0 (Build ID: 0ff470cff6ecc436e723af6a60986c8eefaba7b) TinderBox: Win-x86@6, Branch:master, Time: 2013-01-19 22:38:36  - ENGLISH UI / German Locale  on German WIN7 Home Premium (64bit) with LO41 Masters User Profile

NEW because reproducible with various versions
Comment 2 Michael Meeks 2013-02-12 13:20:20 UTC
a UI conversion snafu ? :-)
Comment 3 Noel Grandin 2013-02-15 07:31:58 UTC
Note: 
NOT reproducible on 64-bit Linux with current master (as of commit 3164966103b7d5c19197b7e94040d585e5af04ac)
Comment 4 Noel Grandin 2013-02-15 09:50:54 UTC
NoelG: I don't know. I'm just making the comment so that people know that testing on Linux is not sufficient.
Comment 5 Caolán McNamara 2013-02-15 11:37:06 UTC
probably one of the custom widgets has the wrong shared library name, which doesn't matter under Linux, but is fatal under windows
Comment 6 Not Assigned 2013-02-15 12:24:59 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=158aee9ad3e8d7dbb58381fc260ebdb53466ce22

Resolves: fdo#60627 wrong lib names for some custom widgets



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 Caolán McNamara 2013-02-15 12:43:02 UTC
that should fix it (although untested if someone under windows can verify that for me it would be great) and added a script for use on other platforms to detect this happening again