Bug 60640 - Send / Email as... Evolution
Summary: Send / Email as... Evolution
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: Other Linux (All)
: high normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-11 09:21 UTC by p_kongstad
Modified: 2014-09-07 11:12 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
log for sending spreadsheet as mail (1.38 MB, text/plain)
2013-11-07 09:23 UTC, p_kongstad
Details

Note You need to log in before you can comment on or make changes to this bug.
Description p_kongstad 2013-02-11 09:21:14 UTC
Hi,

When using this option in the program Scalc, nothing happens. The E-mail program is with the value evolution. When changing to thunderbird this option works.

This has been tested against Evolution 2.32 and 3.4.4 on two different versions of Linux (Ubuntu 10.04 and SolusOS 2).

Last working version of LO was 3.6.5.

Issue also to be found in:
Version 4.1.0.0.alpha0+ (Build ID: fbfda39d26da6747edb3a4c6d593be7e6b2b0f1)
TinderBox: Linux-x86_64_11-Release-Configuration, Branch:master, Time: 2012-12-09_22:33:10
Comment 1 p_kongstad 2013-02-15 11:58:00 UTC
Hi, Could this bug please be tested and confirmed?
Comment 2 Thomas Arnhold 2013-02-15 14:07:00 UTC
Maybe related: bug#60622.
Comment 3 Thomas van der Meulen [retired] 2013-03-21 20:35:07 UTC
Hello P. kongstad, 
I can't reproduce this bug running LibreOffice 4.0.2.1 on Ubuntu 12.10 or linux mint 14.

can you please check that your email progam is set to Evolution.
tools --> Options --> internet --> E-mail 
is it set to: /usr/bin/evolution 

if not please set it and try again  and tell me if you solved it 
if so, please tell me. 


Thomas
Comment 4 p_kongstad 2013-03-21 21:14:00 UTC
Hi,

The same issue still exist on 
Version 4.0.3.0+ (Build ID: 6690e18c5f45e24d013bcccdc47a2d32a3b2f05)
TinderBox: Linux-x86_64@31-Release-Configuration-RHEL5-Baseline, Branch:libreoffice-4-0, Time: 2013-03-18_22:12:52
and 
Version 4.1.0.0.alpha0+ (Build ID: fbfda39d26da6747edb3a4c6d593be7e6b2b0f1)
TinderBox: Linux-x86_64_11-Release-Configuration, Branch:master, Time: 2012-12-09_22:33:10

On 4.1 I have deleted the profile as well. It's make no change.

Standard it is set to evolution. Changing to /usr/lib/evolution makes no change.
Comment 5 Michael Meeks 2013-03-26 12:44:55 UTC
Worth checking what is going on: can you do:

strace -f -s 256 -p `pidof soffice.bin` -o /tmp/slog

and then poke in 'slog' for the execve line that is invoked - digging at that should show us exactly what is going on; possibly something moved / changed in how we have to invoke Evolution (?).

thanks !
Comment 6 p_kongstad 2013-03-26 16:08:17 UTC
Version 4.1.0.0.alpha0+ (Build ID: fbfda39d26da6747edb3a4c6d593be7e6b2b0f1)
TinderBox: Linux-x86_64_11-Release-Configuration, Branch:master, Time: 
2012-12-09_22:33:10

execve("/bin/sh", ["sh", "-c", 
"\"/opt/lodev4.1/program/../program/senddoc\" --mailclient 
/usr/lib/evolution --subject \"noname.ods\" --attach 
\"/tmp/lur93yhw.tmp/lur93yi4.tmp/noname.ods\" "], [/* 37 vars */]) = 0

Version 4.0.3.0+ (Build ID: 9296cf4088a0637f0326803fe220816ebc8daf2)
TinderBox: Linux-x86_64@31-Release-Configuration-RHEL5-Baseline, 
Branch:libreoffice-4-0, Time: 2013-03-23_00:11:56

execve("/bin/sh", ["sh", "-c", 
"\"/opt/libreoffice4.0/program/../program/senddoc\" --mailclient 
evolution --subject \"noname.ods\" --attach 
\"/tmp/lur9bs7q.tmp/lur9bs8x.tmp/noname.ods\" "], [/* 41 vars */]) = 0

Thanks


On 03/26/2013 01:44 PM, bugzilla-daemon@freedesktop.org wrote:
> Michael Meeks <mailto:michael.meeks@novell.com> changed bug 60640 
> <https://bugs.freedesktop.org/show_bug.cgi?id=60640>
> What 	Removed 	Added
> Status 	UNCONFIRMED 	NEEDINFO
> Ever confirmed 		1
>
> *Comment # 5 <https://bugs.freedesktop.org/show_bug.cgi?id=60640#c5> 
> on bug 60640 <https://bugs.freedesktop.org/show_bug.cgi?id=60640> from 
> Michael Meeks <mailto:michael.meeks@novell.com> *
> Worth checking what is going on: can you do:
>
> strace -f -s 256 -p `pidof soffice.bin` -o /tmp/slog
>
> and then poke in 'slog' for the execve line that is invoked - digging at that
> should show us exactly what is going on; possibly something moved / changed in
> how we have to invoke Evolution (?).
>
> thanks !
> ------------------------------------------------------------------------
> You are receiving this mail because:
>
>   * You reported the bug.
>
Comment 7 Thomas Arnhold 2013-03-26 20:23:05 UTC
You have '/usr/lib/evolution' in your settings, Thomas said, that it should be '/usr/bin/evolution'. Probably this is the solution?!
Comment 8 p_kongstad 2013-03-27 09:12:32 UTC
Thanks for the correct path, but it does not change anything.

I have removed and downgraded to Version 4.0.2.1 (Build ID: 7e5467ff8f30d821f4fbf69cb2769163eb64c2c)

execve("/bin/sh", ["sh", "-c", "\"/opt/libreoffice4.0/program/../program/senddoc\" --mailclient evolution --subject \"noname.ods\" --attach \"/tmp/lus9sjii.tmp/lus9sjjq.tmp/noname.ods\" "], [/* 38 vars */] <unfinished ...>

The issue is also present in this version.

It's running on top of Ubuntu 10.04 64 bit with Evolution 2.32.2.
Comment 9 QA Administrators 2013-09-24 01:44:00 UTC
Dear Bug Submitter,

This bug has been in NEEDINFO status with no change for at least 6 months. Please provide the requested information as soon as possible and mark the bug as UNCONFIRMED. Due to regular bug tracker maintenance, if the bug is still in NEEDINFO status with no change in 30 days the QA team will close the bug as INVALID due to lack of needed information.

For more information about our NEEDINFO policy please read the wiki located here: 
https://wiki.documentfoundation.org/QA/FDO/NEEDINFO

If you have already provided the requested information, please mark the bug as UNCONFIRMED so that the QA team knows that the bug is ready to be confirmed.


Thank you for helping us make LibreOffice even better for everyone!


Warm Regards,
QA Team
Comment 10 p_kongstad 2013-11-06 23:34:56 UTC
This bug is still present in Version: 4.2.0.0.alpha1+
Build ID: ebeff1814cbecfba9bbeaeba8067b58f71703a39
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2013-11-06_05:59:04.

However it works in Apache OpenOffice 4.0.1 AOO401m5(build:9714) - Rev 1524958
Comment 11 Stephan Bergmann 2013-11-07 07:52:45 UTC
Can you please provide all the execve lines from the strace output, "grep exec /tmp/slog", or, even better yet, the complete /tmp/slog file?
Comment 12 p_kongstad 2013-11-07 08:16:31 UTC
Hi,

I do not have such a file existing in my system. This is Ubuntu. 

Please advice to where to search for needed information.
Comment 13 Stephan Bergmann 2013-11-07 09:13:58 UTC
(In reply to comment #12)
> I do not have such a file existing in my system. This is Ubuntu. 
> 
> Please advice to where to search for needed information.

I was referring to the instructions mmeeks had given you in comment 5.
Comment 14 p_kongstad 2013-11-07 09:23:47 UTC
Created attachment 88815 [details]
log for sending spreadsheet as mail

Please find the log file as requested.
Comment 15 Stephan Bergmann 2013-11-07 10:06:11 UTC
The problem is that your /usr/bin/evolution internally uses (the system) Python interpreter, LO's soffice.bin process prepends its own Python installation's directories to the PYTHONPATH environment variable (which is handed down to the evolution process) as soon as Python is instantiated in LO, and the two Python versions are apparently incompatible (Python 2 vs. 3, presumably), so /usr/bin/evolution fails with non-zero exit code:

> 5699  execve("/usr/bin/evolution", ["evolution", "mailto:?subject=noname.ods&attach=file:///tmp/lupsegw4.tmp/lupsegw7.tmp/noname.ods"], [/* 37 vars */]) = 0
[...]
> 5699  open("/opt/libreoffice4.1/program/../program/python-core-3.3.0/lib/codecs.py", O_RDONLY) = 32
[...]
> 5699  read(32, "\"\"\" codecs -- Python Codec Registry, API and helpers.\n\n\nWritten by Marc-Andre Lemburg (mal@lemburg.com).\n\n(c) Copyright CNRI, All Rights Reserved. NO WARRANTY.\n\n\"\"\"#\"\n\nimport builtins, sys\n\n### Registry and builtin stateless codec functions\n\ntry:\n    from "..., 4096) = 4096
> 5699  read(32, ", errors='strict'):\n\n        \"\"\" Decodes the object input and returns a tuple (output\n            object, length consumed).\n\n            input must be an object which provides the bf_getreadbuf\n            buffer slot. Python strings, buffer objects and me"..., 4096) = 4096
> 5699  read(32, " decoder.\n\n        This must be a (buffered_input, additional_state_info) tuple.\n        buffered_input must be a bytes object containing bytes that\n        were passed to decode() that have not yet been converted.\n        additional_state_info must be a n"..., 4096) = 4096
> 5699  read(32, "etattr__(self, name,\n                    getattr=getattr):\n\n        \"\"\" Inherit all other methods from the underlying stream.\n        \"\"\"\n        return getattr(self.stream, name)\n\n    def __enter__(self):\n        return self\n\n    def __exit__(self, type, "..., 4096) = 4096
[...]
> 5699  write(2, "Traceback (most recent call last):\n", 35) = 35
> 5699  write(2, "  File \"/opt/libreoffice4.1/program/../program/python-core-3.3.0/lib/encodings/__init__.py\", line 31, in <module>\n", 114) = 114
[...]
> 5699  write(2, "    ", 4)               = 4
> 5699  write(2, "import codecs\n", 14)   = 14
[...]
> 5699  write(2, "  File \"", 8)          = 8
> 5699  write(2, "/opt/libreoffice4.1/program/../program/python-core-3.3.0/lib/codecs.py", 70) = 70
> 5699  write(2, "\", line ", 8)          = 8
> 5699  write(2, "1045", 4)               = 4
> 5699  write(2, "\n", 1)                 = 1
> 5699  write(2, "    ", 4)               = 4
> 5699  write(2, "return {i:i for i in rng}\n", 26) = 26
> 5699  write(2, "    ", 4)               = 4
> 5699  write(2, " ", 1)                  = 1
> 5699  write(2, " ", 1)                  = 1
> 5699  write(2, " ", 1)                  = 1
> 5699  write(2, " ", 1)                  = 1
> 5699  write(2, " ", 1)                  = 1
> 5699  write(2, " ", 1)                  = 1
> 5699  write(2, " ", 1)                  = 1
> 5699  write(2, " ", 1)                  = 1
> 5699  write(2, " ", 1)                  = 1
> 5699  write(2, " ", 1)                  = 1
> 5699  write(2, " ", 1)                  = 1
> 5699  write(2, " ", 1)                  = 1
> 5699  write(2, " ", 1)                  = 1
> 5699  write(2, " ", 1)                  = 1
> 5699  write(2, "^\n", 2)                = 2
> 5699  write(2, "SyntaxError", 11)       = 11
> 5699  write(2, ": ", 2)                 = 2
> 5699  write(2, "invalid syntax", 14)    = 14
> 5699  write(2, "\n", 1)                 = 1
[...]
> 5699  exit_group(1)                     = ?

The fix would be to undo the modifications to PYTHONPATH before spawning new processes (or, better yet, potentially find a solution that does not require modification of the PYTHONPATH environment variable at all).

An immediate workaround should be to not use a generic TDF LO installation set from <http://www.libreoffice.org/download> (which bundles its own Python) but to use one specifically built for the given Linux distro (which likely uses the system Python instead).
Comment 16 Stephan Bergmann 2013-11-07 10:09:15 UTC
(In reply to comment #15)
> LO's soffice.bin process prepends its own Python
> installation's directories to the PYTHONPATH environment variable

... in prependPythonPath (pyuno/source/loader/pyuno_loader.cxx)
Comment 17 p_kongstad 2014-09-07 11:12:48 UTC
As this is due to incompatibility between different version of Python, I close this bug report