Bug Hunting Session
Bug 60660 - Add ability to change template of current document
Summary: Add ability to change template of current document
Status: RESOLVED DUPLICATE of bug 50699
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-11 12:26 UTC by Mirosław Zalewski
Modified: 2013-04-27 07:02 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mirosław Zalewski 2013-02-11 12:26:48 UTC
(This is spin-off of Bug #60592 ).

LibreOffice misses any suitable way of changing template the document is assigned to. This is especially important for people managing complex documents who use Master document feature. To produce high-quality Master document, all child documents should be based on the same template that master document is. Sometime this is not a case, as people get template only after starting work on child documents.

What would be great is new button in File → Properties → General tab. At the bottom of this window is "Template" field. On it's right could be button "change template" which would fire up template manager/file picker. After selecting template, document would be assigned to it.

Best regards
Mirosław Zalewski
Comment 1 Pierre C 2013-02-12 05:54:24 UTC
I confirm the need of this feature.
Not only for complex document, but for peoples who want to use template files.

This extension http://extensions.libreoffice.org/extension-center/template-changer

doesn't work any more with Libo 4.

So, for me, it's a blocker for deploying Libo 4.0.0 on my college ( over 700 computers and 2 000 students) as long as the extension works again or the requested feature is implemented on LibO

Pierre
Comment 2 Cor Nouws 2013-02-21 15:45:57 UTC
@Miroslaw: Can you pls be more specific of the location of the template?
AFAICS, the new template manager does allow to change templates, but only the ones that are saved in one of the folders defined in there.
Is that what you mean?
Comment 3 Mirosław Zalewski 2013-02-21 16:32:18 UTC
@Cor: It might be that we have misunderstanding here. This is what I would like to achieve:

1. I have two templates, let's name them A and B.
2. I create new document based on template A.
3. I decide that template B better suits my document. So I would like to change file properties and assign it to template B (LO will ask later if I want to update styles).

I did not find any option to do that, irrelevant of template location.
I believe that you are talking about modifying of template files; this is completely different situation that is not covered by this bug report.

It is possible that I missed some option. If this is a case, could you please tell me how can I change template of current document? I will try to reproduce steps and close bug report.

If not, could you rephrase topic of this bug report to be less ambiguous? I would be glad if you did.
Comment 4 Cor Nouws 2013-02-22 09:39:36 UTC
Hi Miroslaw,

> [...]
> I believe that you are talking about modifying of template files; this is
> completely different situation that is not covered by this bug report.

Ah, indeed. Sorry.
There is the option to Load styles (window Styles and Formatting (F11), menu at the top right) but that does not change the associated template.

I was looking at various template related stuff, and didn't get yours right. I think the description is fine though. Apologies.
Comment 5 Thomas Arnhold 2013-04-27 07:02:37 UTC

*** This bug has been marked as a duplicate of bug 50699 ***