Bug 60672 - FILEOPEN INSERT 'Link to external data' The link could not be updated.
Summary: FILEOPEN INSERT 'Link to external data' The link could not be updated.
Status: RESOLVED DUPLICATE of bug 63407
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: Other All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-11 15:18 UTC by joaquin
Modified: 2013-11-18 12:08 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
LO-4.0 load data from external link (14.02 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-02-11 15:18 UTC, joaquin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description joaquin 2013-02-11 15:18:19 UTC
Created attachment 74619 [details]
LO-4.0 load data from external link

All links to load data from websites are not showing that loaded data since upgrading toe LO 4.0.

Workaround:
-> Edit -> Links -> select a link and chose [Modify]
  It appears that there is a new difference between the following choices 
  under "Available tables/ranges"

  HTML_all
  HTML_tables

The first selection displays "The link could not be updated.", the last one works in most cases.

Examples:
The following links will only show with "HTML_all"

https://www.asnbank.nl/asnappl/scripts/koersen/koersen.asp
http://www.cs.vu.nl/~x/knipselkrant/ag-128.html

The following link will never show:
http://www.zeit.de/gesellschaft/2013-02/papst-benedikt-ruecktritt
Comment 1 Patrick Smits 2013-04-06 23:43:00 UTC
I have the same problem with one of my spreadsheets. The solution might be reported here (I'm not a programmer)
http://www.mail-archive.com/libreoffice-bugs@lists.freedesktop.org/msg86158.html

version 3.6.5.2
const ScRangeData* p =
pNames->findByUpperName(ScGlobal::pCharClass->uppercase(rAreaName));

version 4.0.1.2
const ScRangeData* p = pNames->findByUpperName(rAreaName);

Best regards.
Comment 2 Patrick Smits 2013-04-06 23:45:12 UTC
BTW The latest version my spreadsheet worked was Calc build 3.6.5.2.
Comment 3 Joel Madero 2013-04-14 17:01:50 UTC
Usually this would be marked as the NEW bug but the duplicate bug has been bibisected and has additional information. Marking this as a duplicate of #63407

*** This bug has been marked as a duplicate of bug 63407 ***