Bug 60701 - Send Document as email fails, when application is installed to a directory with a space
Summary: Send Document as email fails, when application is installed to a directory wi...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: Other Mac OS X (All)
: medium normal
Assignee: Stephan Bergmann
URL:
Whiteboard: target:4.1.0 target:4.0.2 target:3.6.6
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-11 22:20 UTC by Chris
Modified: 2013-03-11 14:31 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chris 2013-02-11 22:20:42 UTC
I have Libreoffice installed into a directory where the path name contains a space. "/Applications/SelfInstalled/space folder" when attempting to send the open document by email in either pdf, word, etc format it fails.  

checking the console logs on OSX i get the following messages:

2/11/13 1:48:46.540 PM [0x0-0xd53d53].org.libreoffice.script: usage: dirname path

2/11/13 1:48:46.660 PM [0x0-0xd53d53].org.libreoffice.script: /Applications/SelfInstalled/space folder/LibreOffice.app/Contents/MacOS/../program/senddoc: line 361: /uri-encode: No such file or directory


If i change libreoffice install directory to not contain a space the problem is resolved.
Comment 1 Flavio 2013-03-05 20:13:39 UTC
I was able to reproduce exactly what Chris explained.

With a space in the path, the mail.app opens but then nothing, and without space, the mail.app opens and an email is created with the attachment.

Bug reproduced on 3.6.5
Mac OS Mountain Lion

Cheers
Comment 2 Commit Notification 2013-03-08 04:38:44 UTC
Arnaud Versini committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c1f02657ccece20a1e5843c78115ffcb193eb459

Fixes fdo#60701 by escaping uri-encode path correctly



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 3 Commit Notification 2013-03-11 10:03:26 UTC
Stephan Bergmann committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5c32ac5104e9cade52c8a373033644282de9ceff

fdo#60701: Properly quote shell parameter expansions



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 4 Commit Notification 2013-03-11 11:36:41 UTC
Stephan Bergmann committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4b49fa35226791e3ee262af7f2ce664aa3d38424&h=libreoffice-4-0

fdo#60701: Properly quote shell parameter expansions


It will be available in LibreOffice 4.0.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2013-03-11 14:31:45 UTC
Stephan Bergmann committed a patch related to this issue.
It has been pushed to "libreoffice-3-6":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8188f9212fa5db9b9e65009ae1c94de2399c5f09&h=libreoffice-3-6

fdo#60701: Properly quote shell parameter expansions


It will be available in LibreOffice 3.6.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.