Bug Hunting Session
Bug 60702 - PRINTING: Embedded SVG graphics print without line width attributes used
Summary: PRINTING: Embedded SVG graphics print without line width attributes used
Status: RESOLVED DUPLICATE of bug 61789
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: All Linux (All)
: high normal
Assignee: Not Assigned
URL:
Whiteboard: BSA bibisected40
Keywords: regression
Depends on:
Blocks:
 
Reported: 2013-02-11 22:22 UTC by Rob Spearman
Modified: 2015-12-22 01:31 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
This is an ODT with an embedded SVG line (18.95 KB, application/vnd.oasis.opendocument.text)
2013-03-06 22:12 UTC, Rob Spearman
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rob Spearman 2013-02-11 22:22:41 UTC
Problem description: 

Embedded SVG graphics display correctly on screen but not when printed or saved as a PDF.  Line width attributes are being discarded.

Steps to reproduce:
1. Insert an SVG file with line width attributes
2. Print page or save document as PDF

Current behavior:

Print/PDF lines in the SVG graphics are all extremely thin.

Expected behavior:

Line widths should match those in the source SVG and onscreen.
Operating System: Fedora
Version: 4.0.0.3 release
Comment 1 Rob Spearman 2013-03-06 22:12:59 UTC
Created attachment 76056 [details]
This is an ODT with an embedded SVG line

Here is a simple test file.  The SVG renders correctly in writer, but fails to print or save as PDF correctly (line becomes very thin).
Comment 2 Joel Madero 2013-03-21 16:09:19 UTC
Thank you for reporting this issue! I have been able to confirm the issue on:
Version 4.1.0.0.alpha0+ (Build ID: 9a46e5614f5a0e0bdce3c497f81ca529da8fb5c)
Date:   Mon Mar 18 18:59:09 2013 +0100 
Platform: Bodhi Linux 2.2 x64

+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + +
As I've been able to confirm this problem I am marking as:

New (confirmed)
Normal - can prevent high quality work
High (regression)

Keywords - regression (works on 3.6.5.2)


+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + +
LibreOffice is powered by a team of volunteers, every bug is confirmed (triaged) by human beings who mostly give their time for free. We invite you to join our triaging by checking out this link:
https://wiki.documentfoundation.org/QA/BugTriage and join us on freenode at #libreoffice-qa

There are also other ways to get involved including with marketing, UX, documentation, and of course developing -  http://www.libreoffice.org/get-help/mailing-lists/. 

Lastly, good bug reports help tremendously in making the process go smoother, please always provide reproducible steps (even if it seems easy) and attach any and all relevant material
Comment 3 Joel Madero 2013-03-21 16:37:01 UTC
There are only 'skip'ped commits left to test.
The first bad commit could be any of:
47498a36f7af8f54e6e3dda89cd4708802a409e6
9ec4be63ed5281f2e9364b140da69291c7abc348
769583027b0158ac4b497355b0495fca5c54f53b
7b32edd2389319e0d394368c4109201528c41f7e
6095212a5bd192017c6a20ee10de26a163372e8c
915b1e16f20d5ce2a32f911ef051103455600845
b17eb9ea515cf4b5bf60dd2b6860febf0806a9bd
fb4214f9d134b556582a4a5280e5458de5f8eebd
5dddcff8ae35692d89751ae98ab8acbbf802b5b4
9a5620ca6473969359f262802c76daf35cbcbb5d
fad6aba1675531a031872af655be5756c5012cb9
We cannot bisect more!


# bad: [5b4b36d87517a6ea96ff8c84c46b12f462fc9a1a] source-hash-8450a99c744e9005f19173e4df35d65640bcf5c4
# good: [65fd30f5cb4cdd37995a33420ed8273c0a29bf00] source-hash-d6cde02dbce8c28c6af836e2dc1120f8a6ef9932
git bisect start 'latest' 'oldest'
# good: [16b0b88cbd4ef0f51816e97277e40c5cf78f7bf9] source-hash-099198a4224778fe6e43f5dc13b5b9b1b4dc828c
git bisect good 16b0b88cbd4ef0f51816e97277e40c5cf78f7bf9
# good: [f28b8f9a6c47fa59bf98fffe937a2f2db7a2445a] source-hash-a581d31b227623e09d2970a91214fda398f98eda
git bisect good f28b8f9a6c47fa59bf98fffe937a2f2db7a2445a
# good: [114fd3b76bcba890e6d702d00cef910f1493c262] source-hash-64ab96cd15e52da88781e720d6f031dbcd0ba902
git bisect good 114fd3b76bcba890e6d702d00cef910f1493c262
# skip: [47498a36f7af8f54e6e3dda89cd4708802a409e6] source-hash-19f4ebd8a54da0ae03b9cc8481613e5cd20ee1e7
git bisect skip 47498a36f7af8f54e6e3dda89cd4708802a409e6
# bad: [99fa32bfa0d6116217da0834f3a630b3775aa16a] source-hash-246ffb108c7e1f762f8d497750ad2414b85b99ef
git bisect bad 99fa32bfa0d6116217da0834f3a630b3775aa16a
# skip: [9a5620ca6473969359f262802c76daf35cbcbb5d] source-hash-ae4e4a11d4300f7448cb6bd170fcb034542caddc
git bisect skip 9a5620ca6473969359f262802c76daf35cbcbb5d
# skip: [6095212a5bd192017c6a20ee10de26a163372e8c] source-hash-a599f5b4b51848e3b397d471c9d12b373caadcef
git bisect skip 6095212a5bd192017c6a20ee10de26a163372e8c
# skip: [b17eb9ea515cf4b5bf60dd2b6860febf0806a9bd] source-hash-b6c016da23d309b4ac7d154bc33a22397974ed73
git bisect skip b17eb9ea515cf4b5bf60dd2b6860febf0806a9bd
# skip: [fb4214f9d134b556582a4a5280e5458de5f8eebd] source-hash-683758efb22d08a4cf211a6d985148f513da2a90
git bisect skip fb4214f9d134b556582a4a5280e5458de5f8eebd
# skip: [915b1e16f20d5ce2a32f911ef051103455600845] source-hash-9210b95bcfd65ae558f445666d9b880e794d4c74
git bisect skip 915b1e16f20d5ce2a32f911ef051103455600845
# good: [7f50375c2cf8bf1e026f61f11ae9666648687164] source-hash-d281a19e1d06856f863788f3344ad42ed1566669
git bisect good 7f50375c2cf8bf1e026f61f11ae9666648687164
# skip: [5dddcff8ae35692d89751ae98ab8acbbf802b5b4] source-hash-d85fd8a85501547d5bb87822d2589a07aed7f2d6
git bisect skip 5dddcff8ae35692d89751ae98ab8acbbf802b5b4
# skip: [9ec4be63ed5281f2e9364b140da69291c7abc348] source-hash-a1ac2538e9b287444500618ab4d2f0f06c25cf34
git bisect skip 9ec4be63ed5281f2e9364b140da69291c7abc348
# skip: [7b32edd2389319e0d394368c4109201528c41f7e] source-hash-44b96a2fce52b6e3e683dc917fab219cf75001db
git bisect skip 7b32edd2389319e0d394368c4109201528c41f7e
# skip: [769583027b0158ac4b497355b0495fca5c54f53b] source-hash-a43a76cd5aa2f145f2cb43fcdbc8f21fb6c89af0
git bisect skip 769583027b0158ac4b497355b0495fca5c54f53b
# good: [e2e46267c18c2706de771a08472ebfce19f68520] source-hash-4316e643ef345b0f673b4a03a80a4b7cb3185588
git bisect good e2e46267c18c2706de771a08472ebfce19f68520
# bad: [fad6aba1675531a031872af655be5756c5012cb9] source-hash-d38a2e3ea04d354492df18aa16d2304babe87dfb
git bisect bad fad6aba1675531a031872af655be5756c5012cb9
Comment 4 Michael Stahl (CIB) 2013-03-27 18:52:47 UTC
this is already fixed on master, by commit
432b6ab482d6fcef05514ab17e4bc762ee552139

which i've just pushed to the 4.0 branch

*** This bug has been marked as a duplicate of bug 61789 ***
Comment 5 Robinson Tryon (qubit) 2015-12-22 01:31:26 UTC
Removing comma from Whiteboard (please use a space to delimit values in this field)
https://wiki.documentfoundation.org/QA/Bugzilla/Fields/Whiteboard#Getting_Started
[NinjaEdit]