Download it now!
Bug 60705 - Can't print to rear paper feed slot on EPSON WF-3540
Summary: Can't print to rear paper feed slot on EPSON WF-3540
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.5.7.2 release
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:4.3.0 target:4.2.0.1
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-12 00:36 UTC by Dave Detty
Modified: 2014-02-07 22:12 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
attachment-14516-0.html (2.81 KB, text/html)
2013-05-02 02:23 UTC, Dave Detty
Details
attachment-14516-1.dat (1 bytes, multipart/alternative)
2013-05-02 02:23 UTC, Dave Detty
Details
epson-inkjet-printer-201212w_1.0.0-1lsb3.2_i386.deb (1.61 MB, application/x-debian-package)
2013-05-02 02:23 UTC, Dave Detty
Details
epson-inkjet-printer-escpr_1.2.2-1lsb3.2_i386.deb (1.73 MB, application/x-debian-package)
2013-05-02 02:23 UTC, Dave Detty
Details
attachment-21344-0.html (2.04 KB, text/html)
2013-05-02 03:18 UTC, Dave Detty
Details
attachment-21344-1.dat (1 bytes, multipart/alternative)
2013-05-02 03:18 UTC, Dave Detty
Details
image.png (59.26 KB, image/png)
2013-05-02 03:18 UTC, Dave Detty
Details
image.png (51.88 KB, image/png)
2013-05-02 03:18 UTC, Dave Detty
Details
image.png (36.34 KB, image/png)
2013-05-02 03:18 UTC, Dave Detty
Details
image.png (40.96 KB, image/png)
2013-05-02 03:18 UTC, Dave Detty
Details
image.png (53.40 KB, image/png)
2013-05-02 03:18 UTC, Dave Detty
Details
image.png (38.38 KB, image/png)
2013-05-02 03:18 UTC, Dave Detty
Details
Epson WF-3530 Print Job Attributes (22.64 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-11-10 03:08 UTC, Paul Kahlert
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dave Detty 2013-02-12 00:36:07 UTC
When trying to print to envelopes to rear paper slot, paper from default front tray is used. This behavior is consistent across Writer and Calc for any document, not just envelopes. Tried turning off CUPS support but that resulted in reduced printer features that eliminated rear paper slot option.  Also tried printing with postscript instead of PDF but issue was unchanged. After document is printed with front tray paper, printer displays message that printing from rear paper slot. I don't think it is a printer issue. Printing from MS Word on Windows 7 PC permits printing using rear paper slot.

My system is Linux, ubuntu 12.04 LTS on IBM ThinkPad X41; LibreOffice 4.0.0.3 (Build ID: 7545bee9c2a0782548772a21bc84a9dcc583b89)
Comment 1 Julien Nabet 2013-02-16 23:10:45 UTC
Michael: I didn't find "printing" expert in FindTheExpert page
I found this http://ask.libreoffice.org/en/question/1687/printer-wont-print-rear-tray/ but not really useful. Any idea how could take a look to this?
Comment 2 Joel Madero 2013-04-16 18:09:09 UTC
hm, but can you print anything else in Linux to the rear feed? For instance can you print a pdf from your pdf viewer to the rear tray? Just because it works in W7, doesn't mean it's LibreOffice problem, could be a problem with print driver in Linux.
Comment 3 Joel Madero 2013-04-17 16:23:07 UTC
Marking as NEEDINFO - @Dave - please confirm that you can print within Linux to rear tray using software outside of LibreOffice such as pdf viewer or even a text editor.

If you can, please set to UNCONFIRMED and report back:)


Thanks for helping us out!
Comment 4 Michael Meeks 2013-04-17 18:53:57 UTC
Yep - would be great to isolate the bug - is it an issue with CUPS ? -> notourbug :-) Ultimately this sort of tray/destination stuff is a fairly basic / fundamental printing issue.
Comment 5 Julien Nabet 2013-04-18 05:38:05 UTC
Dave: as Joel asked, are you able to print to rear paper feed with another software in Ubuntu?

BTW, I don't think it'll help but it's always interesting to test with last stable available version, so did you give a try to 4.0.2? You can find it on LO ppa (see https://launchpad.net/~libreoffice/+archive/ppa)
Comment 6 Dave Detty 2013-04-19 02:45:00 UTC
Sorry for taking so long to get back with you.  I was on travel and didn't
have the offending Linux/LibreOffice computer to test out your request. I
really appreciate your help and feel bad about leaving you hanging.

I printed a pdf from Adobe and to the rear paper slot and it printed fine.
 Printer prompted for inserting of paper into rear slot and printing
proceeded after giving it paper.  I also tried printing to the rear slot
with Libre Calc.  It ignored the rear slot and printed from the default
cassette.  It looks like the problem might lie within Libre.

Thanks again for helping with this.  If I can do anything else to assist,
please let me know.

Dave Detty


On Thu, Apr 18, 2013 at 1:38 AM, <bugzilla-daemon@freedesktop.org> wrote:

>   *Comment # 5 <https://bugs.freedesktop.org/show_bug.cgi?id=60705#c5> on bug
> 60705 <https://bugs.freedesktop.org/show_bug.cgi?id=60705> from Julien
> Nabet <serval2412@yahoo.fr> *
>
> Dave: as Joel asked, are you able to print to rear paper feed with another
> software in Ubuntu?
>
> BTW, I don't think it'll help but it's always interesting to test with last
> stable available version, so did you give a try to 4.0.2? You can find it on LO
> ppa (see https://launchpad.net/~libreoffice/+archive/ppa)
>
>  ------------------------------
> You are receiving this mail because:
>
>    - You reported the bug.
>
>
Comment 7 Dave Detty 2013-04-19 02:46:15 UTC
BTW, I am using the latest version, 4.0.2.


On Thu, Apr 18, 2013 at 10:44 PM, Dave Detty <detty.dave@gmail.com> wrote:

> Sorry for taking so long to get back with you.  I was on travel and didn't
> have the offending Linux/LibreOffice computer to test out your request. I
> really appreciate your help and feel bad about leaving you hanging.
>
> I printed a pdf from Adobe and to the rear paper slot and it printed fine.
>  Printer prompted for inserting of paper into rear slot and printing
> proceeded after giving it paper.  I also tried printing to the rear slot
> with Libre Calc.  It ignored the rear slot and printed from the default
> cassette.  It looks like the problem might lie within Libre.
>
> Thanks again for helping with this.  If I can do anything else to assist,
> please let me know.
>
> Dave Detty
>
>
> On Thu, Apr 18, 2013 at 1:38 AM, <bugzilla-daemon@freedesktop.org> wrote:
>
>>   *Comment # 5 <https://bugs.freedesktop.org/show_bug.cgi?id=60705#c5>on bug
>> 60705 <https://bugs.freedesktop.org/show_bug.cgi?id=60705> from Julien
>> Nabet <serval2412@yahoo.fr> *
>>
>> Dave: as Joel asked, are you able to print to rear paper feed with another
>> software in Ubuntu?
>>
>> BTW, I don't think it'll help but it's always interesting to test with last
>> stable available version, so did you give a try to 4.0.2? You can find it on LO
>> ppa (see https://launchpad.net/~libreoffice/+archive/ppa)
>>
>>  ------------------------------
>> You are receiving this mail because:
>>
>>    - You reported the bug.
>>
>>
>
Comment 8 Joel Madero 2013-04-19 02:49:30 UTC
ah, thanks for testing. This is going to be a terribly tricky one to triage....

michael - additional pointers to confirm and solve this one?
Comment 9 Michael Meeks 2013-04-19 09:40:23 UTC
> Sorry for taking so long to get back with you.  I was on travel and didn't
> have the offending Linux/LibreOffice computer to test out your request. I
> really appreciate your help and feel bad about leaving you hanging.

No problem - so we need a lot more information about your linux system: who is the vendor ? what version is it ? what version of CUPS do you use ?

-How- do you configure the paper-format and tray source ? [ please give screenshots of that, or some concise widget path description File->Print->Properties->Settings->... ;-) for each setting you set ].

Thanks !
Comment 10 Chris Sherlock 2013-05-01 14:16:47 UTC
Hi Dave, we really need some more info about this. Are you using LPD host printing (I'm assuming this is the case). If so, do you have the PPD handy that we can use? Where can we get this from - it seems to be a driver that you have to get directly from Epson themselves, in my Ubuntu system I have to get Gnome Printing to find this model Epson printer because it's not bundled with the distribution version I have.
Comment 11 Dave Detty 2013-05-02 02:23:24 UTC
Created attachment 78746 [details]
attachment-14516-0.html

Hi Julien,

I'm not sure about the LPD host printing.  How do I confirm that for you?
 Attached are the downloads I got from the Epson web site.  If you need
something else, let me know.

Dave


On Wed, May 1, 2013 at 10:16 AM, <bugzilla-daemon@freedesktop.org> wrote:

>  Chris Sherlock <chris.sherlock79@gmail.com> changed bug 60705<https://bugs.freedesktop.org/show_bug.cgi?id=60705>
>  What Removed Added  Status UNCONFIRMED NEEDINFO  Ever confirmed   1
>
>  *Comment # 10 <https://bugs.freedesktop.org/show_bug.cgi?id=60705#c10>on bug
> 60705 <https://bugs.freedesktop.org/show_bug.cgi?id=60705> from Chris
> Sherlock <chris.sherlock79@gmail.com> *
>
> Hi Dave, we really need some more info about this. Are you using LPD host
> printing (I'm assuming this is the case). If so, do you have the PPD handy that
> we can use? Where can we get this from - it seems to be a driver that you have
> to get directly from Epson themselves, in my Ubuntu system I have to get Gnome
> Printing to find this model Epson printer because it's not bundled with the
> distribution version I have.
>
>  ------------------------------
> You are receiving this mail because:
>
>    - You reported the bug.
>
>
Comment 12 Dave Detty 2013-05-02 02:23:25 UTC
Created attachment 78747 [details]
attachment-14516-1.dat
Comment 13 Dave Detty 2013-05-02 02:23:25 UTC
Created attachment 78748 [details]
epson-inkjet-printer-201212w_1.0.0-1lsb3.2_i386.deb
Comment 14 Dave Detty 2013-05-02 02:23:25 UTC
Created attachment 78749 [details]
epson-inkjet-printer-escpr_1.2.2-1lsb3.2_i386.deb
Comment 15 Joel Madero 2013-05-02 02:41:15 UTC
Please provide screenshots that Michael requested as well :)
Comment 16 Dave Detty 2013-05-02 03:18:01 UTC
Created attachment 78752 [details]
attachment-21344-0.html

Sorry, I missed the earlier email asking about system info and printer
setup screen shots.  Linux is Ubuntu 12.04 LTS with latest software
updates.  Are these the screenshots wanted?


[image: Inline image 1]
[image: Inline image 2]
[image: Inline image 3]
[image: Inline image 4]
[image: Inline image 5]
[image: Inline image 6]


On Wed, May 1, 2013 at 10:41 PM, <bugzilla-daemon@freedesktop.org> wrote:

>   *Comment # 15 <https://bugs.freedesktop.org/show_bug.cgi?id=60705#c15>on bug
> 60705 <https://bugs.freedesktop.org/show_bug.cgi?id=60705> from Joel
> Madero <jmadero.dev@gmail.com> *
>
> Please provide screenshots that Michael requested as well :)
>
>  ------------------------------
> You are receiving this mail because:
>
>    - You reported the bug.
>
>
Comment 17 Dave Detty 2013-05-02 03:18:02 UTC
Created attachment 78753 [details]
attachment-21344-1.dat
Comment 18 Dave Detty 2013-05-02 03:18:02 UTC
Created attachment 78754 [details]
image.png
Comment 19 Dave Detty 2013-05-02 03:18:02 UTC
Created attachment 78755 [details]
image.png
Comment 20 Dave Detty 2013-05-02 03:18:02 UTC
Created attachment 78756 [details]
image.png
Comment 21 Dave Detty 2013-05-02 03:18:02 UTC
Created attachment 78757 [details]
image.png
Comment 22 Dave Detty 2013-05-02 03:18:02 UTC
Created attachment 78758 [details]
image.png
Comment 23 Dave Detty 2013-05-02 03:18:02 UTC
Created attachment 78759 [details]
image.png
Comment 24 Paul Kahlert 2013-11-08 02:58:32 UTC
Has there been any updates on this bug? I find that Libreoffice 4.0.2.2 (Build ID: 400m0(Build:2) only prints to the default paper tray no matter what setting I use at print time. Firefox, Document viewer, GIMP and other programs use the tray (cassette) selected. I have the Epson WF-3530 wired networked, Ubuntu 13.10 32bit, Cups 1.6.2, printer connections tried either IPP via DNS-SD or LPD/LPR queue passthru (I've also tryed using USB, but no difference. Driver: epson-inkjet-printer-201212w_1.0.0-1lsb3.2_i386. Openoffice 4 also acts like Libreoffice.
Comment 25 Michael Meeks 2013-11-08 10:04:51 UTC
> Has there been any updates on this bug ?

No progress. I imagine that our PDF output is nailing the wrong attribute into the PDF which causes the issue. What I suggest is that you create a -very- simple:

'Hello world'

document - in HTML, load it in firefox and also writer - print to CUPS - and try to steal the PDF meta-files out of the queue before they are printed and/or deleted.

Then find some PDF wizardry to de-compress / pretty-print them to plain-text, and then do a diff -u of the relevant page setup / handling pieces.

That in turn should allow us to find the exact piece of code that generates the wrong header & tweak it easily. It's a chunk of work, but there is ~no-one with the skills to sit down and do this any more easily than any user.

If you provide a description of the exact attribute that should be changed / removed / whatever in the header, along with a convincing and precise rational for that - then I'll find a developer to make the code fix :-)

Thanks !
Comment 26 Paul Kahlert 2013-11-08 18:14:11 UTC
> Then find some PDF wizardry to de-compress / pretty-print them to plain-text,

  Thanks for the reply. Any pointers on de-compressing, converting to text?
Comment 27 Paul Kahlert 2013-11-10 03:08:49 UTC
Created attachment 88954 [details]
Epson WF-3530 Print Job Attributes

Calc sheet showing attributes that are not sent by LibreOffice compared to Mozilla Firefox and gedit.
Comment 28 Paul Kahlert 2013-11-10 03:12:58 UTC
Attachment added to show attributes not included from LibreOffice print job. I believe the attribute "InputSlot" is the main attribute missing in this case.

  Thanks for any help.
PK
Comment 29 Michael Meeks 2013-11-11 09:51:47 UTC
Wow - that's a great analysis; how did you extract the PDFs from CUPS (out of interest) ? and I guess we need to find a developer to unwind how to get the InputSlot from the print dialog -> the generated PDF metafile :-)

Thanks !
Comment 30 Paul Kahlert 2013-11-11 14:05:36 UTC
  Thanks! Well, I found the queue files in /var/spool/cups directory. After putting the printer offline, I could then view the job attributes to see the names (and values) that Libreoffice doesn't pass on even though the options are available via Libreoffice's print dialog. I was surprised.

  Also, even though I think the InputSlot would take care of the reason I searched for this, it would be great if the developers could include the rest of the attribues not passed on. I included all attributes found from other applications even if Libreoffice passed them on, just to be as complete as possible.

  Thanks for offering, and passing on, the baton.
Comment 31 Paul Kahlert 2013-11-11 16:14:49 UTC
If it matters-

  This also happens running:
Ubuntu 12.04LTS 32bit
CUPS 1.5.3
OKI B6300 printer via network socket port 9100
LibreOffice 3.5.7.2 Build ID: 350m1(Build:2)
Comment 32 Joel Madero 2013-11-11 18:00:46 UTC
Updated version per last comment. Our version field is not like many other projects - we use it for the earliest version the problem is confirmed instead of the latest it's confirmed on. We use comments to say "still a problem with x.x.x.x

Also - I agree with Michael, great triage work here :) If you ever have some time to help out QA - we're always in need of people, especially people who have some great ability to "dig deeper". Send me an email if you have a little free time to help us out (currently our unconfirmed bug list is about 1,200 large) :)


Thanks!
Comment 33 Commit Notification 2013-12-06 20:55:23 UTC
Andrzej Hunt committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4c160e3d54ec1c6c04bc80c6cec7ee58e20af3bb

fdo#60705 Don't discard valid printing options.



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 34 Commit Notification 2013-12-06 20:56:44 UTC
Andrzej Hunt committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=85b6167276e6dc1298e9343af06cafb0ea1fde98&h=libreoffice-4-2

fdo#60705 Don't discard valid printing options.


It will be available in LibreOffice 4.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 35 Andrzej Hunt 2013-12-06 21:14:20 UTC
(Printing to the rear paper feed slot on my Epson EF-3520 now works, so fixed I guess...)

In fact it turns out we were binning any print-option which didn't have a comment in the PPD, which is in fact the case for most options (a sanity check mistakenly checked that we had a comment, whereas presumably it was intended to instead ensure that there was in fact an option).

(Page size has a comment including the page dimensions hence it worked fine -- most options don't seem to have such a comment, e.g. InputSlot.)