Bug Hunting Session
Bug 60717 - LibreOffice 4.0 Calc FIND function error
Summary: LibreOffice 4.0 Calc FIND function error
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.4.3 release
Hardware: x86 (IA32) Windows (All)
: medium major
Assignee: Football_Club_Barcelona
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-12 09:52 UTC by Football_Club_Barcelona
Modified: 2013-12-15 23:43 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot for the font viewing bug (272.36 KB, image/jpg)
2013-02-12 09:52 UTC, Football_Club_Barcelona
Details
an example .xls file attached to the comment 5 (60.00 KB, application/vnd.ms-excel)
2013-04-23 19:52 UTC, Football_Club_Barcelona
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Football_Club_Barcelona 2013-02-12 09:52:28 UTC
Created attachment 74669 [details]
screenshot for the font viewing bug

I use LO with Polish localisation and have the following problems:
- since the version 3.6.4 of LO, something is messed with the find function - it does work, though it doesn't look for EXACT phrases, but only for phrases which are ALIKE to the searched ones; and it has problems finding numbers, especially if it is to search for numbers which are part of larger numbers (= phone numbers). I thought you would fix it until 4.0 but it seems nobody has noticed it.

- in 4.0, my default Microsoft Office 07 font (calibri?) doesn't look well - I attach a screenshot so that you may see. The bug wasn't present in the previous versions.

LO also divides spreadshets into pages differently than  Microsoft Office (and OO.org) in that it can divide a file that MO and OO.org treat as 1-page into 4 pages - though it seems not to be a bug but a difference.
Comment 1 Timur 2013-03-21 13:53:08 UTC
I don't know whether we have the same problem with FIND but sometimes I simply cannot find what I'm looking for with libreoffice-4-0~2013-03-18_07.00.22_LibO-Dev_4.0.3.0_Win_x86 version. 
The problem is random and difficult to locate, but it happens if I search for some part of the word. If I search for the whole word, it finds it. It's like "Whole word only" is on, while it's not.
Looks OK with LO 4.0.2.1. but I cannot be sure.


For other 2 problems, please search the Bug List first. Generally, each must be open separately with clear description. But, they don't look like bugs at all. If you agree, title should be edited.
Comment 2 Timur 2013-03-21 14:03:20 UTC
Correction:
The problem happens like if "Match Case" (not "Whole word only" like I wrote) is on, while it's not.
It's the same with Find toolbar or Find&Replace dialog.
Comment 3 Football_Club_Barcelona 2013-04-01 09:25:21 UTC
I' ve changed the title, as the font viewing issue did not seem to be a bug indeed, and I've learned how to deal with dividing spreadsheets into pages.
Comment 4 Joel Madero 2013-04-14 17:05:33 UTC
We need explicit steps to reproduce the problem.


@Football_Club_Barcelona - when reporting a bug please do the following:

1. 1 bug = 1 report, never put  multiple issues on a single report as it makes it impossible to assign the bug, and very difficult to triage

2. Detail your bug in numbered steps, detail how to reproduce the issue with easy to follow steps.

3. Explain "observed" and "expected" so we can verify that we observe what you observe and so that we understand what you expect to happen.

4. Include your OS and your current (latest tested) LibreOffice version.

5. When setting "Version" field it is the OLDEST version that you have seen the issue, not the latest which it has been tested - I am changing this bug to 3.6.4 as you said you experienced it then.


Marking as this as NEEDINFO, once you provide all the necessary information, mark as UNCONFIRMED and someone will take a look at it.
Comment 5 Timur 2013-04-16 13:01:47 UTC
Due to Comment 3, it's only an issue of LibreOffice 4.0 Calc FIND function error now. 

There might be 2 different problems, and Football_Club_Barcelona may describe his, but I describe mine here:
- download and install LO Dev, I use libreoffice-4-0~2013-03-31_16.47.37_LibO-Dev_4.0.3.0_Win_x86
- create new text document, write the same text in small and capital letters
- Find toolbar or Find&Replace dialog behave like "Match Case" is on, while it's not, and a word can't be found if the case id different

I don't have problems with LibreOffice_4.0.2.2_Win_x86 or any other final version.
Comment 6 Football_Club_Barcelona 2013-04-23 19:52:13 UTC
Created attachment 78395 [details]
an example .xls file attached to the comment 5
Comment 7 Football_Club_Barcelona 2013-04-23 19:53:06 UTC
Thanks Joel Madero,

1) sorry
2)a) create a file containing much numbers and/or names (I attach an example)
  b) try to find one of the names (column 1 in the example) or a part of a number (e.g. a 3-digit number constituting a part of a larger combination - in the attached file, of a phone number - column 3)
3) expected: LO always finding the exact phrase/name v. the exact number typed (even when it is a part of one/many of the the numbers in column
observed: LO often finding words which are alike to the searched one in addtion to (or instead of) the one searched one v. not finding parts of numbers at all
4) Windows XP Media Center 2005 SP3, LO 4.0.0.2
5) sorry again
I wrote this from my memory, as at the moment I am using LO 3.6.2.2

I change the bug back into UNCONFIRMED
Comment 8 Football_Club_Barcelona 2013-04-23 19:55:43 UTC
sorry, the .xls file is concerned with the comment 7
Comment 9 Timur 2013-05-09 08:28:49 UTC
We have 2 reporters here. My problem is a duplicate od Bug 63779 - search is always case sensitive. 
If Football_Club_Barcelona@interia.pl agrees, it should be marked as that.
Comment 10 Joel Madero 2013-06-28 00:18:37 UTC
I did a test with the # 230 and it seemed to work fine with 4.1 RC1.

Marking as WFM

@Football_Club_Barcelona - if this is still an issue with 4.0.3 or even better 4.1 RC1 please give me an exact # to search for an let me know what it's finding/not finding that's incorrect so that I know exactly what to look for instead of just randomly putting in a number and see if it looks like it works.


Thanks!