Bug 60757 - PDF: PDF export of SVG images distorted
Summary: PDF: PDF export of SVG images distorted
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-13 01:03 UTC by Xavier Orr
Modified: 2014-11-22 20:09 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
ODT document with SVG image that becomes distorted upon export to PDF (102.22 KB, application/vnd.oasis.opendocument.text)
2013-02-13 01:03 UTC, Xavier Orr
Details
PDF export of ODT document (61.01 KB, application/pdf)
2013-02-13 07:52 UTC, Xavier Orr
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xavier Orr 2013-02-13 01:03:44 UTC
Created attachment 74717 [details]
ODT document with SVG image that becomes distorted upon export to PDF

Problem description: Since the switch to vector graphics PDF export in LibreOffice 4.0.0, some SVG images become heavily distorted when exported to PDF. A portion of the vector graphics appears to be being rasterized.

Steps to reproduce:
1. Download attached ODT file
2. Export to PDF

Current behavior: Image is distorted

Expected behavior: Image is not distorted

              
Operating System: Mac OS X
Version: 4.0.0.3 release
Comment 1 Thomas van der Meulen 2013-02-13 07:44:35 UTC
Thank you for reporting this bug,
I can't repoduce this bug running LibreOffice 4.0.0.3 on Mac osx 10.6.8.
Comment 2 Xavier Orr 2013-02-13 07:52:45 UTC
Created attachment 74723 [details]
PDF export of ODT document
Comment 3 Xavier Orr 2013-02-13 15:20:18 UTC
(In reply to comment #1)
> Thank you for reporting this bug,
> I can't repoduce this bug running LibreOffice 4.0.0.3 on Mac osx 10.6.8.

Hi, are you sure ? it is the icon that gets distorted, not the text. I have now tested on Windows, Linux and Mac with the same result, so doesn't seem to be platform dependent.

All our company's user manuals are in ODT, so we are pretty keen to get this fixed. We are willing to offer a bounty of USD 300 if someone can fix this quickly.
Comment 4 Thomas van der Meulen 2013-02-15 10:11:54 UTC
Sorry for the first comment, I didn't sow the diffent furt but with the attached of the pdf I do.
So now I can reporduce this bug running LibreOffice 4.0.0.3 on Windows 7,Mac osx 10.6.8 and Ubuntu 12.10.
Comment 5 Alexandr 2014-11-22 20:09:42 UTC
I do not reproduce the bug with LibreOffice 4.4.0.0beta1 on Windows 7. As far as I do not know which patch solves the problem, I set the bug status to RESOLVED WORKSFORME. Please, set it to UNCONFIRMED if you can reproduce the issue with LibreOffice 4.4.0.0.-beta1 or later and provide pdf export setting that you use.