Bug 60762 - PRINTING: Images in spreadsheet do not print or export to PDF
Summary: PRINTING: Images in spreadsheet do not print or export to PDF
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.5.6.2 release
Hardware: Other All
: medium major
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-13 03:06 UTC by windyplayer
Modified: 2015-12-21 15:33 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
A spreadsheet with images. (407.14 KB, application/x-vnd.oasis.opendocument.spreadsheet)
2013-02-13 03:06 UTC, windyplayer
Details
Page style dialog. (41.03 KB, image/png)
2014-10-03 22:26 UTC, Dave Barton
Details

Note You need to log in before you can comment on or make changes to this bug.
Description windyplayer 2013-02-13 03:06:31 UTC
Created attachment 74721 [details]
A spreadsheet with images.

Problem description: Images in spreadsheets do not print, or convert to pdf.

Steps to reproduce:
1. Create a spreadsheet.
2. Add one or more images to cells using Insert / Picture / From file. Resize the images as desired.
3. Attempt to print or export the file to PDF. Use Print Preview if you like.

Current behavior: The images are not displayed.

Expected behavior: The images display on the printed page, or the PDF as they do on the spreadsheet on the screen.

              
Operating System: Windows 7
Version: 4.0.0.3 release
Comment 1 Thomas van der Meulen 2013-02-13 07:30:14 UTC
Thank you for reporting this bug,
I can reproduce this bug running LibreOffice 4.0.0.3 on Winows 7.
Comment 2 Timur 2013-03-06 14:57:26 UTC
I can reproduce this bug running LibreOffice 4.0.1.2 and 3.5.6.2 on Winows 7 and 3.5.7.2 on Ubuntu.
So, I changed Version (earliest!) and Platform. Please correct with some more detailed tests.
Comment 3 tommy27 2014-10-03 14:30:17 UTC
also reproducible on Win7x64 using 4.3.1.2.
haven't tried master.
Comment 4 Dave Barton 2014-10-03 22:26:54 UTC
Created attachment 107289 [details]
Page style dialog.
Comment 5 Dave Barton 2014-10-03 22:28:16 UTC
Tested Version: 4.3.1.2
Build ID: 958349dc3b25111dbca392fbc281a05559ef6848
Windows 7 Ultimate X64 & PCLinuxOS 64

Open the sample spreadsheet then set/check "Page Style -> Sheet" to "Print -> Objects/Images" (see attached image) and the images print/export to pdf.
This is expected behavior and not a bug.
Comment 6 windyplayer 2014-10-04 02:06:56 UTC
So apparently this changes from a Bug to a Suggestion to make this process easier and the option to be easier to find. Or change the default to the expected result, which is to display the images.

For Version: 4.1.2.3
Format menu > Page... > Sheet > check Objects / graphics

Export PDF
Observe that the images are present in the PDF file.

Thanks. Wonder why it took over a year to get this answer?
- wp
Comment 7 tommy27 2014-10-04 06:53:37 UTC
Dave Barton is right.
the issue is due to the page style of that specific file.

I double checked on a fresh new install of 4.3.2.2 and I see that default style setting have "Object/image" ticked so if you create a new file from scratch image will be correctly printed and exported to PDF unless you intentionally disable that option.

so bottom line is this is NOTABUG and I'm gonna removing it from mab4.2

so windiplayer please check your default style settings and specific files style settings.