Bug 60766 - BUGZILLA: Remove Android Impress Remote Versions
Summary: BUGZILLA: Remove Android Impress Remote Versions
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: WWW (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-13 06:45 UTC by Rainer Bielefeld Retired
Modified: 2013-08-31 14:21 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2013-02-13 06:45:11 UTC
I am not happy with the current solution for this, the Versions between the LibO versions make the system unclear, that might break Queries, look 
Will we get Versions for Dictionaries here, too? :-/

That can't work!

If we want to track AIR Version related bugs (currently I don't think that that really is necessary, but I do not know very much concerning that project), we should Ask FDO for a new Product.

A Component should have some kind of Sub Components (please also see Bug 60059), I can't find anything on <https://wiki.documentfoundation.org/BugReport_Detail>
Are there already some ideas/plans?

I think there should be some Mailing list discussion with creation of some Wiki manual in parallel as we had when we created the LibO Version (<http://lists.freedesktop.org/archives/libreoffice-qa/2012-June/001822.html>)

As a first step to integrate this new feature I created a new "PRESENTATION Sub Component" for problems with Impress (not the AIR) related to remote control:
<https://wiki.documentfoundation.org/index.php?title=BugReport_Details&diff=63190&oldid=62665>, what already finds some Bugs here <https://bugs.freedesktop.org/buglist.cgi?query_format=advanced&component=Presentation&product=LibreOffice&short_desc=REMOTE&short_desc_type=allwordssubstr&list_id=231008>.

Please feel free to improve wording if you think precision of hits can be improved.
Comment 1 Marc Pare 2013-02-13 16:44:49 UTC
On the wiki, you write " ... for Problems in IMPRESS related to Android Impress Remote (for Problems with Android Impress Remote  please use different Component),"

Is it just me, but is this a contradiction? Is this what you really wanted to write or did you want to say:

" for Problems in IMPRESS related to Android Impress Remote (for Problems with running Presentations please use different Component)"

Cheers,

Marc
Comment 2 Rainer Bielefeld Retired 2013-02-13 17:09:49 UTC
(In reply to comment #1)
I tried to make my intention some more visible on <https://wiki.documentfoundation.org/BugReport_Details#Presentation>, the thing what is not part of the discussion here and on qa miling list.
Comment 3 Robinson Tryon (qubit) 2013-02-13 19:50:28 UTC
I'm confused about this bug report, but perhaps that's the primary issue: confusion.

There's mention of a "Wiki manual", but that sounds like a separate issue. The most pressing concern is that we're trying to fit two separate projects (LibreOffice and the Android Impress Remote) into a single instance of Bugzilla, and it's causing confusion and pain.

There has been previous discussion about improving our bugtracking system, but AFAIK, no updates since July of last year:

https://wiki.documentfoundation.org/How_to_Improve_Bugzilla
https://wiki.documentfoundation.org/QA-ImprovingBugzilla

I believe that the first thing to do would be to figure out the current status of Bugzilla and our planned updates to it, and then figure out what to do with the Impress Remote.

Given the way that Bugzilla is designed, it sounds Rainer's suggestion for a new top-level FDO project is the easiest course of action:

> If we want to track AIR Version related bugs 
> (currently I don't think that that really is
> necessary, but I do not know very much
> concerning that project), we should Ask FDO
> for a new Product.

(Note: While I agree with Rainer regarding a new top-level project, I disagree with him regarding version #'s. I think version #'s may be helpful in determining whether a particular build of AIR contains certain features or bugs)
Comment 4 Rainer Bielefeld Retired 2013-02-13 21:36:34 UTC
(In reply to comment #3)
> I believe that the first thing to do would be to figure out the
> current status of Bugzilla and our planned updates to it, and then
> figure out what to do with the Impress Remote.

Yes, that's the plan. We have to rethink how we handle development of code outside the core "product", you should meet discussion in <http://lists.freedesktop.org/archives/libreoffice-qa/2013-February/003650.html> on the mailing list.
Comment 5 Michael Meeks 2013-03-01 18:32:24 UTC
Certainly an issue - confirming it :-) as I said on the list, we could reasonably easily create a new top-level bugzilla thing for it.
Comment 6 Rainer Bielefeld Retired 2013-03-01 19:12:14 UTC
Before we involve FDO we should know exactly what we want, for definitions I created separate, related "Bug 61669 - BUGZILLA: Create new Product for "LibreOffice Android Impress Remote""
Comment 7 tommy27 2013-08-31 14:21:12 UTC
I do not see any "Android Impress Remote" Versions in the Version field.
"Android Impress Remote" is just present in the Component field.

I suppose that it was fixed in Bugzilla but nobody closed this report.
so I doing it now.