Download it now!
Bug 60780 - 'Save a Copy' command
Summary: 'Save a Copy' command
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.0.0.alpha1
Hardware: All All
: high enhancement
Assignee: Ádám Csaba Király
URL:
Whiteboard: target:4.1.0
Keywords:
Depends on:
Blocks: 73825
  Show dependency treegraph
 
Reported: 2013-02-13 10:16 UTC by Tim Jones
Modified: 2014-07-22 10:56 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tim Jones 2013-02-13 10:16:49 UTC
Problem description: Please allow 'exporting' of various document formats to allow the open document to stay with the same file/format in a similar way to the current export as PDF.

Steps to reproduce:
1. .... Open an ODF document.
2. .... Save as another format, eg. '.doc'.
3. .... You're now editing the '.doc' document and not the original ODF one.

Current behavior: Saving as another format switches to edit that saved format.

Expected behavior:

              
Operating System: Debian
Version: 4.0.0.0.alpha1
Comment 1 Joel Madero 2013-02-13 18:01:25 UTC
So you're talking about like how Gimp now does "export" vs. Save As? 

Personally I don't like that system but want to verify that it's what you're talking about.

What are the benefits of this?
Comment 2 Joel Madero 2013-02-13 18:03:07 UTC
Marked as NEEDINFO just until we get the pro's of adding export vs. just save as. 

My concern is two fold:

1. People are used to save as

2. People might export a .doc, continue editing the file, forget that they have to export a .doc again and then end up submitting or showing an older file that they forgot to re-export (instead they just did a ctrl + s and saved it as a odt alongside the older exported .doc)
Comment 3 Joel Madero 2013-02-13 18:04:30 UTC
Forget that - If it's a whole new command ("save a copy") I think that makes sense. Marking as NEW.

Sorry Tom for the 3 posts!

Probably relatively easy to do as well. Marking as ProposedEasyHack
Comment 4 Tim Jones 2013-02-13 18:13:35 UTC
(In reply to comment #3)
> Forget that - If it's a whole new command ("save a copy") I think that makes
> sense. Marking as NEW.
> 
> Sorry Tom for the 3 posts!
> 
> Probably relatively easy to do as well. Marking as ProposedEasyHack

Hi Joel, yes that'd be the idea - more of a 'save a copy as ...' command.

The inspiration for it came when editing had been lost due to being asked for a 'Word' copy of the ODT doc I was currently editing, saved it as a '.doc' file, then continued editing. I then went on to save it and close it, then deleted the doc version assuming I'd saved it as the original ODF file!
Comment 5 Commit Notification 2013-03-25 20:45:43 UTC
Adam Csaba Kiraly committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0e1617554c34e62a467a5e1a188353178211e8fe

fdo#60780, Save a Copy wip



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 6 Tim Jones 2013-03-25 20:51:29 UTC
Cool, thanks Adam & Joel! :)
Comment 7 Commit Notification 2013-05-02 09:44:55 UTC
Adam Csaba Kiraly committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7061e8403a3afddae253ad0a016e5613616030bb

fdo#60780, refactor Save a Copy and fix



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 Heiko 2014-07-15 21:57:11 UTC
1st: This works like a charm! Thanks to you, Adam & Joel.

Unfortunately, a "Save a Copy" is missing in the other Components, esp. Calc and Impress and breaks a littble bit user expectations, though a user could fix this by customizing the menu on his own: Adding a "document - save a copy" is possible and seem to work. Having it as default would be nicer.

libreoffice/core/sc/uiconfig/scalc/menubar/menubar.xml:
  <menu:menuitem menu:id=".uno:Save"/>
  <menu:menuitem menu:id=".uno:SaveAs"/>
  <menu:menuitem menu:id=".uno:SaveAsTemplate"/>
+ <menu:menuitem menu:id=".uno:SaveACopy"/>
  <menu:menuitem menu:id=".uno:SaveAll"/>

libreoffice/core/sd/uiconfig/simpress/menubar/menubar.xml:
  <menu:menuitem menu:id=".uno:Save"/>
  <menu:menuitem menu:id=".uno:SaveAs"/>
+ <menu:menuitem menu:id=".uno:SaveACopy"/>
  <menu:menuitem menu:id=".uno:SaveAll"/>


libreoffice/core/sd/uiconfig/sdraw/menubar/menubar.xml
  <menu:menuitem menu:id=".uno:Save"/>
  <menu:menuitem menu:id=".uno:SaveAs"/>
+ <menu:menuitem menu:id=".uno:SaveACopy"/>
  <menu:menuitem menu:id=".uno:SaveAll"/>

Sorry, I'm not used to submit patches, but could you - Adam or Tim - have a look at this?

That would also fix https://bugs.freedesktop.org/show_bug.cgi?id=73825 (enhancement).
Comment 9 Björn Michaelsen 2014-07-22 10:46:42 UTC
(In reply to comment #8)
> Unfortunately, a "Save a Copy" is missing in the other Components, esp. Calc
> and Impress and breaks a littble bit user expectations, though a user could
> fix this by customizing the menu on his own.

Please dont feature creep this issue. If its also needed in other components, please file a new enhancement request against those (and reference this one).

Closing as it seems to be done in Writer.