Download it now!
Bug 60790 - UI: "Select All" shortcut into font field is not effient
Summary: UI: "Select All" shortcut into font field is not effient
Status: RESOLVED DUPLICATE of bug 49853
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: Other Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks: MacOS-Wishlist
  Show dependency treegraph
 
Reported: 2013-02-13 13:34 UTC by Daniel L
Modified: 2016-04-28 11:38 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel L 2013-02-13 13:34:44 UTC
Problem description: Using "Select All" keyboard short into the font field make a "Select All" into the current document

Steps to reproduce:
1. Click into Font field
2. Press Command+A

Current behavior: Select the entire document and flush the font field

Expected behavior: Select the entire font name into the font field

              
Operating System: Mac OS X
Version: 4.0.0.3 release
Comment 1 Daniel L 2013-02-13 13:41:17 UTC
Further more, the font modicafition applied on the current document selection ie the entire document.
Comment 2 Joel Madero 2013-03-21 18:23:55 UTC
Cannot confirm on Bodhi Linux running 4.1 master - maybe OSX only issue

Joren - mind testing?
Comment 3 Daniel L 2013-03-22 07:37:28 UTC
Bug still alive in 4.0.1.3 on MacX
I will test on Windows XP in few hours.
Comment 4 Daniel L 2013-03-22 13:08:36 UTC
Cannot confirm on Windows XP too
Version 4.0.0.3 (Build ID: 7545bee9c2a0782548772a21bc84a9dcc583b89)
Comment 5 Jorendc 2013-03-22 16:51:31 UTC
Thanks for reporting!

I can confirm this behavior. This proves there is something very broken related to the focusing of LibreOffice on Mac OSX.

This may be a duplicate of bug 49853 and others related to this topic, but I'm going to put it only in the 'See Also' field for now.

I'm not going to change the priority of the bug (Normal Medium) looks fine to me. I see bug 49853 has priority 'major medium', so this topic will get some importance via that way.

Kind regards,
Joren
Comment 6 QA Administrators 2015-03-04 02:19:51 UTC Comment hidden (obsolete)
Comment 7 Alex Thurgood 2015-03-25 17:16:26 UTC
It is not just the Font selector, but also occurs in the Style selector and Font size selector. Badly broken indeed.

Version: 4.4.1.2
Build ID: 45e2de17089c24a1fa810c8f975a7171ba4cd432
Locale : fr_
Comment 8 tommy27 2016-04-16 07:26:38 UTC Comment hidden (obsolete)
Comment 9 Maxim Monastirsky 2016-04-28 11:38:51 UTC

*** This bug has been marked as a duplicate of bug 49853 ***