Bug 60856 - KDE: Background in some dialogs is not rendered with oxygen-gtk
Summary: KDE: Background in some dialogs is not rendered with oxygen-gtk
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.1.0.0.alpha0+ Master
Hardware: Other Linux (All)
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: (target:4.1.2)
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-14 19:16 UTC by Ruslan Kabatsayev
Modified: 2013-09-29 18:04 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screenshot of bug (49.26 KB, image/png)
2013-02-14 19:16 UTC, Ruslan Kabatsayev
Details
How it looks in 4.0 (and should look) (46.00 KB, image/png)
2013-02-14 19:17 UTC, Ruslan Kabatsayev
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ruslan Kabatsayev 2013-02-14 19:16:06 UTC
Created attachment 74832 [details]
Screenshot of bug

How to reproduce:
0. Set oxygen-gtk as current GTK theme, make LibO use GTK theming
1. Start Calc
2. Right click on a cell
3. Format cells
4. See newly opened dialog

This doesn't reproduce with Version 4.0.0.1+ (Build ID: baa9a119dabfc5e5dbb5c174cebf8c24298bad6), but does with Version 4.1.0.0.alpha0+ (Build ID: 5cd036c0742f8be8d6fc34f7e3a983cae557d94)
Comment 1 Ruslan Kabatsayev 2013-02-14 19:17:00 UTC
Created attachment 74833 [details]
How it looks in 4.0 (and should look)
Comment 2 Thomas Arnhold 2013-02-15 13:28:54 UTC
The formatting tab page was converted to the new ui format in december.

http://cgit.freedesktop.org/libreoffice/core/commit/?id=43137f06505324b73ff66420c63e40b37a8d0618
Comment 3 Ruslan Kabatsayev 2013-02-15 21:15:39 UTC
In fact, you don't need KDE to use oxygen-gtk.

Now, about the bug itself. It appears that all the tab pages in this dialog have one rectangle at top left which has bg gradient, but is misplaced.
I'm not sure what part of the commit broke it, but here's something what should be taken into account: oxygen-gtk uses both of xy and wh coordinates to determine how to position and render its bg gradient. Failure to specify xy coords as they are expected (pixmapXY-controlXY) may lead to misplaced gradient and/or misplaced whole image. See [1] and [2] for details.

[1]: http://cgit.freedesktop.org/libreoffice/core/commit/?id=7d0d52fb758249a7d6b8fc5e36c0e77354e5f5c3
[2]: https://projects.kde.org/projects/playground/artwork/oxygen-gtk/repository/revisions/49be93c4ae4d8f9af3237930e945cbecba669171/diff
Comment 4 Joel Madero 2013-04-17 16:26:16 UTC
Cannot confirm on Bodhi Linux with either 4.0.1.2 release nor 4.1 master
Comment 5 Ruslan Kabatsayev 2013-05-05 10:05:18 UTC
This appears to be not exactly reproducible with steps I gave in comment 0, so here's some refinement on how to reproduce:
0. Set oxygen-gtk as current GTK theme, make LibO use GTK theming
1. Start Calc
2. Right click on a cell
3. Format cells
4. See the dialog. If it has Numbers tab open by default, you should have reproduced the bug. If it has some other tab, e.g. Alignment open by default, the bug doesn't reproduce.
5. If you didn't reproduce the bug and open tab wasn't Numbers, open Numbers and close the dialog, quit LibO
6. Repeat steps 1-4
Comment 6 Maxim Monastirsky 2013-09-09 16:30:56 UTC
Reproducible with LO 4.1.1.2 under both Fedora 19 & Ubuntu 13.10. Doesn't matter which tab opened by default.

Workaround: Resize the dialog
Comment 7 Maxim Monastirsky 2013-09-09 16:37:02 UTC
(In reply to comment #6)
> Workaround: Resize the dialog
Just to clarify: It helps only with the dialog content painting, not with the tab bar itself.
Comment 8 Maxim Monastirsky 2013-09-29 14:37:14 UTC
Not reproducible anymore with 4.1.2.2. Tested on the same machines as previously (comment 6). Tested both packages from repositories & from libreoffice.org. Setting as WFM.
Comment 9 Joel Madero 2013-09-29 15:29:22 UTC
Thanks for the heads up. In general we just use target for FIXED bugs, not for WFM :) but perhaps this could change, I will bring it up with QA team
Comment 10 Ruslan Kabatsayev 2013-09-29 15:56:56 UTC
I can confirm it appears fixed.
Comment 11 Maxim Monastirsky 2013-09-29 17:18:10 UTC
(In reply to comment #9)
> Thanks for the heads up. In general we just use target for FIXED bugs, not
> for WFM :) but perhaps this could change, I will bring it up with QA team
Hi,
I just followed the instructions from the wiki:
https://wiki.documentfoundation.org/QA/Bugzilla/FAQ#How_to_terminate_a_Bug_if_it_can.27t_be_reproduced_any_longer
https://wiki.documentfoundation.org/QA/Bugzilla/Fields/Whiteboard#Releases
Comment 12 Joel Madero 2013-09-29 18:04:00 UTC
haha go figure that after being involved for 18+ months I still don't know all the nuances, thanks for the heads up. I still am going to ask about this because as far as I know, no QA member does this as it's just too time consuming to figure out "the first version that it works"