Bug Hunting Session
Bug 60862 - Support LibreOffice on the Android platform
Summary: Support LibreOffice on the Android platform
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other other
: high enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-14 22:02 UTC by Robinson Tryon (qubit)
Modified: 2015-05-23 17:31 UTC (History)
13 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Comment 1 Robinson Tryon (qubit) 2013-02-14 22:03:15 UTC
Per jmadero,
UNCONFIRMED -> NEW
Comment 2 Miklos Vajna 2013-02-28 13:31:01 UTC
Daily builds are available at <http://dev-builds.libreoffice.org/daily/master/Android-ARM@24-Bytemark-Hosting/current/>.
Comment 3 a 2013-05-02 05:24:04 UTC
Presumably -mfpu=neon means the builds will not run on Tegra 2.
Comment 4 Don't use this account, use tml@iki.fi 2013-06-15 08:28:01 UTC
This is totally pointless here in bugzilla.
Comment 5 Robinson Tryon (qubit) 2013-06-15 17:42:00 UTC
(In reply to comment #4)
> This is totally pointless here in bugzilla.

When you say "this," do you mean this enhancement/tracking bug, this discussion about the Android version, or??

Here's my thought process:

1) We have a *great many* users/potential users asking for an Android build of LibreOffice.

2) There is general agreement in the QA Team that enhancement requests should live in Bugzilla.

3) Therefore, I added an enhancement bug to Bugzilla.


What would you suggest that we do differently here?
Comment 6 Don't use this account, use tml@iki.fi 2013-06-17 09:13:25 UTC
A LibreOffice-based app for Android isn't just an "enhancement".
Comment 7 Don't use this account, use tml@iki.fi 2013-06-17 09:15:01 UTC
And the title of this bug makes it sound as if all that's needed is just for builds to be provided.
Comment 8 Jérôme 2013-06-19 08:09:40 UTC
For you information, there is now the AndrOpen Office application here :
http://play.google.com/store/apps/developer?id=andropenoffice.com
Comment 9 Michael Meeks 2013-06-19 09:35:15 UTC
Thanks - we continue to invest in this area at a low level - patches are much appreciated :-)
Comment 10 Edmund Laugasson 2013-07-22 22:41:48 UTC
(In reply to comment #2)
> Daily builds are available at
> <http://dev-builds.libreoffice.org/daily/master/Android-ARM@24-Bytemark-
> Hosting/current/>.

Tried LibreOffice4Android-debug.apk on Android 4.2.2 but could not find a way to open document as shown here:
https://people.gnome.org/~michael/blog/2012-07-03-libreoffice-android.html
http://www.youtube.com/watch?v=E2vNTkTQi60 - interview and demo
So - how to open a document? There is no "Open document" choice :(
Comment 11 Don't use this account, use tml@iki.fi 2013-07-23 06:19:57 UTC
I still think this bug makes no sense at all. Already the first sentence in the initial comment is totally misleading.
Comment 12 Robinson Tryon (qubit) 2013-07-23 14:53:28 UTC
(In reply to comment #11)
> I still think this bug makes no sense at all. Already the first sentence in
> the initial comment is totally misleading.

The first sentence in the initial comment is:
"We've had many user requests for a stable build of LibreOffice for the Android platform."

How is that sentence misleading? I believe it to be a statement of fact, supported by the links I provided. What, specifically, is misleading about it?

Is it your opinion that we *do not* want to work towards a stable build of LibreOffice for the Android platform?

This goal may require more than one bug/enhancement request to be submitted, but the work needs to start somewhere.

To answer another of your questions:

> And the title of this bug makes it sound as if all that's needed
> is just for builds to be provided.

Yes, that's all that needs to happen! It turns out that providing stable builds isn't something easy to do (per the devs), but that is all that this enhancement is requesting.

I keep on asking the same questions, and you keep marking this enhancement as RESOLVED INVALID instead of answering them. It's an awesome dance, but it's getting us nowhere, and it sends a message to everyone that you think that an Android build of LibreOffice is an INVALID enhancement for the project.

So I'll ask again: What would you (Tor) suggest we do differently here? Where should the enhancement request live? Do you suggest that we have no enhancement request for an Android build at all?
Comment 13 Don't use this account, use tml@iki.fi 2013-07-23 16:03:38 UTC
"requests for a stable build" sounds as if there already was an unstable build. While the truth is that we (for some value of "we") don't even have any clear idea, or at least no consensus, what kind of end-user Android app (or several apps) using LibreOffice code it is that we want.

Yes, I suggest we have no enhancement request for "an Android build" at all. It is not just a "build". It is (in my opinion) completely new software (from an end-user perspective), that happens to use the same library code as the desktop LibreOffice does.
Comment 14 Robinson Tryon (qubit) 2013-07-23 16:46:17 UTC
(In reply to comment #13)
> "requests for a stable build" sounds as if there already was an unstable
> build. 

Fair enough. I'd be happy to change the language, but I don't think that would resolve the issue...

> While the truth is that we (for some value of "we") don't even have
> any clear idea, or at least no consensus, what kind of end-user Android app
> (or several apps) using LibreOffice code it is that we want.

I don't think we need to make solid plans at this point in the process. My intention with this bug is to use it as a notification that it's something we're thinking about as a project, because so many users are asking for Android support.

If we want to do something specific, such as fix the .apk's so that our size is small enough to fit in the App store, then that can be a separate bug, and can be linked from here.

> Yes, I suggest we have no enhancement request for "an Android build" at all.
> It is not just a "build". It is (in my opinion) completely new software
> (from an end-user perspective), that happens to use the same library code as
> the desktop LibreOffice does.

From an end-user support perspective, we need to have a consistent message to tell to those who ask about Android support. IMHO it shouldn't be something nebulous like "read the developer list archives" -- I'd really like there to be some place (a URL) we can send users, either on Bugzilla or the wiki or the website where they can read the current status of LibreOffice on Android.

If our plan is to consider LO on Android an entirely new piece of software, then I think we should tell our users that. Perhaps that message will also help to communicate the fact that it will be quite some time before we'll have something ready for them.
Comment 15 Michael Meeks 2013-07-24 10:59:31 UTC
I'll re-open this as a valid enhancement and raise it's priority [ though that will have exactly zero impact on resource allocation ;-], ie. I think you're right Robinson :-) having said that - I'm completely with Tor on not wanting to be hassled about progress / status here - this is a volunteer / spare-time project - and communicating around it only sucks up very scarce resource that would be better applied on improving the features; so I'll drop Tor from the CC.

Anyhow - thanks so much Robinson for the awesome work you do on the Ask site (and elsewhere), and we're well aware of the pressure / feedback from users to support this platform - and it's not just users that are frustrated, developers are too :-)

Hopefully as/when there is some user-usable progress and/or we have a build that needs user testing rather than users contributing patches ;-) I'll update this bug. Naturally, anyone that can be encouraged to hack on this with us is much appreciated !

Thanks !
Comment 16 Anzhel Bozhinov 2013-09-20 22:38:56 UTC
What about In-App Purchase for LibreOffice Impress Remote as donation for acceleration LOforAndroid development?
Comment 17 definesinsanity 2013-11-01 18:35:23 UTC
As of version 4.4, Android now has printing support. That pretty much means that Android is now a general purpose operating system with which you can do pretty much everything, except, of course, word processing and spreadsheets.

IMO, Android support should be absolutely first priority for libreoffice, above everything else.
Comment 18 Robinson Tryon (qubit) 2015-01-21 17:33:50 UTC
(In reply to Robinson Tryon (qubit) from comment #0)
> We've had many user requests for a stable build of LibreOffice for the
> Android platform.

A beta of the Android Viewer is now available on the Google Play store:
http://tdf.io/androidviewer
https://wiki.documentfoundation.org/Android

This is just a viewer, and it has some quirks and rough edges (it's a beta!), but it's a big step on the road towards LibreOffice read/write support on Android!

For all of you who have been cc'd on the bug, waiting for updates, please go check out the latest builds and give us feedback and bug reports. (Bug reports can be filed here in Bugzilla using the 'Android Viewer' Component)

Thanks!
Comment 19 Jan Holesovsky 2015-01-26 10:54:50 UTC
Let's close this bug now, the viewer is available here now:

https://play.google.com/store/apps/details?id=com.collabora.libreoffice

For the follow-up problems, please file bugs against the "Android Viewer" compontent.  Thank you!
Comment 20 Robinson Tryon (qubit) 2015-01-26 11:06:08 UTC
(In reply to Jan Holesovsky from comment #19)
> Let's close this bug now, the viewer is available here now:
> 
> https://play.google.com/store/apps/details?id=com.collabora.libreoffice

Awesome! Thanks, Kendy!

> For the follow-up problems, please file bugs against the "Android Viewer"
> compontent.  Thank you!

I'm sure that this will set loose the floodgates with tons of new bug reports, and we're excited to see them, so everyone who reads this, please remember:

ALL: Please make sure to describe only ONE bug or problem per report

(This will make things MUCH easier for QA and the Devs :-)
Comment 21 Edmund Laugasson 2015-05-23 17:31:18 UTC
I would expect the same functionality as the desktop version has - also editing functionality. The viewer on Android is certainly very awaited.

Good solution is https://www.rollapp.com/search?query=libreoffice - there is possibility also connect cloud storages even there are ownCloud, Mega Sync missing but the idea is great. Storage space is always problematic and competing with cloud storage service providers is pointless and offering connection with them would be very appreciated.

Also connecting regular network protocols is appreciated: SSH, FTP, WebDAV, Samba, etc - that functionality should be available already when using LibreOffice dialogs and the "Servers" button.

This means that having cloud version would be possible to use it as web-based office suite not only Android but also other platforms until there will be native versions for all these platforms.

But even on these native versions would be cloud storage connectivity appreciated. Currently the LibreOffice Viewer can open only local files but usually there are no local files at the smartphone or tablet. There is possible to use Android ability to use cloud clients and download files at first to device and then open. At least this should be happen automatically when opening file over cloud storage like in PC.