Bug 60870 - EDITING: Spell Check custom dictionary not recognized?
Summary: EDITING: Spell Check custom dictionary not recognized?
Status: RESOLVED DUPLICATE of bug 60833
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.3 release
Hardware: Other All
: highest normal
Assignee: Andras Timar
URL:
Whiteboard: BSA Confirmed:4.2.0.0.beta2:Ubuntu
Keywords: bibisectRequest, regression
: 58783 (view as bug list)
Depends on:
Blocks: mab4.2
  Show dependency treegraph
 
Reported: 2013-02-15 03:05 UTC by Michael Ragsdale
Modified: 2015-12-17 07:11 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
Test document. Steps are inside. (12.95 KB, application/vnd.oasis.opendocument.text)
2013-02-15 16:26 UTC, Petr Mladek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Ragsdale 2013-02-15 03:05:36 UTC
Problem description: When adding custom words to the Dictionary (people's names, in my documents so far), the Spell Checker seems to "forget" these custom words when you relaunch LibreOffice, until you run Spell Check again

Steps to reproduce:
1. Type a misspelled word intentionally
2. Add it to the custom dictionary (right click word and select Add)
3. close LibreOffice.  It does not matter if the quickstarter is closed or not
4. reopen LibreOffice, and reopen the document you were working on

Current behavior: Misspelled words that you Added to the custom dictionary are flagged as misspelled.  If you run the spell checker, or select one of the misspelled words (it does not matter which word - and there can be more than one of the same and/or different words, or there could be just a single word), the spell checker seems to remember that you added those words to the Custom dictionary.

Expected behavior:

              
Operating System: Windows 8
Version: 4.0.0.3 release
Last worked in: 3.6.5.2 release
Comment 1 Michael Ragsdale 2013-02-15 03:08:42 UTC
Oops, hit the Submit button too soon.

Current Behavior, Continued: Every time you launch LibreOffice, these words will be flagged again, and you will need to rerun spell check, or right click a word and choose Add again.  When you do these, the Spell Checker will "remember" the Custom dictionary, and all custom words will be un-flagged.

Expected Behavior: Words added to the Custom dictionary should not be flagged as misspelled
Comment 2 Thomas van der Meulen 2013-02-15 09:09:37 UTC
*** Bug 58783 has been marked as a duplicate of this bug. ***
Comment 3 Thomas van der Meulen 2013-02-15 09:10:28 UTC
Thank you for reporting this bug,
I can reproduce this bug running LibreOffice 4.0.0.3 on Windows 7.
Comment 4 Petr Mladek 2013-02-15 16:26:43 UTC
Created attachment 74879 [details]
Test document. Steps are inside.
Comment 5 Petr Mladek 2013-02-15 16:30:46 UTC
It seems to be a regression against LO 3.4.

I see the problem also with LibreOffice 3.6.5.2, and 3.5.6.2.  It works fine with 3.4.6. I tested it with the official Linux build on SLED11-SP2, x86_64 with the above attached test document.
Comment 6 Michael Ragsdale 2013-02-15 18:37:05 UTC
Thanks for updating the version information.  My guess is that, through the life of 3.5.x / 3.6.x, I never added custom words to the Dictionary - and thus never saw it creep up until 4.0.0.3.

I'm using Windows 8 Pro 64-bit when I came across the bug
Comment 7 Caolán McNamara 2013-02-18 10:47:45 UTC
I think this is something like this user defined dictionary isn't stored (for some currently unknown reason) as an "active" dictionary, so its disabled when you restart LibO.
Comment 8 Robinson Tryon (qubit) 2013-10-23 16:49:29 UTC
Removing comma from whiteboard (please use a space to delimit values in this field)
https://wiki.documentfoundation.org/QA/Bugzilla/Fields/Whiteboard#Getting_Started
Comment 9 Joel Madero 2013-10-29 19:59:00 UTC
Interesting - this doesn't happen for me:

Ubuntu 13.10
LibreOffice 4.1.2.3 release

Used the test case and it was fine - locale issue?
Comment 10 Robinson Tryon (qubit) 2013-12-14 17:00:55 UTC
CONFIRMED LO 4.2.0.0.beta2 + Ubuntu 12.04.3

(In reply to comment #0)
> Steps to reproduce:

Step 0.

Open a new document in Writer.

> 1. Type a misspelled word intentionally

colonelqubit
qubit

> 2. Add it to the custom dictionary (right click word and select Add)

Right click on word -> Add to Dictionary

2b) Save the document as "test-spell-check-dictionary.odt"

> 3. close LibreOffice.  It does not matter if the quickstarter is closed or
> not
> 4. reopen LibreOffice, and reopen the document you were working on

yep

> 
> Current behavior: Misspelled words that you Added to the custom dictionary
> are flagged as misspelled. 

yes

> If you run the spell checker, or select one of
> the misspelled words (it does not matter which word - and there can be more
> than one of the same and/or different words, or there could be just a single
> word), the spell checker seems to remember that you added those words to the
> Custom dictionary.

To be more clear, if you merely Right Click on one of the red-underlined words that you previously added (and then left-click elsewhere), then ALL of the red-underlined, previously-added words will lose their red underline

Re: spell checker
Yes, merely launching the spell checker (Tools -> Spelling and Grammar) seems to have the desired effect.
Comment 11 Björn Michaelsen 2014-01-17 09:40:33 UTC
(This is an automated message.)

Setting priority to highest as this is a 4.2 MAB. This is part of an effort to make the importance of MAB reflected in priority too.
Comment 12 Tom Colley 2014-02-20 02:06:01 UTC
A solution/workaround for this seems to have been identified for an earlier version of Libreoffice: see Bug 52176, Comments 7,8 and 9.
Comment 13 Mike Kaganski 2014-02-21 10:57:19 UTC
Another 4.2 MAB filed against 3.x?
Comment 14 Andras Timar 2014-03-07 10:54:43 UTC

*** This bug has been marked as a duplicate of bug 60833 ***
Comment 15 Robinson Tryon (qubit) 2015-12-17 07:11:53 UTC
Migrating Whiteboard tags to Keywords: (bibisectrequest)
[NinjaEdit]