Bug Hunting Session
Bug 60833 - EDITING: Terms added to dictionary are lost between editing sessions
Summary: EDITING: Terms added to dictionary are lost between editing sessions
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.6.3.2 release
Hardware: Other Linux (All)
: medium normal
Assignee: Andras Timar
URL:
Whiteboard: BSA target:4.3.0 target:4.1.6 target:...
Keywords:
: 60870 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-02-14 11:05 UTC by Michal Svec
Modified: 2015-09-21 12:18 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michal Svec 2013-02-14 11:05:33 UTC
Problem description:

Adding an unknown word to the dictionary does not persist between LO close/open.

Steps to reproduce:
1. Right-click on unknown word, Add-to dictionary
2. Exit
3. Reopen the deocument

Operating System: openSUSE
Version: 3.6.3.2 release
Comment 1 blubb 2013-03-23 18:57:00 UTC
Tried to save any word in the dictionary of writer, calc, impress. After closing and reopening it, it didn't remember any new word anymore. Tested it on 4.0.3+ and 4.0.0.3
Comment 2 Owen Genat (retired) 2013-12-14 09:15:07 UTC
Edited summary for clarity.
Comment 3 Andras Timar 2014-03-07 10:30:34 UTC
It is a regression from 3.4 to 3.5 caused by d4859a3a976801b33804611b0d911c47c32d17ff
Comment 4 Commit Notification 2014-03-07 10:36:13 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=82ff9ec5935fd5647cb39ae5a85565f4260b0212

fdo#60833 user's wordbook should be selected by default



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 Andras Timar 2014-03-07 10:54:43 UTC
*** Bug 60870 has been marked as a duplicate of this bug. ***
Comment 6 Commit Notification 2014-03-07 11:07:15 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7f98508ec2d20042725790468c5fc39a19c6ecec&h=libreoffice-4-1

fdo#60833 user's wordbook should be selected by default


It will be available in LibreOffice 4.1.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2014-03-07 11:15:51 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=385c54367fe1f7453ff9127de79251deaf28cdee&h=libreoffice-4-2

fdo#60833 user's wordbook should be selected by default


It will be available in LibreOffice 4.2.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 Simon Dedman 2015-09-21 12:18:11 UTC
I've just experienced, this new install from Fresh PPA (5.0.1 build). Adding one word to dictionary, exiting, reopening. Works.
Two words: not saved.
Opening the customdic file (after 1 word, 2 words) means upon reopening LO none are saved.
Copying the customdic does the same thing.
Pasting in word lists from MS office custom dic does the same.